LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   HELP!!, Can't login anymore because I screwed up network config (https://www.linuxquestions.org/questions/linux-newbie-8/help-cant-login-anymore-because-i-screwed-up-network-config-72471/)

ern_day 07-13-2003 11:45 PM

HELP!!, Can't login anymore because I screwed up network config
 
I run a dual boot machine, Windows ME and Redhat Linux 7.1 (Seawolf). I run KDE as the desktop in Linux.

I was in the Network Config tool, and accidently chaged the host and domain names and saved the changes. They were originally set to localhost and localhost.localdomain respectively. I was attempting to set it up to work with my DSL account, but apparently I didn't know what I was doing. I set the host name to "same" and the domain name to my DSL provider.

Now when Linux is booting up it recognizes "same" as a bad host name, but once it goes through the standard boot procedure it does the following:

same login:

blank screen

I was wondering if there is anything I can do to reset the network config back to the defaults, without reinstalling and losing everything (files,mysql,etc) that are important and already there.

Please help!!! Any advice is much appreciated

Best regards,

ern_day

Dark_Helmet 07-13-2003 11:54 PM

Download a rescue distribution. I use Knoppix. It's overkill for a "rescue" disk, but it serves the purpose.

When it boots, right-click on the drive and partition that has your hosts configuration file. Select to change its read/write mode (Knoppix defaults to read-only). Then left click the same icon to mount the drive. Then edit the file with any of the editors Knoppix includes.

Red Hat has a special way of setting up the hostname that I don't remember off-hand.

ksgill 07-14-2003 12:18 AM

what you should do is edit the /etc/resolv.conf file and there you can specify your domain name and domain server. Add something like this to it and save the file:
search Domain_name
nameserver XXX.XXX.XXXXX
nameserver YYY.YYY.YYY.YY
ofcourse you should put the correct values in it. Then try to reconfigure/reboot the machine. Hope it helps

ksgill 07-14-2003 12:21 AM

I also recommend upgrading the the most recent version of redhat. It automatically configures network (if you are a newbie)

MasterC 07-14-2003 02:04 AM

Whoa! I don't think anything so drastic has happened? Or am I reading it all wrong? To me it just sounds like instead of the usual login prompt he's getting "same" as the name of box, no big deal right?

Open up your /etc/hosts and post up the contents. Also in RedHat is seems like there is an /etc/sysconfig/hostname or similar file/directory where this is changed. If you find something along those lines, post that up as well.

Also, look at:
uname -a
And you should see "name" there now, where before it said localhost. Still... no biggie.

What you are seeing as the blank space is exactly that, a login prompt with a blank space. Login as root:
root
And enter root's password:
Password: ******
And then you can use:
startx
To get into a gui, and post up the information I am requesting.

Again, if I am reading this all wrong, my appologies.

Cool

Dark_Helmet 07-14-2003 02:16 AM

Yeah, you're probably right MasterC. When he said "blank screen" I took it to mean the login prompt displayed, but then disappeared; giving a truly blank screen.

Quite a different story if it's actually displaying a login prompt vs. all black.


All times are GMT -5. The time now is 04:45 AM.