LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-24-2006, 02:10 AM   #1
madagascar2k
LQ Newbie
 
Registered: Mar 2006
Posts: 2

Rep: Reputation: 0
help cannot ping to sites but can browse :(


i have just installed my squid with http_port 192.168.0.1:3128 and my clients are 192.168.0.0/24. i have started my squid successfully and all works well.

When i browse on my client pc i can browse to any site like google.com or yahoo.com all works well with browsing but in the client pc i cannot ping google.com or yahoo.com or any site it tells me "Unknown host google.com". Meaning i can browse in the client pc google.com but i cannot ping google.com it tells me "unknown host google.com". I don't understand what is happenning. Can anybody please help me with this pleaassse. any idea or suggestions would mean so much to me. thanks very much. i'm just new in linux admin.
 
Old 03-24-2006, 02:21 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
When you direct your request to squid, the server resolves the host
name for you? What's the resolv.conf on the client(s)?


Cheers,
Tink
 
Old 03-24-2006, 02:32 AM   #3
madagascar2k
LQ Newbie
 
Registered: Mar 2006
Posts: 2

Original Poster
Rep: Reputation: 0
the resolv.conf of the client has only this
statement

nameserver 192.168.0.1

thanx
 
Old 03-24-2006, 02:37 AM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
And does that machine actually run bind, too?
If it doesn't, try to add the same nameserver that
the actual server uses ...


Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot browse the inernet sites in fc2 shams Linux - Networking 1 10-18-2004 05:09 AM
Can browse, Can't ping! cyent Linux - Networking 2 05-11-2004 07:41 PM
HELP!! can ping but cant browse fooforon Linux - Networking 5 09-03-2003 09:52 PM
Can ping but cannot browse placeb0 Linux - Networking 2 08-29-2003 07:16 AM
Unable to Browse Sites tanmay_79 Linux - Networking 1 09-05-2002 03:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration