LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Help... (https://www.linuxquestions.org/questions/linux-newbie-8/help-109253/)

.::Jo3king::. 10-27-2003 06:55 PM

Help...
 
Right...

I am completely new to linux and wanted to give it a go...

I have just installed a complete fresh copy of Red Hat 9.0, the installation went fine...

So i am now running a system with windows XP and RH9.0

So... I started RH and everthing started to load up (all the green OKs and stuff) but then i get the error message 'Id "x" respawning too fast: disable for 5 minutes'. This message keeps repeating itself as many others have said.

So I check out the forums (and cant make a damn bit of sense out of any of it) and notice people having trouble to do with Geforce graphics cards... I have a Geforce 2 MX.

So... I've worked out how to log in in text mode as root, but dont know commands to run anything or download drivers etc...

What I really need is a step by step guide as of what to do! I hope this isn't a lot of work... but it would be greatly appreciated! Thanks!

Joe

Peacedog 10-27-2003 07:03 PM

hi .::Jo3king::. here ar a couple of links that should help.

http://www.google.com/linux
http://www.linux.org/
http://linux.ctyme.com/
http://sourceforge.net/
http://www.onlamp.com/linux/cmd/
(i found this thru a forum search here at linux general)

hope this helps, post any success. good luck.

.::Jo3king::. 10-27-2003 07:04 PM

Cheers Peacedog! Will do!

Peacedog 10-27-2003 07:09 PM

on another note,

Quote:

i get the error message 'Id "x" respawning too fast: disable for 5 minutes'
i'm guessing, but, it sounds like you have the wrong refresh rate. if it were me, i'd look into refresh rates w/ my monitor and possibly driver issues w/ my video card. good luck.

wahwah 10-27-2003 07:10 PM

Hi,

I also had trouble with my NVidia GeForce card (a GeForce4 MX 440 on SuSE 8.2). I got it working OK after some trouble.
I'm also quite new to Linux, but maybe I can help with the things I've learned so far... basic console commands, the etc/modules.conf file, runlevels etcetera. I prefer to do that tomorrow though (bedtime for me).
Can you communicate with icq? I can also read those on my work if it's not taking up all of my time :-))
Just let me know - my icq no is 3821806
Otherwise I'll check this forum every now&then
Bye

.::Jo3king::. 10-27-2003 07:15 PM

Well I'm on MSN... Not ICQ

All help is appreciated, but i really could do with something step by step...

And looking at those guides its still pretty complex... i dont have a clue what i'm looking for...

My friend installed his exactly the same as me and he could just boot straight into linux after installing... Ooh... the envy :-)

Peacedog 10-27-2003 07:32 PM

a full set of specs would be more useful. anything fom the mobo to the exact video card and monitor your using. there will be someone here at this forum that can help you. check out the links i gave you and do a little research. i am certain of one thing the answer is out there. and

Quote:

My friend installed his exactly the same as me and he could just boot straight into linux after installing... Ooh... the envy :-)
he didn't learn anything from that experience. you have an opportunity to learn a great deal about your system here. it's just an opinion, but, learning is my goal here. the more problems i encounter, the more research i have to do, the more i learn. it's all about perspective.

.::Jo3king::. 10-27-2003 09:03 PM

Ok! I never thought of it like that!

I'll learn as much as i can... but for the moment i cant even see what i'm doing!

My Video card is a standard GeForce 2 MX
spec:
Memory Interface: 64/128-bit SDR, 64-bit DDR
Texels per Second: 700 Million
Memory Bandwidth: 2.7GB/s

I dont have a clue about my monitor... its just a stardard plug and play as far as i know... How can i find out?

.::Jo3king::. 10-28-2003 11:35 AM

*bump*

Please help guys... I'm really stumped!

Bruce Hill 10-28-2003 12:23 PM

Start here -> http://www.nvidia.com/object/linux.html
They have an easy to install video driver. You still haven't given quite enough information to determine which driver you need, but I think it't this one:
http://www.nvidia.com/object/linux_d..._1.0-4496.html
You can look in their readme file to see if your driver is listed. If you get the correct one and follow the steps as Nvidia laid them out, I think you can install it. If not, they have a forum at Nvidia, also. They are going all out to support Linux.

.::Jo3king::. 10-28-2003 05:03 PM

Do i need to download it while booted into linux? How do i do that? And then how do i install it?

Bruce Hill 10-28-2003 06:23 PM

are you joking?
 
Quote:

Originally posted by .::Jo3king::.
Do i need to download it while booted into linux? How do i do that? And then how do i install it?
Yes, you need to download it while booted into Linux. Unless you want to try to install it while booted into some other system. Do you need it for Windoze XP of for DeadRat 9.0?

I built a comp for my wife and daughter last month. It's running with Debian installed to the hard drive with the Knoppix v3.3 Live CD. I put a Nvidia video card in it, and got the drivers installed okay. I'm a newbie, too. I'll be glad to help you, if you're willing to read :study: If you're not willing to read and try to do something for yourself, you won't get anywhere at LQ. There are two kinds of posts here: one, is from the guy who knows what he's doing and gives you the advice that's proven to work; the other is from someone who has time on their hands, wants to help everyone else, but really doesn't have a clue what's up. If you're willing to read the first type of guy will usually answer your post. If not, the second type is more likely to throw something on the wall and see if it will stick. More times than not, when you follow that advice, something breaks ;)

First, you haven't posted what PEACEDOG asked for, or he may have solved your problem by now. Post your motherboard, video card, and monitor with results like this example:

Asus A7V8X-X
Nvidia GeForce4 MX440-8X
Philips LCD 150B4

If you have a computer you bought from a store, did they give you any manuals, or at least some type of box with some stuff in it? If they did, then look through that for those answers.

If there's no booklet or paperwork about the motherboard, the only way I know you can get that is by taking the left side off the case and looking directly on the motherboard. If that's your only option, forget it. We can install a video card without that information.

The monitor information you should be able to find by looking on the back of the monitor. It will have a sticker with some information. All we need is the company and the model number, if that's available.

The video card can be obtained while you're running Windblows - you are reading this in Windoze eXperience aren't you? Do you see the little keys with the Windoze logos on your keyboard? One is between the Ctrl and Alt keys on the bottom left, and the other is between the Alt and the Menu key on the bottom right. And do you see the Pause/Break key at the very top right of your keyboard? Good. Press one of the Windoze logo keys and then press the Pause/Break key. (NB: You must do this quickly, or the Start menu will appear. If that happens, release the little Windoze logo key and try again. If you receive a message something like this:

Your mouse has moved, Windows must restart

you'll remember why you're trying Linux.

Now, that will open a dialog box with the title System Properties. In there you will see some tabs, and I believe there is one that says Device Manager (no Windoze XP on these comps, so it's from memory). If not, is there one that says something about Hardware? Whenever you get there, you will see a list of things with a + sign in front of them. If any of them isn't installed correctly, you'll see something like a big yellow ? or a yellow triangle with a ! inside it, or something like that. I'm getting weaned off Micro$loth. Left-click on the arrow in front of the listing that says Display Adapter and this will tell you what video card you have.

Write down this information, because when we try to help you we don't find

Quote:

a standard GeForce 2 MX
monitor... its just a stardard plug and play as far as i know...



And then go to the link I gave you http://www.nvidia.com/object/linux_...2_1.0-4496.html and read what's on that page, plus, click on all the little blue link lines in there and read what's in them. You will find a file which has the video cards listed in it. It's a blue one that says Text Version. Inside there under APPENDIX A: SUPPORTED NVIDIA GRAPHICS CHIPS they tell you which ones are supported (there is no standard GeForce 2 MX) and how to determine (from within your Linux system) which chipset you have.

Okay, Sherlock - happy investigating. If you can do the above, you can probably install the driver by yourself :D If not, post back, and I'll help you if someone else doesn't get to you first. I'm off to install my freshly compiled kernel :cool:

.::Jo3king::. 10-29-2003 01:24 PM

Right, thanks for the detailed post, here goes:

Video card:
It says "Geforce 2 MX" in my device manager.
I've looked ath that readme and the coices are:
o GeForce2 MX/MX 400 0x0110
o GeForce2 MX 100/200 0x0111
o GeForce2 Go 0x0112
The top one is mine.
I have located the drivers i need: http://download.nvidia.com/XFree86/L...-4496-pkg2.run
I think those are right.
I dont know how to download the files in text mode and install them either...


Monitor:
What I can find on the back is:
Product No.: EM-151
Product Series: IZ-558
Model: 558
100-240V - 50-60hz 1.5a
(The manual says different. I think I've got the wrong manual.)


MotherBoard:
I really cant find this anywhere. If need be I will take off the side, but I'd rather not, its quite a lot of work cos i'm in such a mess...

Bruce Hill 10-29-2003 06:29 PM

Quote:

Originally posted by .::Jo3king::.
Right, thanks for the detailed post, here goes:

Video card:
It says "Geforce 2 MX" in my device manager.
I've looked ath that readme and the coices are:
o GeForce2 MX/MX 400 0x0110
o GeForce2 MX 100/200 0x0111
o GeForce2 Go 0x0112
The top one is mine.
I have located the drivers i need: http://download.nvidia.com/XFree86/L...-4496-pkg2.run
I think those are right.
I dont know how to download the files in text mode and install them either...

Not a problem. You get the driver like this. You say you know how to login in text mode as root. Okay, when you're at the root prompt # type pwd to determine your present working directory. If it's not /home/<user> then you should do # cd /home/<user> with the <user> being your user name. For me, that would look like this: paul:/home/mingdao# but I am on a Debian box and not RedHat, so yours may be slightly different. The computer name is paul, and my user name is mingdao. The # sign in a bash shell represents the superuser.

Once you do that, then just type
# wget http://download.nvidia.com/XFree86/L...-4496-pkg2.run and it will go to the Nvidia site and download the driver into your pwd. That's the easy part :D NB: You must type the full address totally correct to the Nvidia driver. LQ doesn't display it all, just so you'll know that you can't have any elipses (...) with anything left out of the address line.


Quote:

Monitor:
What I can find on the back is:
Product No.: EM-151
Product Series: IZ-558
Model: 558
100-240V - 50-60hz 1.5a
(The manual says different. I think I've got the wrong manual.)
Okay, I entered IZ-558 at www.google.com (Google is your friend :D) and this is the link http://www.yjfy.com/P/Preview/monitor/IZ-558.htm to your monitor's specs. Go there and print it, you'll need this later.


Quote:

MotherBoard:
I really cant find this anywhere. If need be I will take off the side, but I'd rather not, its quite a lot of work cos i'm in such a mess...

Joe,

I'd still like to know which motherboard you have just to be certain we get the right driver. Is there anyone you can call, say at the store where you bought this comp? If not, let's just go ahead with this, okay? One other question - how do you know that your card is the GeForce2 MX/MX 400 for certain? Did you do what Nvidia says to check your PCI ID?

Quote:

If you want to check your Device PCI IDs for comparison with the table
above, you can use either `cat /proc/pci` or `lspci -n`; in the later
case, look for the device with vendor id "10de", eg:

02:00.0 Class 0300:10de:0100 (rev 10)
If so, then you're okay.

From this point I think it would be best to just print the Readme file on the Nvidia site and follow the directions. That's what I did on my girls' comp with the Nvidia card, and it worked. The first time I tried it, I didn't follow everything verbose, but tried to download something a bit newer. Just do exactly what they say, and I think it will work perfectly. If not, post back. NB: While you are doing this, get a notebook, and write down everything that you do. If you do this, and something goes wrong, you'll have the exact step where the problem occured and it can easily be fixed. If you don't, and just post back something like it didn't work like they said it would and now all I've got is a black screen most people will ignore your post and just move on because there were no details to check where you made a mistake.

So, first print the file under Step 1 where it says README - Text Version ftp://download.nvidia.com/XFree86/Li...496/README.txt and do just that :D Keep it right there with you when you install the driver and you probably won't go wrong.

Next, download the driver as stated above.

Then, install it. And don't forget, our own MasterC has a post at http://www.linuxquestions.org/questi...threadid=71711 that explains Nvidia driver installation. This may be helpful, also. He really knows his stuff :cool:

Last, post back saying, "Thank God, that worked! I'm one step closer to being "Micro$loth FREE in 2003!"

.::Jo3king::. 10-29-2003 07:38 PM

OK! The downloading and installation of the drivers went smoothe... So i rebooted and got the same 'Id "x" respawning too fast: disable for 5 minutes' message. So I guessed... well thats okay... I just need to XF86Config!

So I looked at MasterC's FaQ, and try hard to follow it, but he has written it for someone who has access to a GUI by the looks of it... I have never even SEEN my GUI... So what do I do from here to edit my XF86Config file in just text mode?

Thanks again for your time and efforts!

Joe


All times are GMT -5. The time now is 05:04 AM.