LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-25-2010, 08:08 PM   #1
ciao303
Member
 
Registered: Jul 2010
Posts: 65

Rep: Reputation: 15
HDMI Support for Linux


Hi,

I have Ubuntu and Mint, how would I be able to to use HDMI vid/snd thru Linux???

Thanks
 
Old 09-25-2010, 09:26 PM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 19,094

Rep: Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379
Quote:
Originally Posted by ciao303 View Post
Hi,
I have Ubuntu and Mint, how would I be able to to use HDMI vid/snd thru Linux???
How can anyone give you any help, when you don't provide the details? What kind of hardware are you using? What are you plugging in to??
 
Old 09-25-2010, 11:18 PM   #3
ciao303
Member
 
Registered: Jul 2010
Posts: 65

Original Poster
Rep: Reputation: 15
Hardware list:

Acer 5251-1005 Laptop
AMD V120 2.2 GHz Processor
2 GB DDR3 RAM
ATI Mobility Radeon 4250 (up to 893MB HyperMemory)

Im plugging it into a Sony 40" 1080p LCD HDTV
 
Old 09-26-2010, 09:56 AM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 19,094

Rep: Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379
Quote:
Originally Posted by ciao303 View Post
Hardware list:

Acer 5251-1005 Laptop
AMD V120 2.2 GHz Processor
2 GB DDR3 RAM
ATI Mobility Radeon 4250 (up to 893MB HyperMemory)

Im plugging it into a Sony 40" 1080p LCD HDTV
Ok....Google turns up a link on how to address this:
http://wiki.archlinux.org/index.php/..._Does_Not_Work

Yes, it's for Arch linux, but the steps are the same for Ubuntu.
 
Old 09-27-2010, 09:27 PM   #5
ciao303
Member
 
Registered: Jul 2010
Posts: 65

Original Poster
Rep: Reputation: 15
odd...

when i did % aplay -l teriminal gave me this message:

bash: fg: %: no such job

what gives?
 
Old 09-28-2010, 10:22 AM   #6
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 19,094

Rep: Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379
Quote:
Originally Posted by ciao303 View Post
odd...

when i did % aplay -l teriminal gave me this message:
bash: fg: %: no such job
what gives?
You don't type in the "%"...that was the prompt on the example box.
 
Old 09-29-2010, 01:52 AM   #7
ciao303
Member
 
Registered: Jul 2010
Posts: 65

Original Poster
Rep: Reputation: 15
ok so this is what I came up with...

**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC272 Analog [ALC272 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0


whats next?
 
Old 09-29-2010, 07:57 AM   #8
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 19,094

Rep: Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379Reputation: 4379
Quote:
Originally Posted by ciao303 View Post
ok so this is what I came up with...

**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC272 Analog [ALC272 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0


whats next?
You follow the rest of the instructions in the link I sent you first. Play a test sound, and if it works, edit the file as instructed, and reboot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] no HDMI audio in Linux dimm0k Linux - Hardware 34 02-21-2012 08:30 PM
LXer: Using HDMI Audio/Video On Linux LXer Syndicated Linux News 0 12-10-2008 04:00 PM
LXer: Using HDMI Audio/Video On Linux LXer Syndicated Linux News 0 12-10-2008 11:40 AM
Asus M3A78-EMH HDMI SATA HD Support slac_usr2 Slackware 5 04-05-2008 01:12 AM
LXer: Using HDMI With ATI Linux Drivers LXer Syndicated Linux News 0 12-14-2007 12:30 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration