LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-08-2004, 01:33 PM   #1
mattuc
LQ Newbie
 
Registered: Apr 2004
Location: Portland, OR
Distribution: Red Hat 9
Posts: 21

Rep: Reputation: 15
HDD mounting problem


I'm new to Linux, running RH9, kernel 2.4.20-31.9
trying to mount an 80G Maxtor drive. model 6Y080L0
In secondary slave position, jumpered slave.
I'm trying to make one 80G fat32 LBA partition accessible from both Linux and Win98.
I partitioned this drive as Fat32 (LBA) w/ fdisk in Linux, formatted it in windows. Windows can read it, but scandisk found bad sectors which it supposedly fixed. made a directory in Linux (/mnt/d) but when I try to mount I get the error:
mount: wrong fs type, bad option, bad superblock on /dev/hdd1,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)
i ran fsck and got:
fsck 1.32 (09-Nov-2002)
e2fsck 1.32 (09-Nov-2002)
/dev/hdd: clean, 11/10010624 files, 314137/20010816 blocks
this would have found a bad superblock, correct?
I also tried deleting the partition and making and formatting a linux partition to see if it would mount that, but no luck there either. In fact, after formatting it in Linux and rebooting it doesn't recognize the partition table because fdisk -l shows this:
Disk /dev/hdd: 81.9 GB, 81964302336 bytes
16 heads, 63 sectors/track, 158816 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Disk /dev/hdd doesn't contain a valid partition table <<<

My BIOS is set to autodetect and chooses LBA by default, but if I change settings from autodetect to 'user' and let it auto detect the type it chooses CHS. I have no idea if that has anything to do with anything though.
Win98 has no trouble reading or writing to this drive, I just can't get it to mount in Linux. Other LBA drives and windows partitions mount fine, and I'm not mounting them all at the same time, so it shouldn't be a "too many mounted filesystems" problem.
Help?
 
Old 05-08-2004, 02:08 PM   #2
sharma_deepak83
LQ Newbie
 
Registered: May 2004
Location: India
Distribution: Red Hat, mandrake, Fedora,Knoppix
Posts: 27

Rep: Reputation: 15
Use vfat instead.

For mounting FAT32 u must have vfat module loaded into the kernel. use
"cat /proc/filesystems" and see that vfat is present or not. If it is not then u have to add it into the kernel by recompiling it. once the vfat added identify the partition to be loaded and add an entry in the /etc/fstab filesystem accordingly.

Happy Linuxing
 
Old 05-08-2004, 03:48 PM   #3
mattuc
LQ Newbie
 
Registered: Apr 2004
Location: Portland, OR
Distribution: Red Hat 9
Posts: 21

Original Poster
Rep: Reputation: 15
this is what i got. i don't know what the nodev thing means so I don't know how to read this. vfat is in there though.

$ cat /proc/filesystems
nodev rootfs
nodev bdev
nodev proc
nodev sockfs
nodev tmpfs
nodev shm
nodev pipefs
ext2
nodev ramfs
iso9660
nodev devpts
ext3
nodev usbdevfs
nodev usbfs
vfat
nodev autofs
 
Old 05-09-2004, 09:33 AM   #4
sharma_deepak83
LQ Newbie
 
Registered: May 2004
Location: India
Distribution: Red Hat, mandrake, Fedora,Knoppix
Posts: 27

Rep: Reputation: 15
Good just mount it brother !!! using the mount command just like this...

mount -t vfat [partition] [directory-to-mount]

and want to do it every time the computer boots up. Just add the entries in the /etc/fstab file. Us "fdisk -l" command to see the partitions and there corressponding dev entries...

Happy Linuxing
 
Old 05-09-2004, 12:38 PM   #5
mattuc
LQ Newbie
 
Registered: Apr 2004
Location: Portland, OR
Distribution: Red Hat 9
Posts: 21

Original Poster
Rep: Reputation: 15
I still get this:

# mount -t vfat /dev/hdc1 /mnt/d
mount: wrong fs type, bad option, bad superblock on /dev/hdc1,
or too many mounted file systems
(could this be the IDE device where you in fact use
ide-scsi so that sr0 or sda or so is needed?)

???
 
Old 05-09-2004, 12:48 PM   #6
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
First see if Linux actually sees it. With the command run as root: fdisk -l
If you see the partition you want to mount, it is ok. (it's not hda, but some other like hdc, hdd, hd...) Mount it!

If it says it is already mounted. Run command mount with no arguments. That will show you all the mounted stuff on your computer and where they are mounted. That way you can see if and where it is.

If you can't see it with fdisk -l then there is something wrong with connecting the harddisk to your computer. Check that out.

Just curious. Is it possible to make a 80GB FAT partition? In windows the biggest I could get was 32768 MB.
 
Old 05-09-2004, 04:37 PM   #7
mattuc
LQ Newbie
 
Registered: Apr 2004
Location: Portland, OR
Distribution: Red Hat 9
Posts: 21

Original Poster
Rep: Reputation: 15
it shows up fine with fdisk -l :

Disk /dev/hdc: 81.9 GB, 81964302336 bytes
16 heads, 63 sectors/track, 158816 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/hdc1 1 158816 80043232+ c Win95 FAT32 (LBA)

but it still won't mount. Windows reads the 80G partition so I don't think that's the problem, but maybe I'll try redoing it with 3 smaller partitions to see if that helps at all.
 
Old 05-10-2004, 07:26 AM   #8
sharma_deepak83
LQ Newbie
 
Registered: May 2004
Location: India
Distribution: Red Hat, mandrake, Fedora,Knoppix
Posts: 27

Rep: Reputation: 15
try insmod vfat
and then mount -o loop -t vfat /dev/hdc1 /mnt/d
 
Old 05-10-2004, 10:50 PM   #9
mattuc
LQ Newbie
 
Registered: Apr 2004
Location: Portland, OR
Distribution: Red Hat 9
Posts: 21

Original Poster
Rep: Reputation: 15
still nada.

# mount -o loop -t vfat /dev/hdc1 /mnt/d
mount: wrong fs type, bad option, bad superblock on /dev/loop0,
or too many mounted file systems

thanks for all of this help. any other thoughts?
 
Old 05-11-2004, 12:46 AM   #10
mattuc
LQ Newbie
 
Registered: Apr 2004
Location: Portland, OR
Distribution: Red Hat 9
Posts: 21

Original Poster
Rep: Reputation: 15
btw, i also tried splitting it into 3 small partitions and i get the same error. bad option, bad superblock, etc.
 
Old 05-11-2004, 01:14 PM   #11
mattuc
LQ Newbie
 
Registered: Apr 2004
Location: Portland, OR
Distribution: Red Hat 9
Posts: 21

Original Poster
Rep: Reputation: 15
I have a bad drive. I decided to try partitioning and formatting it entirely in Windows since that's how I did my other drives and they work, and Partition Magic immediately found errors in the partition table. it kept saying that the LBA and CHS blocks didn't match up and that they should have the same values and then it claimed to have fixed them, but when I tried to format the disk it just paused for a second then marked it BAD and wouldn't do anything else with it.
Never never NEVER buy anything from COMPUVEST.COM, that's the second bad drive they sent me, and they sent me bad memory. Nothing I've ordered from them has ever worked and their return policies make it expensive and near impossible to exchange anything. I got charged shipping for that drive 3 times. compuvest sucks, tell your friends.

Last edited by mattuc; 05-11-2004 at 01:15 PM.
 
Old 05-11-2004, 01:47 PM   #12
sharma_deepak83
LQ Newbie
 
Registered: May 2004
Location: India
Distribution: Red Hat, mandrake, Fedora,Knoppix
Posts: 27

Rep: Reputation: 15
try mount /dev/hdc* [mount-directory]

Try to send me ur partition table ( by just copying the output of fdisk -l ). Anyways
try mount /dev/hdc* [mount-directory]
Do u recieve the same message when u try to mount other partitions
 
Old 05-11-2004, 09:55 PM   #13
mattuc
LQ Newbie
 
Registered: Apr 2004
Location: Portland, OR
Distribution: Red Hat 9
Posts: 21

Original Poster
Rep: Reputation: 15
the output of fdisk -l

Disk /dev/hdc: 81.9 GB, 81964302336 bytes
16 heads, 63 sectors/track, 158816 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

Device Boot Start End Blocks Id System
/dev/hdc1 1 158816 80043232+ c Win95 FAT32 (LBA)

(i repartitioned to one 80G again since the 3 smaller ones didn't work, have to go back to Win98 to format before I can try to mount again...)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mounting HDD HELP!!! westverg Ubuntu 3 07-05-2005 06:12 PM
HELP!!! I have a problem mounting my SATA ntfs HDD patatoemasher Debian 3 06-25-2005 06:05 AM
Firewire hdd: mounting problem Ungluun Slackware 8 07-15-2004 10:13 AM
Mounting HDD vs. Mounting Filesystem snailophone Linux - Hardware 4 08-12-2003 11:00 AM
Problem with mounting second hdd. Neo22589 Linux - Hardware 6 03-08-2003 02:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration