-   Linux - Newbie (
-   -   Having trouble with my printer... (

trist007 02-27-2009 09:12 PM

Having trouble with my printer...
I have a Slackware 12.0 box. I also have a local via usb HP Desktop D1455. I run Settings-Printers on the gui Desktop. I select CUPS as the service. I select my brand and model. I setup the settings for legal paper. Then I click TEST for the test page, it prompts for a password, I tried both my user and the password and root and the root's password and neither worked. So instead of inputing another user name and password I hit cancel. I get a message saying the test page printed successfully even though it did not. I then get another notice labeled Catastrophe. Here's a pic of the notice. I then click ok and then cancel the user name and password again and then I get another notice saying that it was unable to remove printer.

Any ideas?

jdkaye 02-27-2009 10:38 PM

It's a bit strange you got that far. On my system at least, you can only add printers as root ordinary users can't do this. When I open the printer manager the first thing I have to do is click on "Administrator Mode" button. Have you tried doing it that way?

trist007 02-27-2009 10:49 PM

It's weird, when I click on administrator mode, I put in the correct root password, but kernel says it's not the right one. Really odd. So I login to the desktop as root. I open up printers, add a printer, and again, the same error in that picture pops up. I've been using Slackware 12.0 for about 6 months and I love it. I've gotten to know how to do everything. Getting really proficient with the distro. The only thing that is really left is to be able to print, which would be great.

trist007 02-28-2009 02:37 AM

I went to OpenPrinting and downloaded the file. I ran it, chmod 755 rc.cups, started cups, opened a browser and went to localhost:631, added printer via the ppd and it was added. It was all green, no red spots hehe. I hit print test page and this error returned

"Unable to start filter "foomatic-rip-hplip" - No such file or directory."

So I ran the file. However, I'm confused. I'm running Slackware and none of the distro options are anything close to Slax. So I tried them all and none of them worked.

What should I do?

trist007 02-28-2009 10:31 PM


jdkaye 02-28-2009 11:50 PM

As you see I'm running debian so I can't really help you on slack-specific issues. Maybe try a more slack oriented forum than this one. There's the Slackware forum under Linux-Distributions.

H_TeXMeX_H 03-01-2009 04:04 AM

The way I always setup my printer is go to:

Then for an HP printer pick the option with the printer serial number in it.

All times are GMT -5. The time now is 12:02 PM.