-   Linux - Newbie (
-   -   Having a problem with DAT /dev/st0 SCO/SUSI (

sjpiv44 02-11-2008 11:02 AM

Having a problem with DAT /dev/st0 SCO/SUSI
Using a DAT tap drive, I did a, tar cvf /dev/st0 filename.tar /filepro/*, to pick up the data from the SCO system. I can do a tar tvf /dev/st0 and see the data.

When I move the tapedeck to the SUSE system, it seemed to see it as we booted up. When I tar tvf /dev/st0, the light on the tape drive indicates it is being accessed but It gives me a read error. If you need more info, I will be to site and replicate.

I the device st0 have parameters that can be set or changesed?

This worked at one time. We can figure out, one, why the SCO dev /rct0, which worked using the filePro backup to rct0. Now the SCO system is seeing the DAT as st0.

On the SUSE system, we get the following:
tar: Can not read input/output error
tar: at the begining fo tape, quitting now
tar: error is not recoverable.

Need some help ! ! !

Thanks in advance for your help.

Jack Privitt, IT
Up & Running Arkansas

ravibhure 02-21-2008 03:45 AM

Hello sjpiv44,
It's to complicated & such hard situation to find out and recover your Input/Output error, but there are some command that getting you some results.
first off all you have to go using following steps

$ mt -f /dev/st0 status
$ mt -f /dev/st0 setblk 0
$ tar tvf /dev/st0
Now you will see table of content of your data. setting your block size to zero.

sjpiv44 04-08-2008 04:31 PM

Below is a show if each command.

Below is a copy if the results of, 1st, status and the view of tape inventory.
After the first of 1st of 4 tapes, the flowwing is the only difference I saw. BOT ONLINE IM_REP_EN when I did a status. All the tapes displayed the same on status.

FORDONE:~ # mt -f /dev/st0 status
drive type = Generic SCSI-2 tape
drive status = 318767104
sense key error = 0
residue count = 0
file number = 0
block number = 0
Tape block size 0 bytes. Density code 0x13 (DDS (61000 bpi)).
Soft error count since last status=0
General status bits on (41010000):

FORDONE:~ # tar tvf /dev/st0
tar: /dev/st0: Cannot read: Input/output error
tar: At beginning of tape, quitting now
tar: Error is not recoverable: exiting now

ravibhure 04-09-2008 12:59 AM

Hi sjpiv44,
To late to check reply,
when you put the
$ mt -f /dev/st0 status
It shows the block on which it has.
that time put command
$ mt -f /dev/st0 fsf
and again try
$ tar tvf /dev/st0

blacky_5251 04-09-2008 01:15 AM

Try adding '--blocking-factor=128' to the tar command on the SUSE system.

Older *NIX systems often use blocking factors that don't correspond well with Linux. We often strike this problem with tapes created on AIX and DG-UX systems.

sjpiv44 04-11-2008 05:30 PM

I am having a problem addressing the 'Blocking-factor=128' The man tar states
-b, --blocking-factor=BLOCKS BLOCKS x 512 bytes per record

I need to understand what we are saying, referring to 'Blocking-Factor'. For some reason when our old HP, C1533 DAT died, the 'HP replacement was not, possiblely, fully compatable with the HP C1599A. I am starting to question.

When we had the HP C1533, I was successful in getting a copy of the files that I needed. I am having a learning experance.

All times are GMT -5. The time now is 07:56 PM.