-   Linux - Newbie (
-   -   Has ANYONE got the Alcatel Speedtouch 330 modem working... (

DanteDDK 03-14-2004 09:31 AM

Has ANYONE got the Alcatel Speedtouch 330 modem working...
...with Mandrake 10 yet? Please let me know how you did it. Bare in mind i'm a complete Linux n00b and have only been using it for two days, so detailed explanations are much appreciated.

So far Iíve...

1. Downloaded the binary Microcode from the Alcatel Speedtouch site.

2. Renamed KQD6P2.eni as mgmt.o and put it on disk.

3. Ran the modem configuration tool in the hardware section (that had recognised I was using a Alcatel Speedtouch 330)

4. Entered my details and told Linux MDK to get the mgmt.o file from disk to the /usr/share/speedtouch directory - as it couldn't find my alcaudsl.sys on the windows partition (despite it being on there).

5. I then said I'd like to start my connection at reboot, restart the network (it told me I needed to) and then test the connection.

But the last part always says that my connection isn't responding.

It's the Silver modem by the way. I've heard that makes a difference.


Ygarl 03-14-2004 12:09 PM

Bravo! Bravo!
Another reader with the SAME problem I mentioned earlier in this thread and on the Network forum.

I don't have it running either.
Wife getting a bit pi**ed off with me spending all evening booting from XP to Mandrake over and over all evening instead of letting her maintain her EBay shop...

I would happily swap over if I could get online on Mandrake
Good luck...
I did exactly the same thing, except Mandrake 9.2 already has the microcode available.

Help us lost Alcatel owners, please!

bigjohn 03-14-2004 12:46 PM

As far as I could work out, last time I tried to meddle with my speedtouch (the old turquoise cow shit one), the file you get from alcatel with the .eni suffix seemed to be compressed - I never did work out how I could unpack it.

I'm sorry, at the moment, I'm half way through downloading the 3rd mandrake 10 community disc so I can't boot into windows and tell you where you'd find the alcaudsl.sys actually goes.

But from memory, you'll have to use windows explorer (if you have XP it's under accessories) and I think you'll find it in the programme files under drivers. But that's the one to copy to a floppy and rename to mgmt.o and put into the /usr/share/speedtouch directory.

Actually I've got the mandrake speedtouch driver on dvd as well, but that's because I usually buy my disc's from mandrake direct (i.e. 9.1 power pack boxed version). I'll see if I can install it and e-mail it to you as an attachment or something.



bigjohn 03-14-2004 12:56 PM

Nah, that didn't work. There's no facility to attach the file, so an e-mail is on it's way DanteDDk



bigjohn 03-14-2004 01:02 PM

Oh, and before I forget.

I actually got a replacement for my speedtouch, because it used to bug the hell out of me when it has to shut down the connection to swap OS's and also because I used to get a weird problem. It would tell me that there was a problem with line 150 of the file and when that happened, I couldn't access the net.

Despite lots of searching I never did find the answer. So I got an "all in one" modem router device from Solwise (£70) which now handles the connection completely. This turned out to be a result, because if I either re-install, or try a different distro on a seperate partition, I just have to apply the LAN configuration IP address and I'm connected (which helps if you're a total linux clown like me, and have to learn to use a text browser like lynx, because I've managed to screw up my X server - again!).

But as I say, just a thought. Not everyone has the money to go for the "luxury option".



DanteDDK 03-14-2004 02:17 PM

New e-mail address has been sent. Thanks in advance. I'll let you know if it works.

bigjohn 03-14-2004 05:08 PM

It's on it's way.



Ygarl 03-15-2004 03:56 AM

Oh this is just silly!
XP recoginises the thing easily - intstall the driver in 30 seconds, put in the dialup number - Bob's your uncle!
Let me know if that works, guys. I'm using the Drakconnect in Mandrake 9.2 which contains the microcode on the distro and I'm getting nowhere!


DanteDDK 03-15-2004 06:26 AM

No it still doesn't work :cry:

This is really annoying me now. Unless isn't something wrong with the info I entered - but it should all be correct as I got a print out from my ISP.

DanteDDK 03-18-2004 03:24 PM


bigjohn 03-18-2004 05:02 PM

Well, I'm just trying to think of anything as how you might get it sorted.

The theory of it is that you just copy the microcode into the /usr/share/speedtouch then when you set up the connection, you tell it to use an adsl connection or if it offers it, a speedtouch modem - I just tried it, to see when it offers you the facility. And yes, I always told it to start at boot - I seem to recall that the one I had (as I said before, the turquoise cow shit one i.e. the older version) was a bit temperamental if I tried to switch it on and off.

Erm,,,,, and all seem to have various solutions as to how you might get it working.

The only thing that I've spotted that I recall having to make sure of was that my connection details where in the chap or pap -secrets. That's probably in the /etc/ppp (if I recall correctly).

Sorry if that's no help - I definitely didn't have any snags putting it into the /usr/share/speedtouch in 9.0 or 9.1 (it was an absolute f****r to config in 8.2). But I never used it after It was pissing me off i.e. the delay between OS's etc etc.



p.s. you could also check out some of the speedtouch stuff here. If you just follow the search link for speedtouch, you'll even see some of my post's from just before I changed over to using a modem router device like this one, mine is actually the earlier model - but it's bloody brilliant. You would need a PCI ethernet card, but once that's installed, you follow the instructions, which I found easy (after I rang their tech dept). Once it's up and running, you just have to input the internal IP in the LAN connection, and judging by the price, unless you're after the wireless version, then it's quite reasonable. And here's where I got the info about my modem/router device from - there's stacks of other stuff as well.

Andrew Benton 03-20-2004 04:41 PM

I have an old green speedtouch and a purple 330 so I can't comment on how to get a silver 330 to work, but this guy seems to know what he's talking about
To get the mgmt.o firmware driver untar this bundle (don't run make install) from Thompson

alanbenjamin75 04-14-2004 02:35 PM

I'm sure (in my opinion etc) that when people put up replies to these forums, they have never followed the instructions to some of the so called 'driver' updates. I have yet to meet anyone through a LUG who followed these so called fixes, but they are happy to point fellow Linux users who are new to a direction that leads them up a blind ally. Linux is not an easy OS to get into. It does require quite a bit of head scratching if you haven't experimented beyond the Windows OS'. However, once you do get into it, you feel less inclined to go back to Windows. Internet browsing is safer, and you feel like you finally have some control over your PC that you may have spent a load of money on.

All times are GMT -5. The time now is 08:14 AM.