-   Linux - Newbie (
-   -   HAL Failed at boot on Mandrivel 2009.0. Error: Session D-Bus not accessible. HELP! (

Wendy-G 02-06-2009 12:17 AM

HAL Failed at boot on Mandrivel 2009.0. Error: Session D-Bus not accessible. HELP!
I've been around UNIX and UNIX-Like operating systems for more years than I want to count. I've installed Linux on some rather odd machines, even got Mandrake 7 to load on an IBM Thinkpad without any difficulty. NEVER did I EVER have as much trouble as I did with this last and first go-round since the turn of the century. The worst experience – until lately – was installing RH 6.1 on an old Cyrix 166 machine with a Tyan Tomcat Single processor motherboard. The board was designed for two processors, but only had one socket. Yeah. You got it, Linux loaded the dual processor kernel. Simple fix – if you know what to look for. At least I BOUGHT that copy, so I had support.

This time, I started with the latest debian distro. BIG mistake. It took hours – days really – and I never did get though the installation without the installer crashing saying it failed to load something somewhere. Eventually, during attempt nine or ten -- no exaggeration there -- it loaded the software, but failed to load the boot manager. I wanted LILO. I'm familiar with it, or was. I am NOT familiar with the latest version at all. The version I'm familiar with came with the old Mandrake 6 and 7, or RH 5 and 6. Culture shock!

I tried to load it and couldn't. It failed to load. Tried GRUB and that failed, too, as did GRUB-2. I logged out of Linux and went searching for it in Doze – AFTER reloading doze. I couldn't find LILO and couldn't load it OR GRUB through the installer. I finally found and loaded GRUB from Doze, but the site that everyone points to for LILO appears to be dead. I get 404 errors when searching for it.

I eventually got to a GUI desktop in debian Etch. I had to load GRUB from DOS before debian would find it. My machine is a Dual Boot. Tri-Boot Really. 2K-Pro handles booting 98 second edition and 2k. GRUB handled the Linux and 2k end of it. Only my doze systems didn't work at first.... I even reloaded the dos MBR and reformatted to vfat and STILL couldn't get back to doze. Debian ate my OE. M$ does not make an OS. It makes an operating environment. It is so piecemeal, patched and cobbled together you can't call it an operating SYSTEM. But debian ATE IT!

I couldn't do much of anything in debian, including accessing help screens – once I finally got in. Needed to download an install KDE to get any help at all, but it didn't seem to have a whole lot on debian or GNOME – at least that I wanted. Ever try to find man pages on stuff you don't know? You don't know why something is not working, so you can't call up a man page and find out if you don't know what it is that's malfuncitoning. The help screens for Linux rot. Always have. I bought hundreds worth of books and read them before I got old-lady 5.2 and 6.1 running peoperly.

RTFM? I did. It's useless. There aren't any examples to follow. Want to boot debian from something other than CD? They speak AROUND doing it with a HDD and show you an example for doing it from a floppy. They confused me with the interchangeability of hda and sda in the same sentence. I didn't know my drives were no longer called hda, hdb and so on. I didn't know they switched to SCSI nomenclature, they failed to say that in a clear concise manner.

Then, I couldn't get Firefox. Not just get it to run, but get it at all. I had to settle for Ice-Weasel and the Firefox 2 core. Hey, Firefox-2 is dead. I downloaded and installed Firefox 3.0 MONTHS ago. It's alreadu up to 3.05! Firefox-2 is dead! Long live Firefox-3! I thought debian was supposed to be on the cutting edge? I couldn't even COMPILE Firefox 3 the librarires were so out of date it wouldn't work. I could download and compile the libraries on my own, but...WHY? It's a NEW install! It was supposed to be CURRENT! Isn't Etch Current? Apparently not.

When I couldn't log in as root.... Eventually I got in using GNOME. I like GNOME. They say it's more like an Apple and KDE is more like losedoze. I think GNOME is more familiar to a doze user than KDE. I don't like apples. I enjoy cider, not apples. Never had an Apple Mac, so I can't tell you. The thought of using a computer that wasn't compatible with the majority of the world never appealed. Buying system specific hardware and software seemed stupid to me when I chose to go to PCs when I finished learing on my Commodore C-64. Why buy an IBM when I can get a clone for less than half the price? Right? Well.... I KNOW the laterday MACs are good machines and that you can actually use a lot of the same hardware and software as a PC – TODAY. Not back in the day.

So, with a totally dysfunctional debian that refused to do much of anything and a revived w98/2k box, I decided to try Fedora – AFTER reloading and spending DAYS reloading and updating the software. I need the bleeding programmes that aren't well supported in WINE, or I would leave doze out of the picture all together.

Okay, Fedora-10. Hey, I once loaded RH. Right? I'm used to RH 5.2 and 6.1, I loaded Mandrake 7 over top of RH 6.1 as an upgrade. I KNOW RH systems and can cope with Fedora-10. It's just a newer and better RH. Right?

How WRONG could I be?

Talk about SLOW. I got it running, but I couldn't do anything it was so slow. It was like running X in RH 5.2 on a 486SLC-50 with 10MB RAM and a 2MB Diamond Stealth Video card. All right, not quite that bad. That system actually took MINUTES to execute a simple command in X. Fedora-10 WAS painful. Click, wait two three screen paint. Double click, wait for two minutes and MAYBE your browser window will load.

Yes, I actually did have RH running on a 486 SLC-50 machine. The machine is still with us, even if the HDD that had 5.2 on it is long since dead. Fedora 10 was SO painful I was soon sick and tired of it. Especially since I couldn't log into the GUI as root and do the simple but plentiful administrivia necessary with a new Linux system. Type your root password, (16 characters in upper and lower case with a mix of numbers, letters and strange characters), and you expect to be root. After the second time I typed it I was a bit put off, but okay. The third time I was flat out frustrated. By the tenth time, no lie, I was screaming and red in the face.


Three hours of screaming at a totally inanimate lump of plastic and metal ensued. Absurd, but I was having a bad couple of weeks. Still am, when you get right down to it.

I ditched Fedora. I didn't want to read pages and pages and PAGES of man pages to find out how to fix it. There was too much wrong with it. How do you speed it up? Over-clock? No thanks. The board, processor and RAM are too old. GONE!

Hey, my system ain't the latest and greatest, but my Athlon 1600+ with 1GB RAM runs at 1.4GHz. It should pop screens, not be click and wait. Besides, there weren't any places in GNOME or KDE that I could get to root in the GUI like I could in debian – not without using a terminal screen I haven't truly used in YEARS, with commands I've long since forgotten. I was not up for a total refresher course in UNIX.

Having been around UNIX using the old Bell Labs System V, having used a root login on an IBM 3081-D mainframe, as well as old AT&T 386 machines with UNIX as an operating system to run call accounting and telephone switching systems AND having a Linux RH 6.1 SAMBA server with an up time that would have stretched into years were it not for failing batteries in a UPS and a power outage that lasted DAYS, I KNOW why I don't want to be root in an X-windows environment for very long. That server never did catch so much as a bug that wasn't a system feature, much less a virus or trojan. It was rock solid and steady until the HDDs finally failed of old age and hard use. Nothing to worry about. I don't want to be root all the time. It isn't smart for security reasons. Don't tell me I can mess up my system as root. I KNOW I can mess up my system as root. I've messed up lots of things as root over the years. However, I did the system destruction trying to FIX things as root, NOT by making a mistake and deleting a vital directory or file. You can mess it up is something you tell a five-year-old, not a sysadmin and consultant who has run her own computing business – successfully – for a number of years. I've had a computer since the days when you had to write your own programmes to do ANYTHING. You bought a modem, read the manual to learn the commands it understood, then WROTE the drivers so it would work.

HEY, System designers, your safety MIS-Feature is a CRAPPY BUG! I can't remember enough command line commands to do the job anymore. I'm old, I forgot more than most will ever know about system archetecture – 8086, 8088, 286, 386 and 486 archetecture to be sure, but more than most here have experience with. However old and feeble I am, I DO know when to be and not be root! It should be my choice, not yours. Now. That out of the way, back to why I'm here.

Rant over.

So, I went to Mandrivia. I loaded Mandrake before. It was slick. Hey, why not. Mandrivia 2009.0 latest free stable release. Right?

GAH! If this is stable, microsleaze has nothing to worry about.

I have a stack of sticky notes listing software that failed to load that would shock you. Mind you, this is from software that I downloaded, did the MD5 check-sums, verified the burns on media that was known to be good. Then – talk about paranoid – I checked the media with the installer before installing! One install attempt never produced the same software failures the previous attempts did. No failures were reproducable, other than selecting and installing software failed. Booting from HDD, network, CD, copying disks to HDD.... I tried them all. I spent a WEEK trying. I don't give up easily. Finally, I got what I have come to call a clean install, only to find it's rather incomplete. More than half the software packages I THOUGHT I selected to load and install were never loaded! Why do I have to download MAKE? I selected the development packages!

Now to the errors.
I had a clean booting system after the install. All I needed to install and STILL need to install, is I thougth writer and the like would fail to load, but they don't. Not even now. THEN, fool that I am, I allowed KDE to do an update.

HAL failed to load on the next reboot.

Trying to load GDM gives me a screen with what looks like machine code place holder zeros that are actually a failed system font somewhere, a red do not enter symbol that should have an error message that I can't read and boxes for my login.

I know who the users are on the machine. I set it up. However, what am I logging into? What are the errors? Where are the log files? I have to log in as a user, since root logins are so very frowned upon. ;) Right. I still don't get sysadminly stuff as root when I login. Just the nasty notes I can't read when I boot and the one error message. I don't get the sys-adminly messages after booting that I would normally receive as root. The LOUD thump you heard was my head hitting my desk. I have impressions from the centre keys of my M$ Natural keyboard in my forehead and I somehow doubt they'll fade for a while.

When I finally got to my desktop, I got an error.


Error: Session D-Bus not accessible.

Cannot run with parameter '--icon' when Session D-Bus is not accessible.


HAL failed to load. Of course I get a Session D-Bus failure. WHY do I havce a session D-Bus Failure? Why did HAL fail to load?

I've been away from a current version of Linux for so long, nothing is where I expect it to be. However, I DO remember my VI commands and even have a small VI pamphlet with command sequences in it that was published by AT&T. I got it from them when I used to work there. I know basic commands like cp, mv and so-forth. I waited to see if there would be an update that would fix things. There wasn't. Instead, I read that this was fixed after RC2 was released.

System particulares are as follows.

AMD Athlon XP 1600+ running at 1396.481Mhz. (Factory Specs)

2 Kingston ValueRam 512MB PC2100 RAM chips. They checked out using the Memory86 programme. It's not bad RAM.

Soyo SYK7V Dragon+ MoBo.

The secondary RAID array on the motherboard, a Promise Ultra 100 Controller, (a primary and a secondary UDMA EIDE Condroller for 4 devices), is enabled as a tertiary and quaternary UDMA EIDE controller. They're listed as booting to SCSI in BIOS. I am booting to hda, not sd0.

ECS AGP4, 64MB 315Pro AGP Video display adapter.

Hanns-G Hi221D Monitor

Promise Ultra-66 controller card

Adaptec 2941AU SCSI controller

SCSI 8x24 CDRW Teac CD-R58S

An LG 48x EIDE DVDRW described as an HL-DT-ST DVD-RAM GSA-H55N

Kworld PVR-TV 7133 TV-Tuner/Video Capture Card.
Listed as a: SAA7131/SAA7133/SAA7135 Video Broadcast Decoder Misc: says the Module is the saa7134

Audio is C-Media Electronics CM8738

0: VT602 [Rhine-II] VIA Technologies 10x100
1: 21x4x DEC-Tulip Compat Davidcom Semiconductor Cnet 200Pro.

Any and all help you can provide would be appreciated. I am getting sick and tired of mandrivel, floppy hat and Debby and Ian's mess they call debian. I can't tell you how frustrated I am after these last two weeks, but my cat won't come near me and his tail is between his legs. My husband is slinking around with his head down and his shoulders hunched. He's scared to say a word.


Laserman 02-06-2009 01:06 AM

Hi Wendy,

WOW! What a rant. I'm looking forward to your autobiography.

As to the software issues that are plaguing you, looking around this site and linux sites in general will reveal that many thousands of people are running those distros with little to no problems.
I am writing this reply on a Fedora 10 system that installed and booted up in not much more time than it took to read your post. :)

Debian is not really a cutting edge distro, in fact it is nearly as conservative as say Slackware. It would seem to be the most appropriate match for your vintage hardware.

Both Fedora 10 and Mandriva use KDE 4 by default. Personally I think that was too edgy a move since IMHO KDE 4 is barely in beta stage. My Fedora install is entirely KDE free and runs great.

The common factors seem to be you and the computer. Your credentials are impressive so perhaps it is time to take a long hard look at the hardware.

You may want to consider Damn Small Linux as it has been said to run on a 386 with 64 meg of ram. If it doesn't run on your machine then consider a new box.

Drakeo 02-06-2009 01:44 AM

there is no doubt you have had troubles let me tell you what the real problem with the install on mandriva 2009 one. it says there is stuff on this install you really do not need do you want me to get rid of it say no! you want it all. then after you get going it will come back and ask you to set up the root password took for ever. top it off you should up date after that another 700 mbs to another kernel. so there was only two problem with my install after I did it that way.

please do not ask how bad it was the other way.
I zapped the gspca_main module in to dust then built the gspcav from max. then took that dkms nvidia driver they built and burned it to dust and built my own I find it very stable and I use the kde that really sucks but works slow. so I down loaded k3b Why not to use but if you do that it load kde 3.5.10 huge cool thing so now I can use 3.5 or 4.2. cool plus my opera works does my cam and so does my 3d desktop. I help on there forums a lot.
I prefer slackware.and pclinuxOS 2008 yes 2008

Wendy-G 02-06-2009 01:45 AM

Hey Laserman,


Originally Posted by Laserman (Post 3433846)
Hi Wendy,

WOW! What a rant. I'm looking forward to your autobiography.

Tale of woe, more like. The rant was on root boot. However, thanks. ;)


Originally Posted by Laserman (Post 3433846)
The common factors seem to be you and the computer. Your credentials are impressive so perhaps it is time to take a long hard look at the hardware.

You may want to consider Damn Small Linux as it has been said to run on a 386 with 64 meg of ram. If it doesn't run on your machine then consider a new box.

Don't think so. I think it's a combo. It ran FINE until I allowed the update. Not that it was up and running for long before KDE asked for an update.

Then and only then did I run into issues. Now, I made sure my stuff was up to snuff before installing. I read all the hardware and software requirements and desires. I fall well above all of the *DESIRED* system specs except, *perhaps*, in the video card department. That runs on the ragged edge of bottom end, even in MY opinion. Granted, an Athlon like I have can be had for less than a sawbuck, but it's still far above a PIII 800.

I say it's the software or how it was applied. Yes, it is old hardware in computer years and, yes, it's slower than MOST of the machines out there running this distro. However, it is much higher than some of them running it. This is Linux, not doze where you need to upgrade your box with your software. That was the whole reason for turning to Linux. I can't get things to run on doze anymore. They want *shudder* Vista and the biggest tattletale ever, XP, 2003 or 2007, all of which require I register the software to the board and heaven forbid I ever get or need a new MoBo.

I'm retired. I don't have 300 to toss away on a new board and proc. every time I need to update software. I need something that will handle file serving. This proc and board do it. Linux was designed for it. Fedora, or floppy hat as I call it, doesn't like this board, that I know. It chokes and pukes every time it starts to boot.

The board and chipset are fine, it's how the software is accessing it and the load order that the software is being done in. I'm sure of it. I left off how this is the SECOND time I've had a successful install with Mandrivel. I changed it for the other OE issues I was having. I needed to have 2k and 98 on the first two partitions of sda, with the way 2k was behaving. Instead, I had the partitions as vfat, ext3, vfat and that was preventing me from moving things around and using some of my software. It took me another day to get a working copy after reloading 2k and 98 for the second time. Grr.... I HATE those packages and the update processes.

As I said, I had no problems *until* I allowed the mondo 500MB update. I felt like I was updating doze with how much software I had to download with a distro that's a month or two old. So, it's something with how that update was applied, not the hardware. It worked and even updated -- pice-meal-- until I screwed with the partition order and got the mondo one-time update and had to install software that should have already been installed when the OS went in.

As for others who are running similar OSs, did they install new with the latest release and go through the mondo update? Or, did they update a working system recently? Was their software strictly from Mandrivel, debian or floppy hat? these are pertenent questions. If they have software that was updated, upgraded and/or provided from third parties, the updates and the order in which they were applied would be VERY different from what I experienced. Sometimes you have to finagle boot order, load order and/or start order. Juggling software load/boot order like that was a UNIX issue in days gone by and, I dare say, is an issue to this day. I suspect it's something along those lines today.

By the way, to get Floppy hat to boot, I had to slow the boot process, not speed it up. If I made the system pause to close the DVD drive tray, it dragged the boot time, or it changed the boot order sufficently, one of the two, for the kernel to boot the machine. Otherwise it would reboot seconds after loading the kernel.

It's got me scratching my head more than screaming at this point. As I said, the machine is up, if not running properly. The screaming came when one time the software failures would be one set, the next time it would be something else. There were always three or more, but never any common problem files. Once in a while it was open office core, but it was always with another two or ten packages, never the same *set*. This time it was just Open Office -- UNTIL the update.

Thanks for replying so quickly.


Drakeo 02-06-2009 01:59 AM

yeap that up date was a big problem oh yeah Iknow had to rebuild the stuff I need because the kernel and dkms nvidia kernel never was patched yeap been there done that fun to much.mandriva is not my favorite set up. wait till you find the bug in the harddrake2 to configure your hard ware and it want to install a nvida kernel that is not even the kernel your running mmmmmm mmm yeah fun. this last big up date came down today I said sorry not today I will wait till there kernel comes out be for I rebuild everything again. that new up date is crazy way crazy saw it today 500 mbs. kernel mmmmmmm mmmmmmmmm. man get it together 2.6.28 nvida 180 but not my old legacy mmmmmm mmmmm mmmmmmm yeah fun. good for trouble shooting not really for use.

JZL240I-U 02-06-2009 07:32 AM

For your root login woes this worked (AFAIR):

You have to do this as root, i.e. you have to start kcontrol(?) with "kdesu kcontrol".

Btw. my Hardware is an Athlon 700 Mhz. Works flawlessly with SuSE 11.0.

Drakeo 02-06-2009 11:34 PM


Originally Posted by JZL240I-U (Post 3434111)
For your root login woes this worked (AFAIR):

You have to do this as root, i.e. you have to start kcontrol(?) with "kdesu kcontrol".

Btw. my Hardware is an Athlon 700 Mhz. Works flawlessly with SuSE 11.0.

Yeap all my systems work great I just been doing it long enough to know the problems that come with new module and new trees for the root.
This week I did give up on GSB to much work there just is not enough good things about it to spend time on it anymore. I liked it I just think it is has different ways to go and it's a different path I want to take.

All times are GMT -5. The time now is 03:15 PM.