Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 05-08-2014, 10:30 PM   #1
LQ Newbie
Registered: May 2014
Posts: 20

Rep: Reputation: Disabled
GTK+ problems building with Pango and GLib- Packages exist, but they don't configure?

Ok so I got LibFII to work, but I'm still having trouble with other packages- trying to get Pango and I'm met with the following error on ./configure:

checking for CoreText availability... no
checking for CAIRO... yes
checking which cairo font backends could be used... none
configure: Disabling cairo support
configure: error: *** Could not enable any backends.
*** Must have at least one backend to build Pango.
I have libcairo2 and libharfbuzz0- when I tried to sudo-apt get install both of them, it said they were up to date, so I have no idea what else it could mean by back-end???

Also, when I try to install gdk pixbuf, it says that I need a version of GLib which is higher than 2.36, but the version I compiled and make'd was version 2.4...

Requested 'glib-2.0 >= 2.37.6' but version of GLib is 2.36.0
Old 05-08-2014, 10:37 PM   #2
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866Reputation: 4866
To compile software against a library like pango you also need to install the development package of that library, in the case of pango (assuming that you use Debian 7) that would be libpango1.0-dev.
Also, if you compile a library manually that package manager isn't aware of that, which causes the version problem you have with glib.
Old 05-11-2014, 06:26 PM   #3
LQ Newbie
Registered: May 2014
Posts: 20

Original Poster
Rep: Reputation: Disabled
Old 05-11-2014, 06:32 PM   #4
LQ Newbie
Registered: May 2014
Posts: 20

Original Poster
Rep: Reputation: Disabled
So, I got developer packages for pango (Thanks!!) but everything is updated and fine with glib...

I'm still getting the backend issue with pango

But I'm getting this for GLIB:

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
Any idea what this means?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
glib-2, pango, and gtk+, what is going going on? tethysgods Linux - Software 2 08-27-2008 02:09 PM
Upgrading GLib, Pango and GTK Packages PremithiumX Linux - Newbie 4 08-10-2008 12:48 PM
[Slackware 10.2] "Upgrading" packages gtk+, glib, atk, pango stevesk Linux - Newbie 9 07-02-2006 07:09 PM
Pango requesing glib that dosen't exist! exvor Linux - Software 1 04-30-2006 12:49 AM
Freerock uninstall stole GTK looking for up-to-date pango, atk, gtk, glib and xft tgz Oholiab Slackware 8 09-18-2005 12:57 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:05 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration