LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-07-2008, 03:33 AM   #1
dqiu350508
LQ Newbie
 
Registered: Apr 2008
Posts: 19

Rep: Reputation: 0
gtk glib problem


when i ./configure in the catalog of gtk ,there will be mistake :

checking for BASE_DEPENDENCIES... configure: error: Package requirements (glib-2.0 >= 2.13.5 atk >= 1.9.0 pango >= 1.17.3 cairo >= 1.2.0) were not met:

Requested 'glib-2.0 >= 2.13.5' but version of GLib is 2.12.3
Requested 'pango >= 1.17.3' but version of Pango is 1.14.9

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

The version of glib in my computer is 2.6.1

[root@localhost ~]# rpm -q glib
glib-1.2.10-20.el5
glib-2.6.1-2

I installed glib in /opt/glib2.6 previously , so append the path of glib in PKG_CONFIG_PATH that is :
[root@localhost ~]# echo $PKG_CONFIG_PATH
/opt/glib2.6/lib:/opt/glib2.6/lib/pkgconfig

why there show the version of glib is 2.12.3,where is the problem?

so i cant install Pango too ,the same problem is also occurred when execute ./configure in the catalog of pango :

checking for GLIB... no
configure: error:
*** Glib 2.14.0 or better is required. The latest version of
*** Glib is always available from ftp://ftp.gtk.org/.
 
Old 08-07-2008, 07:42 AM   #2
matthewg42
Senior Member
 
Registered: Oct 2003
Location: UK
Distribution: Kubuntu 12.10 (using awesome wm though)
Posts: 3,530

Rep: Reputation: 63
To build programs which use a library, you need to install the development package for that library in addition to the normal package for the library.

On the major rpm distros, I believe the convention is to have a package with the same name root but with "-devel" appended.

On debian-based systems, the convention is to append "-dev".

By the way, did you check that there is not already a pre-built package for the thing you are trying to install? It's not usually necessary (or a good idea) to build things from source unless you are a developer.
 
Old 08-07-2008, 10:38 AM   #3
dqiu350508
LQ Newbie
 
Registered: Apr 2008
Posts: 19

Original Poster
Rep: Reputation: 0
Thanks a lot !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ld linking problem using glib 2.10.1 gtk 2.8.15 and gcc 4.1.0 jwsegar Linux - Software 1 06-11-2006 10:41 PM
Problem installing glib/pango/gtk+ WRSpithead Linux - Software 10 03-26-2005 01:57 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
glib/xchat/gtk problem bootznbooze77 Linux - Newbie 1 08-07-2003 06:02 AM
Glib and gtk installation problem J_Szucs Linux - Newbie 3 08-06-2002 10:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration