LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-24-2003, 03:11 PM   #1
TraCe66
LQ Newbie
 
Registered: Jun 2003
Posts: 11

Rep: Reputation: 0
Exclamation GTK+-2.1.5 Problem


I have been trying to install wxPython, but when i use ./configure
it gives me the following error :

checking for GTK - version >= 1.2.7... no
*** Could not run GTK test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK was incorrectly installed
*** or that you have moved GTK since it was installed. In the latter case, you
*** may want to edit the gtk-config script: /usr/bin/gtk-config
checking for gtk-config... (cached) /usr/bin/gtk-config
checking for GTK - version >= 1.2.3... no
*** Could not run GTK test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK was incorrectly installed
*** or that you have moved GTK since it was installed. In the latter case, you
*** may want to edit the gtk-config script: /usr/bin/gtk-config
configure: error:
Please check that gtk-config is in path, the directory
where GTK+ libraries are installed (returned by
'gtk-config --libs' command) is in LD_LIBRARY_PATH or
equivalent variable and GTK+ is version 1.2.3 or above.

I have configured the GTK+-2.1.5, but when i try wxPython it is not able to find the latest GTK+-2.1.5. I have also used ldconfig while doing the wxPython.

Please help me out. I have been stuggling a lot....
 
Old 06-26-2003, 06:59 AM   #2
TraCe66
LQ Newbie
 
Registered: Jun 2003
Posts: 11

Original Poster
Rep: Reputation: 0
Is there any one who can help me............................

TRaCe66
-----------------------------------------------------
Somethings do Change, somethings do not!
 
Old 06-26-2003, 07:04 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
gtk2 is *NOT* gtk, they are seperate libraries, so you need gtk version 1 installed aswell as version 2.

btw, am i right in guessing this is for pyslsk? that's an icky program to install... as you're finding out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gtk problem CMDR_PAIN Linux - Newbie 4 02-28-2006 11:37 AM
GTK 2.0 problem abhishekgedam Linux - Software 4 11-26-2005 03:12 PM
gtk+ 2.4.14 problem, how do I execute GTK? nautal Linux - Software 2 06-17-2005 07:09 PM
GTK 1.x Problem kule Slackware 1 04-02-2005 04:17 PM
problem with gtk+ MisterESauce Linux - Software 15 02-07-2005 12:36 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration