LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   GRUB Won't Timeout and Auto-Boot Unless Keyboard Is Plugged In (https://www.linuxquestions.org/questions/linux-newbie-8/grub-wont-timeout-and-auto-boot-unless-keyboard-is-plugged-in-902369/)

recursionisrecursion 09-10-2011 11:32 PM

GRUB Won't Timeout and Auto-Boot Unless Keyboard Is Plugged In
 
I have an extra machine and thought I'd set it up as a Folding@Home box. I installed the most recent Ubuntu 32 bit, which comes with GRUB. I'm fairly new to linux but I've been reading a ton of guides on it, I got the machine to work exactly the way I want it and able to be managed via SSH from my regular desktop. However, I found once I was ready to unplug the keyboard, mouse, and monitor, the machine no longer booted to the OS.

I plugged the monitor back in and found that it was hanging on the GRUB screen with Ubuntu highlighted. All I need to do is plug the keyboard back in, and the default 10 second countdown begins immediately. Alternatively, if I tap the enter key on the keyboard, it also boots. But with no keyboard, no boot - just stuck on the GRUB screen.

I've done a lot of research because I didn't want to ask a "newbie" question, basically all I've found is to edit a boot file to change the run level to 3 instead of 5, this didn't make any difference though because I'm not getting far enough to actually get to an OS to have a run level for. I also tried editing the GRUB configuration file and changing around the timeout options, but none seem to get it to timeout without a keyboard plugged in.

I could post the grub configuration files and whatnot, but at the moment they're all at the default. If there's any other information I can provide please let me know. I feel like there's just some setting I missed for "don't wait for keyboard" or something...please help!

corp769 09-11-2011 12:01 AM

Hello,

Have you checked all known settings within your BIOS? I have seen something like this before in the past, and it might be because of your BIOS settings. Double check before you/we dive into this problem any further if you can.

Cheers,

Josh

recursionisrecursion 09-11-2011 09:12 AM

Thanks for replying! I've scoured the BIOS settings, I've found things like boot device order, what to do when there's been a power failure, etc. I don't see any setting that seems like "don't boot unless there's a keyboard", what exactly am I looking for?

recursionisrecursion 09-11-2011 09:28 AM

Success! I did a little more research and found a way to skip the GRUB menu completely. I found it here: http://ubuntuforums.org/showthread.php?t=1302684

It's kind of a work-around because it didn't actually solve the issue of GRUB not working unless there's a keyboard, it just skips GRUB completely. However, it maintains the ability to plug in a keyboard and hold shift in order to get the menu and boot into something different.

Here's what the post says:

If the "GRUB_TIMEOUT=0" does not work, [...] open /etc/grub.d/00_header and go to approximately line 238:
Code:
gksu gedit +238 /etc/grub.d/00_header
Find this section and make the changes in dark red, then save the file and run "sudo update-grub".

Quote:
make_timeout ()
{
cat << EOF
if [ "\${recordfail}" = 1 ]; then
set timeout=-1
else

# Manually change timeout to 0
# set timeout=${2}
set timeout=0
# End manual change


fi
EOF
}
This should eliminate the menu display. It also preserves the ability to display the menu by holding down the SHIFT key during boot.

I'll mark this thread as 'solved' in a day or so, to see if anyone has any other ideas to actually fix my GRUB problem as opposed to skip it!


All times are GMT -5. The time now is 09:30 PM.