LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   grub windows problems (https://www.linuxquestions.org/questions/linux-newbie-8/grub-windows-problems-146206/)

Moebius 02-14-2004 10:59 PM

grub windows problems
 
Hey, I'm trying to boot windows from my windows hard drive (secondary master, hdc) using grub and it ain't working. The error I get when I select windows while booting from grub is:

Code:

Booting 'windows'

root (hd1, 0)
Filesystem type unknown, partition type 0x7
chainloader +1

The Linux hard drive is Primary Master (hda)

The windows entry in my /boot/grub/menu.lst looks like this:
Code:

title windows
root (hd1,0)
chainloader +1

Any ideas? Thanks.

spuzzzzzzz 02-14-2004 11:21 PM

try changing "root (hd1,0)" to "rootnoverify (hd1,0)" that should prevent grub from trying to read the partition.

jax8 02-15-2004 02:19 AM

here is my grub.conf file

I had the same problem when I upgraded to Windows XP
This seems to work though




# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/hda2
# initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz

title Red Hat Linux (2.4.20-8)
root (hd0,0)
kernel /vmlinuz-2.4.20-8 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-8.img

title Windows XP
# as far as I can understand it the Windows XP hard disk hd1
# needs to think it is the first disk on the IDE bus in order to boot
# so do a swap and add the following two commands to change it
map (hd0) (hd1)
map (hd1) (hd0)
# you then need to tell grub which hard disk and which partition to read the booting information from
# although you have done a swap using the above commands the disks don't change their labelling
# so use hd1,0 as the root device (in grub all numbering starts at zero)
# the telltale to knowing which partition to add to the rootnoverify option
# is the output of fdisk -l the `*' on /dev/hdb1 showing it's the active or boot partition
rootnoverify (hd1,0)
# now tell grub that you are going to be doing an indirect boot using an external chainloader
# i.e it's going to grab the Windows boot code and run it instead
# of directly loading the linux kernel like it usually does.
chainloader +1
# not sure exactly what makeactive does
# I'm assuming it is marking the root partition you specified
# with the rootnoverify command as the active or boot partition
# if it isn't already marked as the `*' or boot partition
makeactive

Moebius 02-15-2004 06:36 PM

ok I tried just changing it to rootnoverify last night, but that didn't work. It just came up with:

Code:

Booting 'windows'

rootnoverify (hd1, 0)
chainloader +1

I'll try jax8's suggestions in a little while...


All times are GMT -5. The time now is 06:04 AM.