LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-14-2007, 04:09 PM   #1
Amuro-Ray2020
Member
 
Registered: Aug 2004
Location: Arizona
Distribution: Linux Mint
Posts: 81

Rep: Reputation: 15
GRUB unable to mount partition


I have a 160 GB hard drive that I have created 3 partitions on, sda1 which is ext3, sda2 which is NTFS, and sda3 which is ext3 also. I have installed two different Linux distro's, Backtrack2 on sda1, and then Linux Mint on sda3. GRUB recognizes the NTFS partition and the Mint partition, both Windows and Mint boot fine. However, the Backtrack 2 partition was not recognized, so I added it myself to menu.lst:

Code:
## ## End Default Options ##

title           Backtrack 2
root            (hd0,0)
kernel          /boot/vmlinuz root=/dev/sda1 ro quiet splash
initrd          /boot/splash.initrd
quiet
savedefault
boot

title           Linux Mint (KDE), kernel 2.6.17-10-generic
root            (hd0,2)
kernel          /boot/vmlinuz-2.6.17-10-generic root=/dev/sda3 ro quiet splash
initrd          /boot/initrd.img-2.6.17-10-generic
quiet
savedefault
boot

title           Linux Mint (KDE), kernel 2.6.17-10-generic (recovery mode)
root            (hd0,2)
kernel          /boot/vmlinuz-2.6.17-10-generic root=/dev/sda3 ro single
initrd          /boot/initrd.img-2.6.17-10-generic
boot

title           Linux Mint (KDE), memtest86+
root            (hd0,2)
kernel          /boot/memtest86+.bin
quiet
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title           Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda2
title           Windows Vista/Longhorn (loader)
root            (hd0,1)
savedefault
makeactive
chainloader     +1
The partition can be mounted in Linux Mint, so I based my grub entry on the lilo.conf file:

Code:
boot = /dev/sda
prompt
timeout = 20
bitmap=/boot/splash.bmp
change-rules
reset
vga = 0x317
image = /boot/vmlinuz
  root = current
  initrd = /boot/splash.initrd
  label = bt
  read-only
As I mentioned, when I try to boot the Backtrack 2 entry in GRUB, it fails with an error stating that the partition cannot be mounted. I have very little experience with GRUB, how can I get this to work?

Any help is greatly appreciated!
 
Old 05-14-2007, 04:26 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,891

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Boot mint and mount the Backtrack partition. Look into the /boot folder (Backtrack) and get the name of the initrd file you find there. Then edit your grub config to show the same name.
 
Old 05-14-2007, 04:32 PM   #3
Amuro-Ray2020
Member
 
Registered: Aug 2004
Location: Arizona
Distribution: Linux Mint
Posts: 81

Original Poster
Rep: Reputation: 15
Splash.img

That's what I did, but there was only one initrd in the boot folder:

Code:
tsnow@Mint-laptop:/Backtrack2/boot$ ls -a
.  ..  map  splash.bmp  splash.initrd  vmlinuz
Could it be somewhere else? This distro is based on SLAX, but I installed the full version to the hard drive, so it should be able to boot, assuming I used lilo. Isn't there a way I can install lilo to that partition, then have GRUB load lilo? Cause I know that you chainload the NTLDR for Windows...

Thanks for the quick response
 
Old 05-14-2007, 04:52 PM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,812

Rep: Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168Reputation: 2168
The root direct locates the grub stage files - it needs to be the same in all stanzas. Try this
Code:
title           Backtrack 2
root            (hd0,2)
kernel          (hd0,0)/boot/vmlinuz root=/dev/sda1 ro quiet splash
initrd          (hd0,0)/boot/splash.initrd
boot
I prefer to have a separate boot partition; then copy the images into that, then you can use something similar to what you have (except the root directive of course).
Means you have to think up names for your kernel images ...
 
Old 05-14-2007, 05:15 PM   #5
Amuro-Ray2020
Member
 
Registered: Aug 2004
Location: Arizona
Distribution: Linux Mint
Posts: 81

Original Poster
Rep: Reputation: 15
Error 17

Thanks syg00, I didn't know that! Okay, I have made the changes, and my grub menu.lst stanza for Backtrack looks like this:

Code:
title           Backtrack 2
root            (hd0,2)
kernel          (hd0,0)/boot/vmlinuz root=/dev/sda1 ro quiet splash
initrd          (hd0,0)/boot/splash.initrd
boot
However, it still gives me an Error 17: Cannot mount partition. I have no idea where to proceed from here
 
Old 05-14-2007, 05:43 PM   #6
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,891

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
At this point, I suggest re-installing Backtrack. Install the bootloader to the boot sector of the partition (not to the MBR). Pay careful attention to the partition selection and format options.

Then edit the grub config in Mint to read:

title Backtrack2
root (hd0,0)
chainloader +1

The chainloader option works just as well as specifying the kernel parameters and initrd. It works because the bootloader for that partition is completely installed in (hd0,0) boot sector, and you just pass the boot process over to that bootloader.
 
Old 05-15-2007, 02:07 AM   #7
Amuro-Ray2020
Member
 
Registered: Aug 2004
Location: Arizona
Distribution: Linux Mint
Posts: 81

Original Poster
Rep: Reputation: 15
Error 13

Okay, I tried the chainloader idea, and at least now it gives me a different error message. I made sure that lilo installed to /dev/sda1, and now upon attempting to boot with the menu.lst of:

Code:
title Backtrack2
root (hd0,0)
chainloader +1
It gives me an error code of 13, unsupported executable format
 
Old 05-15-2007, 08:40 AM   #8
uncle-c
Member
 
Registered: Oct 2006
Location: The Ether
Distribution: Lubuntu 14.04 LTS, Kali
Posts: 297

Rep: Reputation: 30
I'm begining to wonder if the partition housing backtrack is actually bootable. Have you tried using any "Rescue CDs" which can boot individual partitions ? Also what is your "fdisk -l" output like ?

UC
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ext3 partition unable to mount majalee Linux - Hardware 4 07-17-2006 10:54 PM
unable to mount ntfs partition capnp72 Fedora 6 03-02-2006 07:37 AM
Unable to mount FAT32 partition automatically alaskazimm Linux - General 4 08-24-2005 07:19 PM
Grub Error 17: Cannot mount selected partition and other Grub problems Sebastian Naitsabes Linux - General 1 07-05-2005 08:33 AM
Unable to mount NTFS partition as user vharishankar Linux - General 4 04-02-2005 09:22 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration