LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Grub timeout is not working (https://www.linuxquestions.org/questions/linux-newbie-8/grub-timeout-is-not-working-720322/)

procfs 04-20-2009 12:55 AM

Grub timeout is not working
 
Hi

here is my grub.con

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/hda6
# initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=1
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Red Hat Enterprise Linux AS (2.6.9-42.EL)
root (hd0,0)
kernel /vmlinuz-2.6.9-42.EL ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.9-42.EL.img

I am running Redha AS4, the timeout value in grub file is not working and though I have set it to 1 second, but it stais at the grub manu for a long time and start booting.

I have reinstalled the grub but still no change

billymayday 04-20-2009 01:13 AM

Are you sure this is the version being used? Try changing the title a little and see if it changes when the menu pops up.

procfs 04-20-2009 01:20 AM

Hi billymayday

This is the release file content Red Hat Enterprise Linux AS release 4 (Nahant Update 4)

I changed the title as you suggested, and when the machine boots up I can see the in the grub menu

Regards

billymayday 04-20-2009 01:26 AM

And it boots OK if you hit enter?

Did the delay work for a larger value (say 10 secs)?

procfs 04-20-2009 01:31 AM

Yes when I hit enter it boots okay

billymayday 04-20-2009 01:43 AM

But did it work for larger timeout values?

procfs 04-20-2009 02:19 AM

No not even for larg timeout it works

billymayday 04-20-2009 02:25 AM

That's very odd. I'd try commenting that line out, and manually re-entering a timeout line.

procfs 04-20-2009 02:28 AM

Did that to billymayday, and I reinstalled the grub but made no difference

Libu 04-20-2009 02:32 AM

Try commenting out the "hiddenmenu" line.

#hiddenmenu

All this would do is show you the grub bootloader.

procfs 04-20-2009 02:50 AM

Hi Libu same thing it just not auto boot

billymayday 04-20-2009 03:11 AM

Can you try booting without your keyboard plugged in?

Libu 04-20-2009 03:21 AM

Are you looking at the correct file "/boot/grub/grub.conf" ? (/boot/grub/menu.lst should be a link to this, likewise so should /etc/grub.conf )

procfs 04-20-2009 03:33 AM

hay billymayday it worked, and I pluged in another key doard and its working okya. Can you explained what is going on.

procfs 04-20-2009 03:34 AM

By the way Thanks you guys


All times are GMT -5. The time now is 10:52 AM.