LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   GRUB Stage 1.5, Error 22 (https://www.linuxquestions.org/questions/linux-newbie-8/grub-stage-1-5-error-22-a-621966/)

Michael AM 02-18-2008 05:49 AM

GRUB Stage 1.5, Error 22
 
Hi,

I have openSUSE 10.3 installed. That went all right, and from time to time I start it up to learn more about Linux.

I helped a friend with a broken disk - meaning I had to remove the power and data cable from one of my disks to attach my friends disk.

Now when I reattach my disk GRUB complains with error 22.

Note: Linux is installed on disk 3, and the boot disk points to GRUB on disk3 - when I remove it's power I get error 21

A very few times I have gotten the system to reboot. Just in case the SATA cables were the problem I replaced both of those - it worked twice after that.

How I can just get rid of the GRUB as it seems to be getting in the way.
I may have reinstall windows XP. The Windows "repair" option seems to have wasted my Windows as well - but I am hoping that is not the case.

btw: booting from a Knoppix CD does let me see all the disks and all the partitions.

Help is appreciated!

Michael AM 02-18-2008 05:52 AM

Oh yes, if I do not have my second windows disk attached - I dont get error 22.

Michael AM 02-18-2008 06:25 AM

Question is now academic, Windows "repair" mode just trashed my disk. C'est la vie, now to see if knoppix can help me out.

anupamsr 02-18-2008 06:43 AM

First try: get http://www.ultimatebootcd.com/, supposedly you can fix everything with it. You can give command "fdisk /mbr" to get everything working.

----- Another guess
Here is what I think your problem is. It seems that now when you attach your disk, the disk number is different than it was when you did the installation of GRUB.

If I am right, there is a really very simple solution (albeit non-graphical). Attach all the disks you want to attach while booting. Then boot through any livecd (Knoppix etc.).

Now you will have to recognize which drive is the one your linux is installed (or for that matter, windows). As far as I remember, Knoppix will have already mounted every disk. Just type "mount" and see for yourself.

All you have to do now is to modify the grub menu.1st file so that it refers to the current directory.
----- Another guess
You can always reinstall :D

Michael AM 02-18-2008 11:39 AM

Other than download the ultimatebootcd you suggested I had done all that - and even used the knoppix CD to make a backup of the C disk once it showed up again.

I am just new to the current (last 6 years) of Linux. I have worked with UNIX for almost 30 years and am very glad that there are Linux distros aka Live CD's that boot nearly anything.

Short answer - I reinstalled Linux (openSuse 10.3) and I could now reboot (openSuse also would not boot, even thru the CD because it always wante some extra GRUB it seemed, same with the windows Repair that is running to it's end now.

The other happy moment is that I remembered the XP admin password. I had given up and just entered on of my older passwords - and it gave me a prompt.

After FIXMBR from the emergency recovery, or whatever Windows calls it, FIXMBR erased the GRUB links - and finally windows repair got to repairing - warning to the windows unaware - windows repair is reinstall windows. I'll find out later if it has saved anything of the previous installation.

Lastly, many thanks for your suggestions. If I had not done them already :P they would have fixed me up nicely.

anupamsr 02-19-2008 07:16 AM

Glad that you were able to solve the problem. It has been a really long time since I installed Windows.

Also, as far as I remember, it should not delete anything.

I have a nice story regarding this. Once I was "troubleshooting" my friends computer - some problem with Windows XP, and he wanted a reinstall because the computer won't boot (nothing related to Linux). He had very important data in his "Desktop". Unfortunately, he told me this while I was in the middle of installation. Fortunately, the installation CD couldn't find some driver, so it prompted for specifying its location.

At that point, I saw that all the drives were already mounted, and right-clicking any file would give you all the options available while running Windows normally! Naturally, it means I had copy/paste available :) So I copied his Desktop to some other drive.


All times are GMT -5. The time now is 06:27 AM.