-   Linux - Newbie (
-   -   GRUB menu.lst for Fedora and Mandrake Dual boot (

the_padre 03-14-2005 12:50 AM

GRUB menu.lst for Fedora and Mandrake Dual boot
I've installed Fedora 3 and Mandrake 10.1 CE on my single hard disk as follows:
- Fedora was installed first in hdb2 partition and Mandrake was next on hdb5
- Boot loader record for Fedora 3 on /dev/hdb1 first sector of boot partition and Mandrake 10.1 in the MBR

The result of fdisk are as follows:
Device Boot Start End Blocks Id System
/dev/hdb1 * 1 13 104391 83 Linux
/dev/hdb2 14 485 3791340 83 Linux
/dev/hdb3 486 550 522112+ 82 Linux swap
/dev/hdb4 551 1027 3831502+ 5 Extended
/dev/hdb5 551 1027 3831471 83 Linux

I configured Mandrake to use GRUB as the bootloader. Finally, I added the line for Fedora on the /boot/grub/menu.lst as shown below (Note: To shorten the list I'm not showing the lines for Mandrake "failsafe" and "linux-nonfb").
timeout 10
color white/blue blue/cyan
default 0

title Mandrake 10.1 CE
kernel (hd0,4)/boot/vmlinuz root=/dev/hdb5 devfs=nomount acpi=ht resume=/dev/hdb3 splash=silent vga=788
initrd (hd0,4)/boot/initrd.img

title Fedora 3
kernel (hd0,1)/boot/vmlinuz-2.6.9-1.667 root=/dev/hdb2
initrd (hd0,1)/boot/initrd-2.6.9-1.667.img
My question: Why am I getting "File not found" on the Fedora kernel line when I select to boot it? As a result I can't boot Fedora.

If you can help me, I'll tell God.

morneo 03-14-2005 01:27 AM

I had the same problem and fixed it.Try this

login to mandrake and access the fedora partition. it is usually a folder under /
it might be /data
goto boot/grub and look for menu.lst file.
in the menu.lst file you will have the lines for fedora
make sure that the lines for fedora i.e kernel and initrd are the same as the lines in the menu.lst in mandrake.
if not change the menu.lst in mandrake. make sure u have a backup of menu.lst in mandrake.
once the changes are made save the file and restart.

let me know if it worked

Simon Bridge 03-14-2005 01:30 AM

Well... there's always the obvious: "File not found" suggests linux is looking in the wrong place for the file. I'm used to grub configs that would looklike this...

title Fedora 3
root (hd0,1)
kernel /boot/vmlinuz-2.6.9-1.667 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.9-1.667.img

however, I'm not sure about dual boot for different distros of linux. Where I've had two kernels, I've just stuck everything in the same boot partition. The above assumes that vmlinuz and initrd are in the directories specified - this should make / = /dev/hdb2 and everything should be relative to that(?)

Now for someone to contradict me :)

the_padre 03-15-2005 02:21 AM

Thanks, guys.

Per morneo's suggestion I booted into Mandrake and mounted the Fedora partition.

# mkdir /mnt/fc3
# mount /dev/hdb1 /mnt/fc3
# cd /mnt/fc3
# cat boot/grub/menu.lst

This showed me the GRUB entry which looks very much the same as what Simon suggested.

title Fedora 3
root (hd0,1)
kernel /boot/vmlinuz-2.6.9-1.667 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.9-1.667.img

I then cut and pasted that entry into my Mandrake /boot/grub/menu.lst and rebooted.

Voila! It works. I can boot Fedora 3 now.


I'll tell God what a bunch of nice people you are.

All times are GMT -5. The time now is 09:57 AM.