LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   grub menu - can't remove thru editing etc/default/grub (https://www.linuxquestions.org/questions/linux-newbie-8/grub-menu-cant-remove-thru-editing-etc-default-grub-4175595239/)

eco_bach 12-11-2016 02:41 PM

grub menu - can't remove thru editing etc/default/grub
 
Please help. This is driving me crazy. Can't stand the extra delay of seeing the grub menu every time I boot.

On Ubuntu-mate 16.04 Have edited my /etc/default/grub to read (and then of course doing a sudo update grub)

Code:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#  info -f grub -n 'Simple configuration'

#GRUB_DEFAULT=0
#GRUB_TIMEOUT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true

#GRUB_DISABLE_OS_PROBER=true
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"


c0wb0y 12-11-2016 04:31 PM

Quote:

#GRUB_TIMEOUT=0
uncomment it, then

Code:

grub2-mkconfig -o /boot/grub2/grub.cfg
or
grub-mkconfig -o /boot/grub/grub.cfg

Some distros, use grub-mkconfig instead of grub2-mkconfig.

BW-userx 12-11-2016 05:45 PM

update-grub works too in some

eco_bach 12-12-2016 06:55 AM

Thanks
In my case it was
sudo grub-mkconfig -o /boot/grub/grub.cfg

No change!

Also
then tried a
sudo update-grub

No change

frustrating

doesn't the update-grub command by default update grub.cfg?

BW-userx 12-12-2016 07:07 AM

Quote:

Originally Posted by eco_bach (Post 5640954)
Thanks
In my case it was
sudo grub-mkconfig -o /boot/grub/grub.cfg

No change!

Also
then tried a
sudo update-grub

No change

frustrating

doesn't the update-grub command by default update grub.cfg?

Hold on let me give this a shot, Bold is what I am going to remove the comment out, the update, then reboot, brb.
Code:

userx@voided1.what/etc/default>> cat grub
#
# Configuration file for GRUB.
#
GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Void"
GRUB_CMDLINE_LINUX_DEFAULT="loglevel=4"
# Uncomment to use basic console
#GRUB_TERMINAL_INPUT="console"
# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console
GRUB_BACKGROUND=/usr/share/void-artwork/splash.png
#GRUB_GFXMODE=1920x1080x32
#GRUB_DISABLE_LINUX_UUID=true
#GRUB_DISABLE_RECOVERY=true
userx@voided1.what/etc/default>>

BACK:
I tried it three different ways, that one showing being the first, then changed this line
Code:

GRUB_TIMEOUT=5
to this
GRUB_TIMEOUT=0

re-commented out the first hidden time out, update-grub, and it worked on my system. no wait time. Using update-grub.

The way @c0wb0y showed you to update grub is just the long way of doing the same thing.

AwesomeMachine 12-12-2016 01:19 PM

You can also just hit the enter key and the machine will boot without waiting for grub to time out.

c0wb0y 12-12-2016 02:08 PM

Did you even bothered looking at the newly-created grub.cfg (if it indeed re-created)? Did you check if it is /boot/grub or /boot/grub2? Here's another recipe:

Code:

update-grub2

BW-userx 12-12-2016 02:11 PM

Quote:

Originally Posted by AwesomeMachine (Post 5641130)
You can also just hit the enter key and the machine will boot without waiting for grub to time out.

yeah but if he turns it on, then runs out the door for a cigarette , he got no time to hit that key it is still preboot, but then comes back and it is still not booting yet, (fast smoke) well. hit the enter key always works. :rolleyes:

eco_bach 12-12-2016 02:50 PM

c0wb0y, thanks will try that. AwesomeMachine, yes of course, but the point is I shouldn't have to manually bypass GRUB every time I boot.

One thing I noticed. When I do a
sudo update-grub
My Windows Boot manager on another partition-drive gets updated
This doesn't seem correct

Quote:

[sudo] password for foo:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.4.0-53-generic
Found initrd image: /boot/initrd.img-4.4.0-53-generic
Found linux image: /boot/vmlinuz-4.4.0-31-generic
Found initrd image: /boot/initrd.img-4.4.0-31-generic
Found Windows Boot Manager on /dev/nvme0n1p2@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration

colorpurple21859 12-13-2016 07:43 AM

maybe the grub.cfg needs to go into the /boot/efi/EFI/ubuntu, or whatever the directory is in the EFI folder

BW-userx 12-13-2016 08:30 AM

Quote:

Originally Posted by eco_bach (Post 5641231)
c0wb0y, thanks will try that. AwesomeMachine, yes of course, but the point is I shouldn't have to manually bypass GRUB every time I boot.

One thing I noticed. When I do a
sudo update-grub
My Windows Boot manager on another partition-drive gets updated
This doesn't seem correct

That is correct, it will list everything you have that is bootalbe, it is when you no longer see it seeing Windows when it updates is when you go into wtf mode, then post a help me.

eco_bach 12-13-2016 09:51 AM

ok thanks. Guess I will have to just get accustomed to hitting the return key on very boot though wish I could still hide grub

BW-userx 12-13-2016 10:19 AM

Quote:

Originally Posted by eco_bach (Post 5641587)
ok thanks. Guess I will have to just get accustomed to hitting the return key on very boot though wish I could still hide grub

grub is still going to pop up, then go into its boot sequence. it will just not be there for very long. Try setting it to 100 (one Hundred ) and see what happens. because it should be working. I see no reason why it isn't.

all that setting does is put grub into a wait state, then without even hitting your enter key, when that time is up it will just boot the default system, (top of the list) automatically.

Just change your background image to something pleasant to look at as well.

Shadow_7 12-14-2016 01:15 PM

# update-grub

Should change the /boot/grub/grub.cfg (implies as root and /boot/ is mounted if it is it's own partition). Bear in mind that you can have another grub for another install that is what actually gets used at boot. Sound like that might be in play. There's also other customization areas beyond /etc/defaults/grub (/etc/grub.d/? recalling a 40_custom entry/file that I used long ago). Although more for menu items than settings, but they can get in the way.


All times are GMT -5. The time now is 04:51 AM.