LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-11-2016, 03:41 PM   #1
eco_bach
Member
 
Registered: Dec 2016
Posts: 230

Rep: Reputation: Disabled
grub menu - can't remove thru editing etc/default/grub


Please help. This is driving me crazy. Can't stand the extra delay of seeing the grub menu every time I boot.

On Ubuntu-mate 16.04 Have edited my /etc/default/grub to read (and then of course doing a sudo update grub)

Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

#GRUB_DEFAULT=0
#GRUB_TIMEOUT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true

#GRUB_DISABLE_OS_PROBER=true
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
 
Old 12-11-2016, 05:31 PM   #2
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 417

Rep: Reputation: 74
Quote:
#GRUB_TIMEOUT=0
uncomment it, then

Code:
grub2-mkconfig -o /boot/grub2/grub.cfg
or
grub-mkconfig -o /boot/grub/grub.cfg
Some distros, use grub-mkconfig instead of grub2-mkconfig.
 
Old 12-11-2016, 06:45 PM   #3
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,634

Rep: Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074
update-grub works too in some
 
Old 12-12-2016, 07:55 AM   #4
eco_bach
Member
 
Registered: Dec 2016
Posts: 230

Original Poster
Rep: Reputation: Disabled
Thanks
In my case it was
sudo grub-mkconfig -o /boot/grub/grub.cfg

No change!

Also
then tried a
sudo update-grub

No change

frustrating

doesn't the update-grub command by default update grub.cfg?

Last edited by eco_bach; 12-12-2016 at 08:00 AM.
 
Old 12-12-2016, 08:07 AM   #5
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,634

Rep: Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074
Quote:
Originally Posted by eco_bach View Post
Thanks
In my case it was
sudo grub-mkconfig -o /boot/grub/grub.cfg

No change!

Also
then tried a
sudo update-grub

No change

frustrating

doesn't the update-grub command by default update grub.cfg?
Hold on let me give this a shot, Bold is what I am going to remove the comment out, the update, then reboot, brb.
Code:
userx@voided1.what/etc/default>> cat grub
#
# Configuration file for GRUB.
#
GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=false
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Void"
GRUB_CMDLINE_LINUX_DEFAULT="loglevel=4"
# Uncomment to use basic console
#GRUB_TERMINAL_INPUT="console"
# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console
GRUB_BACKGROUND=/usr/share/void-artwork/splash.png
#GRUB_GFXMODE=1920x1080x32
#GRUB_DISABLE_LINUX_UUID=true
#GRUB_DISABLE_RECOVERY=true
userx@voided1.what/etc/default>>
BACK:
I tried it three different ways, that one showing being the first, then changed this line
Code:
GRUB_TIMEOUT=5
to this
GRUB_TIMEOUT=0
re-commented out the first hidden time out, update-grub, and it worked on my system. no wait time. Using update-grub.

The way @c0wb0y showed you to update grub is just the long way of doing the same thing.

Last edited by BW-userx; 12-12-2016 at 08:15 AM.
 
Old 12-12-2016, 02:19 PM   #6
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,511

Rep: Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007Reputation: 1007
You can also just hit the enter key and the machine will boot without waiting for grub to time out.
 
Old 12-12-2016, 03:08 PM   #7
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 417

Rep: Reputation: 74
Did you even bothered looking at the newly-created grub.cfg (if it indeed re-created)? Did you check if it is /boot/grub or /boot/grub2? Here's another recipe:

Code:
update-grub2
 
Old 12-12-2016, 03:11 PM   #8
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,634

Rep: Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074
Quote:
Originally Posted by AwesomeMachine View Post
You can also just hit the enter key and the machine will boot without waiting for grub to time out.
yeah but if he turns it on, then runs out the door for a cigarette , he got no time to hit that key it is still preboot, but then comes back and it is still not booting yet, (fast smoke) well. hit the enter key always works.
 
Old 12-12-2016, 03:50 PM   #9
eco_bach
Member
 
Registered: Dec 2016
Posts: 230

Original Poster
Rep: Reputation: Disabled
c0wb0y, thanks will try that. AwesomeMachine, yes of course, but the point is I shouldn't have to manually bypass GRUB every time I boot.

One thing I noticed. When I do a
sudo update-grub
My Windows Boot manager on another partition-drive gets updated
This doesn't seem correct

Quote:
[sudo] password for foo:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.4.0-53-generic
Found initrd image: /boot/initrd.img-4.4.0-53-generic
Found linux image: /boot/vmlinuz-4.4.0-31-generic
Found initrd image: /boot/initrd.img-4.4.0-31-generic
Found Windows Boot Manager on /dev/nvme0n1p2@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for EFI firmware configuration

Last edited by eco_bach; 12-12-2016 at 09:53 PM.
 
Old 12-13-2016, 08:43 AM   #10
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, fedora,Xubuntu, others
Posts: 3,934

Rep: Reputation: 660Reputation: 660Reputation: 660Reputation: 660Reputation: 660Reputation: 660
maybe the grub.cfg needs to go into the /boot/efi/EFI/ubuntu, or whatever the directory is in the EFI folder
 
Old 12-13-2016, 09:30 AM   #11
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,634

Rep: Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074
Quote:
Originally Posted by eco_bach View Post
c0wb0y, thanks will try that. AwesomeMachine, yes of course, but the point is I shouldn't have to manually bypass GRUB every time I boot.

One thing I noticed. When I do a
sudo update-grub
My Windows Boot manager on another partition-drive gets updated
This doesn't seem correct
That is correct, it will list everything you have that is bootalbe, it is when you no longer see it seeing Windows when it updates is when you go into wtf mode, then post a help me.
 
Old 12-13-2016, 10:51 AM   #12
eco_bach
Member
 
Registered: Dec 2016
Posts: 230

Original Poster
Rep: Reputation: Disabled
ok thanks. Guess I will have to just get accustomed to hitting the return key on very boot though wish I could still hide grub
 
Old 12-13-2016, 11:19 AM   #13
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware FreeBSD Win10 MX
Posts: 9,634

Rep: Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074Reputation: 2074
Quote:
Originally Posted by eco_bach View Post
ok thanks. Guess I will have to just get accustomed to hitting the return key on very boot though wish I could still hide grub
grub is still going to pop up, then go into its boot sequence. it will just not be there for very long. Try setting it to 100 (one Hundred ) and see what happens. because it should be working. I see no reason why it isn't.

all that setting does is put grub into a wait state, then without even hitting your enter key, when that time is up it will just boot the default system, (top of the list) automatically.

Just change your background image to something pleasant to look at as well.

Last edited by BW-userx; 12-13-2016 at 11:23 AM.
 
Old 12-14-2016, 02:15 PM   #14
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,003
Blog Entries: 1

Rep: Reputation: 847Reputation: 847Reputation: 847Reputation: 847Reputation: 847Reputation: 847Reputation: 847
# update-grub

Should change the /boot/grub/grub.cfg (implies as root and /boot/ is mounted if it is it's own partition). Bear in mind that you can have another grub for another install that is what actually gets used at boot. Sound like that might be in play. There's also other customization areas beyond /etc/defaults/grub (/etc/grub.d/? recalling a 40_custom entry/file that I used long ago). Although more for menu items than settings, but they can get in the way.
 
  


Reply

Tags
grub, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
editing grub menu iceman81 Linux - Newbie 4 09-21-2013 10:47 PM
[SOLVED] GRUB 2 Menu Editing, something is not right here feeblebrain Debian 20 08-19-2011 12:47 AM
LXer: Grub Customizer Lets You Reorder, Add Or Remove GRUB 2 (Or BURG) Menu Entries LXer Syndicated Linux News 0 10-09-2010 06:20 PM
editing menu.lst in puppy grub tigertim71 Puppy 13 08-17-2009 07:01 PM
Setting password on grub, wha to do after changing default values in /boot/grub/menu. sarajevo Linux - Security 1 08-17-2005 09:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration