-   Linux - Newbie (
-   -   GRUB loading, please wait ERROR 15 (

ceantuco 09-02-2008 09:57 AM

GRUB loading, please wait ERROR 15
Hi Guys,

This morning I turned on my PC and I got 'ERROR 15' while loading GRUB. My computer was working fine last Thursday and I haven't done any updates. (haven't used it since then)
I'm running open Suse 11.0.
I also tried Suse's DVD repair option which went through a lot of steps and repaired a few things and after that I rebooted the system and now I'm just getting grub>_ .
Can anyone help me???

Agrouf 09-02-2008 10:30 AM

do you know on which partition grub is installed?

ceantuco 09-02-2008 10:58 AM

Never mind. I copied my important data and I'm reinstalling OpenSuse as I type.
Thanks for your help!

Agrouf 09-02-2008 11:08 AM

Ouch! That's like using a nuclear bomb to kill a fly!
You just had 2 commands to type:


Just had to know if grub was on hd0,0 or somewhere else. If you didn't know, you just had one additional command to find it.
That would have took 2 seconds, maybe up to 10 seconds if you type slow.

ceantuco 09-02-2008 11:17 AM

lol!!! if I knew it was that easy to fix I would've tried it! lol I just learned something new! lol I needed to start using this system asap so now it is going to take longer until it is fully configured and operational! lol thanks a lot. I'm writing the command you sent me on my little Linux pocket guide.
Last Thursday I run the following command to Mount a HD that had a viruses and I needed to have full permissions mount -t ntfs-3g /dev/hda1 /dev/cesar which worked fine and I was able to delete a virus from this HD. Do you think running the command above messed up something?

ceantuco 09-02-2008 11:31 AM

installation just finshed! I missed Linux all morning! lol :)

Agrouf 09-02-2008 01:14 PM

No, I don't think the command you typed could have messed something, although it is incorrect command and must have failed because you have to use a device and mount point, and not 2 devices with the mount command. Maybe /dev/cesar is a regular directory, but in this case you shouldn't put that in /dev.
Anyway, if you have a ntfs drive, I suppose you have Windows. And if you have Windows, it is highly likely that the mbr has been messed up from there since Windows doesn't know the existance of GRUB and ignores it. Instead, GRUB tries to make Windows think it is alone on the hard drive. Windows could have fucked grub silently and it wouldn't even make it feel bad!

lorebett 09-02-2008 01:23 PM

In case it happens again, I found this document quite useful:

ceantuco 09-02-2008 01:28 PM

sorry the command was mount -t ntfs-3g /dev/hda1 /MNT/cesar ... and yes, I have a dual boot system. Probably the virus that I was working on messed up my boot partition.

ceantuco 09-02-2008 03:37 PM

it wasn't the command I entered last week. I had to re-connect the same hd to my linux box and now when i rebooted the system it came up fine. I think it was the long weekend what damaged my boot loader! lol
Thanks guys!

Sinaz 09-03-2008 03:54 AM

I got the same error last week, but I was not sure where grub was so I had to find it first.

find /boot/grub/stage1
and then edited root on every kernel option...
Agrouf, will this do it for all kernels at once?


Agrouf 09-03-2008 04:09 AM

You could edit the file
Are you sure it was grub error 15?

Sinaz 09-03-2008 06:39 AM

I think so.
Somehow in each kernel root line it was pointing to an incorrect location say (hd0,0) instead of (hd0,2). What I don't understand is why that happened, I think windows has something to do with it because I wasn't able to boot windows either.

ceantuco 09-04-2008 01:10 AM

Hi Sinaz,

Did you do any Windows update? the machine that I have the issue with runs Suse and Windows xp. I remember last Thursday I had to connect that infected hard drive to the machine running xp to run a virus scan. I remembered I installed AVG free antivirus but then I rebooted the machine to use Suse and it worked just fine. I wonder if the AVG installation or a possible automatic windows update had something to do with it.
One thing I'm sure is that I didn't run any updates for OpenSuse.

Sinaz 09-04-2008 06:16 AM

No I didn't update windows but it's been having long shutdown times (several minutes) lately. I'm not really sure what happened because now it's my parents desktop computer and who knows what they have done to the poor machine! Anyway I was unable to boot linux nor windows until I found the solution I wrote above.
Could be that the hard drive is old? It's a seagate barracuda of 40 GB and it's been running for more than 6 years I think.

Anyway now linux is working again and what is better is that I have learned how to deal a bit with grub! ;)

All times are GMT -5. The time now is 04:23 AM.