Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 11-05-2009, 01:30 PM   #1
LQ Newbie
Registered: Apr 2007
Posts: 18

Rep: Reputation: 0
Grub Install causing problems

Hi All,

I recently wrongly installed Grub in HDA1 where my Windows XP C:\ drive was installed.Using grub-install /dev/had1 command using Linux Rescue.

Grub got installed properly,but I'm not able to boot windows as C: as
Grub installed in it. When I try to fix this problem by Windows Installable CD by going to recovery Wizard, it is not possible as Windows is not detecting that drive.I tried mounting NTFS drive in Windows to recover my data, but still i was not able to mount C: even in Linux.

[root@localhost ~]# mount -t ntfs /dev/hda1 /mnt/win/
mount: wrong fs type, bad option, bad superblock on /dev/hda1,
missing codepage or other error
In some cases us
eful info is found in syslog - try
dmesg | tail or so[/B]

I'm getting the above problem.

I have some important data in C:. Please help me to recover my C: data atleast.

Old 11-05-2009, 01:58 PM   #2
Registered: Nov 2009
Location: Lisbon, Portugal
Distribution: Gentoo, CentOs, Ubuntu, Debian
Posts: 182

Rep: Reputation: 49
Try to install gparted and try to fix trough there. It's a nice gui tool that list your partitions, and you can try to fix it from there.
Old 11-05-2009, 06:06 PM   #3
Registered: Sep 2007
Location: Missouri
Distribution: CentOS, and many others
Posts: 34

Rep: Reputation: 16
What does the /boot/grub/grub.conf file say that windows is trying to boot to, or is it not even in there? Can you do a "fdisk -l" (I think this is the command) and see the partition listed as ntfs? Which distro are you using, many distros do not support mounting ntfs right out of the box. I run CentOS and had to install 4 packages to get it to work right. The packages were fuse and fuse-ntfs-3g with "yum install fuse fuse-ntfs-3g", and dkms and dkms-fuse with "yum install dkms dkms-fuse". If you are running kernel 2.6.18-164 or newer I think that the fuse kernel module is included in the kernel itself, so you do not need to install the dkms and dkms-fuse modules. you also need to make sure the kernel devel packages are installed. Then you can mount it with "mount -t ntfs-3g /dev/hda1 /mnt/win/" in theory. The only way I have ever done it is by editing the fstab file. and using the mount command.
Old 11-09-2009, 04:31 AM   #4
LQ Newbie
Registered: Apr 2007
Posts: 18

Original Poster
Rep: Reputation: 0
thanks for the feedback..but...


I will try Gparted first. But to clarify..

I'm using Kernel I compiled the kernel with NTFS option enabled.I'm able to mount other NTFS drives.Only the C: in HDA1 is having this problem.
The reason for that problem is I worngly installed GRUB in that disk space.So, the first 512K is occupied by GRUB.
If I do a FDISK i can still see that /dev/hda1 is NTFS partition with * representing Boot device where GRUB is installed.I think the data in that drive is still in place.

Please help me to find the solution.

Old 11-09-2009, 04:33 AM   #5
LQ Newbie
Registered: Apr 2007
Posts: 18

Original Poster
Rep: Reputation: 0

Could you tell me how to edit the FSTAB file?
Old 11-09-2009, 05:44 AM   #6
Registered: Sep 2009
Location: Wirral, UK
Distribution: Red Hat Enterprise Linux / Fedora 11
Posts: 47

Rep: Reputation: 18
Originally Posted by arun4will View Post
Could you tell me how to edit the FSTAB file?
/etc/fstab.conf is edited as below:

/dev/sda1 /boot ext3 defaults,acl,usrquota 1 2


/dev/sda1 = Partition
/boot = Mount point
ext3 = Filesystem type
defaults,acl,usrquota = Options for the filesystem - defaults are fine, i've just added acl and usrquotas there for example.
1 = Backup related info, 1 is fine
2 = Priority for partition to be checked by fsck on boot.
Old 11-09-2009, 06:30 AM   #7
Larry Webb
LQ Veteran
Registered: Jul 2006
Location: Crystal Beach, Texas
Distribution: Suse for mail +
Posts: 5,100
Blog Entries: 7

Rep: Reputation: 229Reputation: 229Reputation: 229
Try using Super Grub to repair your mbr and it will help you boot your windows partition.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
grub install problems bigearsbilly Linux - General 6 07-02-2009 07:25 PM
GRUB install problems... (post windows install on ubuntu) sersdf Linux - Software 4 02-27-2009 08:59 AM
Grub install problems MrHnau Linux - Software 7 02-27-2007 01:45 PM
Re install of fedora core 6 on 2nd hard drive causing problems phipper Linux - Newbie 9 01-07-2007 03:01 PM
FC5 Clean Install causing Grub problem jfraymondpa Fedora 7 10-30-2006 07:04 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:28 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration