Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 03-05-2004, 04:59 PM   #1
Registered: Aug 2003
Location: DMZ
Distribution: Ubuntu
Posts: 144

Rep: Reputation: 15
GRUB - initrd !??

Hi Pals

I have Linux Red Hat 9.0 with kernel 2.4.20-8

I wanted to change some features in te kernel. so I compiled it and took the file "bzImage" and added it to the /boot directory and renamed it to vmlinuz-2.4.20-new side by side with my old vmlinux2.4.20-new

Now in the GRUB configuration file I copied and pasted the old kernel parameters except with changing the vmlinuz file name.

The line inird ... I left it the same.

But it failed to boot succesfully.

So it there anything to be done with the initrd line (wth is initrd by the way)
Old 03-05-2004, 05:07 PM   #2
LQ Guru
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Generate one using /sbin/mkinitrd
mkinitrd /boot/initrd-2.4.20-8 2.4.20-8

Its generally used for loading modules required to initialize your root filesystem. If you have these modules compiled directly into the kernel then it's not necessary to have one, but you need to change references to LABEL= in your /etc/fstab and /boot/grub.conf to the actual devices.
Old 03-05-2004, 07:48 PM   #3
Andrew Benton
Senior Member
Registered: Aug 2003
Location: Birkenhead/Britain
Distribution: Linux From Scratch
Posts: 2,073

Rep: Reputation: 64
Just delete the initrd line. You don't need it. It just changes the way the screen looks while the system is booting. I think it looks better plain.
Old 03-07-2004, 03:04 AM   #4
Registered: Aug 2003
Location: DMZ
Distribution: Ubuntu
Posts: 144

Original Poster
Rep: Reputation: 15
I have the following "grub.conf":

default = 2
timeout = 10
splashimge = (hd0,6)/boot/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-8)
root (hd0,6)
kernel /boot/vmlinuz-2.4.20-8 ro root=LABEL=/ hdc=ide-scsi
initrd /boot/initrd-2.4.20-8.img
title Red Hat Linux (2.4.20-8) Netfilter
root (hd0,6)
kernel /boot/vmlinuz-2.4.20-8-netfilter ro root=LABEL=/ hdc=ide-scsi
initrd /boot/initrd-2.4.20-8-netfilter.img
title WindowsXP
root no verify (hd0,0)
chain loader +1

I got the following Error while booting the second option "Red Hat Linux (2.4.20-8) Netfilter":

VFS: Cannot open root device "LABEL=/" or 00:00
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 00:00
Old 03-07-2004, 03:34 AM   #5
Registered: Oct 2003
Location: Iowa
Distribution: LFS 5.0, building 6.3, win98se, multiboot
Posts: 288

Rep: Reputation: 30
The easiest way to avoid this problem is to be certain that you compile in support for your root filesystem instead of compiling it as a module. Although as mentioned creating a new initrd should work.
Old 03-09-2004, 04:52 PM   #6
LQ Newbie
Registered: Mar 2004
Location: Crystal Lake, IL
Distribution: RH9
Posts: 4

Rep: Reputation: 0
Admitted Newbie, but...

I ran the mkinitrd as well as compiling in support for the FS and get the same result. I'm currently using RH9 also and my grub.conf looks almost identical.

Thanks in advance!
Old 03-09-2004, 04:57 PM   #7
Registered: Feb 2004
Location: Ottawa, Ontario, Can
Distribution: Slackware, ubuntu
Posts: 391

Rep: Reputation: 31
Make sure youve fixed all the symbolic links as well in both the grub config and the boot directory. I wouldnt bother with initrd, just comment out that line in grub. As for mounting the root filesystem, doublecheck it is pointing to the right partition. If that didnt work, its liklely the kernel was compiled wrong. Dont worry, it took me 4+ times to get my first compiled kernel working.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
manual grub: kernel ok, initrd fails with Error 16 alar Fedora 3 08-15-2005 01:03 AM
Grub, initrd and new kernel (2.6.10) wilu Linux - Newbie 3 02-25-2005 07:28 AM
What is "initrd" in grub.conf? captainstorm Linux - Newbie 2 07-30-2003 05:12 AM
Grub and initrd.img homestead1000 Linux - Software 2 07-25-2003 03:39 PM
initrd..img - grub.conf liguorir Linux - Software 2 06-29-2003 03:05 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:07 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration