-   Linux - Newbie (
-   -   Grub File Not found Grub Rescue Error on External Sata to USB Drive (

imayneed 08-19-2012 08:47 PM

Grub File Not found Grub Rescue Error on External Sata to USB Drive
I tried to install Linux Mint 13 KDE 64 bit from both CD and pendrive and I got the error explained in the thread title.
After the first install, I tried to reinstall grub, but this time I got
Stage 1.5 Grub loading, please wait, error 2.

I used Guided - Use Entire Disc option.

Am I doing something wrong?

Ztcoracat 08-20-2012 01:17 AM

Do you have another operating system already on the computer that your trying to install Mint on?

If so you have to use expert mode not guided.
For example:

When I installed Debian I had to allow 20GB for my Debian install and 1GB for the swap space.
When I didn't install using the expert mode I only had the grub rescue menu.

If you don't have another operating system already on your computer than it could be the cd/dvd.
I touched the underneath side of my first burn and had to go get the ISO file again and reburn to be able to install.
The other thing is that I learned is that it is wise to only obtain ISO from the Official Site;( in your case ) Linux Mint.
And make sure that you have the right files for your install based on the type of architecture your system is.


imayneed 08-20-2012 01:43 AM

I just finished a reinstall.
This time first, I created a GUID Partitioned Disk (from OS X on the PC).
And then from Manual in the installation options, I chose

200 MB GPT Protective Partition (Not used - Automatically created for GPT)
2 MB Reserved BIOS Boot
225 GB ext4 at /
19 GB (don't use this partition) (I just created maybe for a debian install later)
6 GB Swap

This way, it worked.
I guess, when creating with MBR Partition, and choose guided; there is a problem with the installation. I got the files from Mint site as I always do.
Since I had the problem with the MBR twice, I wanted to try GPT.
I guess I could have installed the bootloader to the / partition. I don't know which is better, a 2 MB Reserved BIOS or installing it to the partition.
I don't need a Debian install right away, but just to check how boot works, I might install after the updates are done and I am done with the settings.
Maybe it would have worked with the MBR too if I have chosen manual.
The point of guided installation (guided - use entire disk) should be 'being the easiest method'. Especially when the user decides to choose an entire disk for the operating system.Anyway, the manual installation is also pretty explanatory. If you don't mount a partition or boot; it warns you.
Thanks for your reply.


As soon as I restarted, it gave me:



So, I still don't know what am I doing wrong or what is wrong.

I am now installing Debian to sdc4 as /, sdc5 again as swap.
I didn't use the 2 MB as /boot and I am installing the bootloader to sdc.
Let'see what will happen. I will inform.

Ztcoracat 08-20-2012 02:17 AM

The installer made the grub bootloader for me. I didn't add it to the /.

I manually worked with my partition's also.
You should have

an ext3 that is used for the journaling file system and dedicate it to the /
Your swap space is rather big. I made my swap 1GB.

Look at all of the partitions and write them down. It helped me when I choose manual during the installation when it came time to manipulate the partitions. If I think of anything else; to try to help I'll post back. I have to sit back and think about this for a while.

imayneed 08-20-2012 02:54 AM

Installing Debian and installing the bootloader directly to the sdc didn't help either.
I got the error

Loading grub
Unknown file system

And this happened even after I updated the mbr with gptsync from gparted.

I made the swap 6GB because when I chose Guided-Use entire disk, it automatically created a 6GB swap, most likely because my RAM is 6GB.

So, still no go. I will think and search about what could this error be also.
I mean Linux can be installed on an external USB. I have installed and running it from USB Flash also.

I can dedicate this entire disk for this Linux installation. So, anyway works for me.
One Linux installation, two Linux installations (just in case, something goes wrong with the first one), MBR, GPT, but couldn't so far.

Thank you.

jefro 08-20-2012 03:44 PM

I am having a similar issue so I will add that many posts suggest "boot-repair". I tried it and can't fix my issue but maybe try it on yours.

Ztcoracat 08-20-2012 07:38 PM

Ok had time to think a while on this. Sometimes it can be a little confusing when your dealing with the partition manager in the installer.
It was confusing for me and it took me three times to install Debian 6.0.5 correctly.

When you first start the install choose manual.
Than you'll go thru the keyboard setup, time and the clock, and DHCP and etc. Use Expert Mode

1. When it's time to work with the partitions (you'll need to make 2)the partition manager should show you all partitions and Free Space.
Arrow down to your Free Space. Highlight your free space and Create a new partition and dedicate it to the Journaling File EXT 4 or 3 (whichever you have) Before you finish creating your first partition make sure that you indicate the / ( mount point) Finsish creating partition.

2. Highlight with you up/down arrow keys the Free Space; hit enter; create your next partition that your are dedicating to the swap. Finish making the 2nd partition. The installer should say something like:
Make changes to new partition and write to disk.

3. After you create those partitions you should be asked about the mount points. The installer will ask you if you want them at the Beginning or the End. Choose End.

4. The installer at this point should start to install all of the files and when complete it should pop open your cd/dvd drive and your new OS should be installed.

Like I said before Imayneed; it took me a few times to get it right. I struggled with the installation because there were things I did not know. Once I knew I had to ignore my ntfs and Windows Recovery and create new partitions from the Free Space it was ok.
Everyone's system is different. It is my sincere hope that your able to get your Mint or Debian installed.
Don't give up; it will work indubitably. Perseverance gave me my new system.

And, if your installing on a Mac; I'm sorry I don't have any knowledge on them.

Ztcoracat 08-20-2012 09:26 PM

If you have a Mac this might help.
If I misunderstood you; I'm sorry.

Trying to help-

imayneed 08-21-2012 07:07 AM

Thanks, I will try again and inform.

No, it is not a mac. It is an ASUS G72 Notebook, but the drive is an external USB Drive.

Oh, when I said mac in my second post, I meant the OS. I edited the post so there would be less confusions.
And that OS X is in an internal drive. I am trying to install Linux on an external drive.

jefro 08-21-2012 07:04 PM

Did you try the boot-repair?

Ztcoracat 08-21-2012 10:41 PM

In that case you can try this thread:
I used Google to find this thread and there were others as well.

I have a 500GB external Toshbia hard drive but I have not put a operating system on it.
And, in honesty; don't know how-

imayneed 08-22-2012 02:56 AM

I haven't tried boot repair yet. I had to deal with a MS Project project.
I checked the link and as soon as I try it, I will inform.

Last link about the drive didn't work for me.

All times are GMT -5. The time now is 07:46 AM.