LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   grub failed to load linux (grub think ext3 partition as fat) (https://www.linuxquestions.org/questions/linux-newbie-8/grub-failed-to-load-linux-grub-think-ext3-partition-as-fat-575108/)

khairilthegreat 08-06-2007 10:41 AM

grub failed to load linux (grub think ext3 partition as fat)
 
I cant boot to my linux.

Grub says:
Code:

Booting'Ubuntu, kernel 2.6.15-23-386'
root(hd1,0)
Filesystem type is fat, partition type 0xC
kernel /boot/vmlinuz-2.6.15-23-386 root=/dev/hdc1 ro quiet splash

Error 15 : File not found

If I use ubuntu instalation CD then in the menu screen I choose boot from first harddisk, I can boot into Ubuntu. Grub says
Code:

Booting'Ubuntu, kernel 2.6.15-23-386'
root(hd1,0)
Filesystem type is ext3, partition type ...(I forget)
kernel /boot/vmlinuz-2.6.15-23-386 root=/dev/hdc1 ro quiet splash
.....
.....
.....

and grub load Ubuntu.

How to solve this problem? I've tried to reinstall grub, but no luck. The only way I can boot to ubuntu is using the CD.

Thanks in advance.

pixellany 08-06-2007 10:58 AM

I expect that somehow the installed system is seeing the disks and partitions differently. When running from the installed Linux (on the hard disk), open a terminal and enter "fdisk -l" ( It might need to be "sudo fdisk -l"). Post the results here + relevant details of your configuration. e.g. what is on hda and hdb?

saikee 08-06-2007 12:26 PM

Do what pixellany told you to and supply the output of "fdisk -l".

Ubuntu's installer may be using a kernel still able to see a pata disk but an installed Ubuntu will use the latest kernel that sees a Pata same as the Sata/SCSCI/USB hard disk family. Thus there may be a problem in the naming of the hard disks and partitions.

You can prove this theory by posting "fdisk -l" in the Live CD and then boot up the installed version and post the 2nd "fdisk -l".

khairilthegreat 08-09-2007 08:01 AM

This is the content of fdisk -l.

Code:

root@ns:/# fdisk -l

Disk /dev/hda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start        End      Blocks  Id  System
/dev/hda1  *          1        1275    10241406    c  W95 FAT32 (LBA)
/dev/hda2            1276        5099    30716280    c  W95 FAT32 (LBA)
/dev/hda3            5100        9493    35294805  83  Linux
/dev/hda4            9494      14592    40957717+  f  W95 Ext'd (LBA)
/dev/hda5            9494      14592    40957686  83  Linux

Disk /dev/hdc: 41.1 GB, 41110142976 bytes
255 heads, 63 sectors/track, 4998 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start        End      Blocks  Id  System
/dev/hdc1  *          1        1216    9767488+  83  Linux
/dev/hdc2            1217        1338      979965  82  Linux swap / Solaris
/dev/hdc3            1339        4998    29398950  83  Linux

The two drive is PATA.

I have Ubuntu in /dev/hdc1, and Windows XP in /dev/hda1.

My box is installed with ubuntu 6.06 dapper.

This problem emerged when I reinstall my box. What confuses me is I reinstalled the computer with the same ubuntu version (6.06). The previous installed version doesn't produse any problem.

pixellany 08-09-2007 08:23 AM

Try editing the /boot/grub/menu.lst so that the Ubuntu entry has:
root (hd2,0)

(Or try this at boot time---when the grub menu comes up, hit the tab key to stop the countdown, then "e" for edit. You can now try different grub commands.)

You could also change the IDE cabling and jumpers so that the system would see the drives as hda and hdb.

khairilthegreat 08-09-2007 10:07 AM

I tried what you suggest but no luck. Grub says device not exist.

I look into device.map and it contains
Code:

(hd0)        /dev/hda
(hd1)        /dev/hdc

which I think the correct entry, because my drive is /dev/hda and /dev/hdc.

I really don't want to change any jumper. I do no hardware changes when I install the computer. Grub work previously and it drive me crazy why it doesnt work now. All the configuration (hardware) is not changed.

What confuses me more is why I can boot when I use the installer CD. You know when I insert the installation CD into my drive, then the CD will prompt me with option
Code:

Install in text mode
Install a server
....
....
....
Boot from first harddisk

If I choose boot from first harddisk, it will then proceed to my grub menu. The same grub menu as before, then I can boot into ubuntu.
Quote:

(Or try this at boot time---when the grub menu comes up, hit the tab key to stop the countdown, then "e" for edit. You can now try different grub commands.)
What kind of command to trouble shoot this problem?

Its really confusing.

jay73 08-09-2007 10:20 AM

You need root (hd1,0).

pixellany 08-09-2007 12:12 PM

Quote:

You need root (hd1,0).
Which is what he had in the original post...but there was no space after "root".
How about trying root (hd1,0) in the grub interactive mode at bootup? You can also try the grub "find" command.
http://www.gnu.org/software/grub/manual/grub.html#find


All times are GMT -5. The time now is 08:49 AM.