-   Linux - Newbie (
-   -   GRUB error 21 upon installation (

viticus 07-18-2007 02:05 PM

GRUB error 21 upon installation
Here is my setup:
I have a stripe RAID of two drives for XP pro. I've been wanting to try linux out for a while now and picked up a Ubuntu live cd. I installed a third hard drive specifically to play around with linux. I put the live cd in the drive and booted from the cd. This is where the first problem occurred: I had to install w/ noapic.
The cd booted up. I went through the installation, partitioning as I should. Once finished I tried to reboot my pc. I guess it defaults to reboot from the HD with the newly installed linux OS. When it trys to boot from this drive, it freezes at the "verifying" stage.
I reset, went into BOOT MENU changed it to boot from my RAID drives, then I get the GRUB error 21. I tried to reset and noticed at the prompt that my RAID drives do not show up there, only my linux HD. I checked my BIOS, the RAID drives do not show up there either.

Any advice helpful. I've found multiple listings from google, mainly about bootloaders and fdisk \mdr commands. I'm not familiar with how to use this stuff.

SCerovec 07-19-2007 12:17 PM

Buddy, seems You disassembled Your RAID array?
A heavy data-rescue seems eminent :-(
Try to reassemble/ fix Your RAID without that 3rd HDD first.
Afterwards, allways play with the RAID off-box ;-)

viticus 07-19-2007 04:51 PM

What do you mean play with the RAID off-box?

I've done this over and over again. I boot my RAID for xp. then i install my 3rd hard drive for linux and then install it. regardless, i get still get a GRUB 21 error. I read about a couple of commands but I'm not sure where or how to use them:

fdisk \mdr
fdisk -l

would these help? something about my bootloader may have installed improperly. any ideas?

Le Beastie 07-19-2007 07:28 PM

It sounds like RAID and regular HDs don't play well with Grub. I could be wrong, but I think "off-box" means isolating the two sets of drives from each other (the multi-disk RAID drive and the regular drive, that is). Perhaps the safest thing to do would be to temporarily remove your RAID drives from the boot order (if you can do that; I don't have much experience with RAID) when you want to boot into linux, and set the linux distro up without a boot loader. (Because you'll be booting directly to the third HD, which only has linux on it).

By the way, is your RAID setup okay? It sounded like you might have somehow lost it in your BIOS.

viticus 07-19-2007 08:58 PM

yeah my RAID disappeared. I don't know where there crap it went. Luckily I back everything up before I ever decide to start experimenting. I'm just going to try and start from scratch. I'm going to try without the RAID, and only use 2 HDs. I'll just have a spare for now. I'll put xp on one and try linux on the other. wish me luck. "I'm goin in" :)

SCerovec 07-20-2007 04:12 AM

"OK man, we will cover You" :D
Really be carefull regardnig grub's device mapping against Your RAID array ;-)
I still would do it with RAID off-box ;-) --> lesser headache that way...

viticus 07-20-2007 11:11 AM

All right fellas, here's what I've done now. I took out the third HD. No problem.

So I install windows first, on its own HD.
Then I install a second HD. I then boot from my Ubuntu live cd and installed it. I tried putting the boot loader(which I have finally figured out how to mess with) on the Linux HD. When I restart, I choose to boot from the Linux HD. It gives me the OS selection menu. Nothing will boot from this menu. Both OSs give me errors(Ubuntu is error 17 & windows is error 13).

Now if I try to boot from the Windows HD, it boots windows right up.

It seems like there's a boot loader issue. Any ideas?

C'mon guys, we're almost there. I can feel the energy of the Decepticons!!

SCerovec 07-21-2007 03:17 AM

"What we got here is failure to comunicate..."

buddy, You got yourself a double_device_remapping problem which is a serious issue.

1. When You tell Your BIOS to boot from the (wild guess) 2nd HDD with Linux, it remaps the drives:
1st Master -> 1st Slave
1st Slave -> 1st Master
Then You land in the grub and it seeks for (hd0,0) as the windows partition, which now (thanks to BIOS) shows on Ubuntu's 1s partition, and then tries to 'chainload +1' ubuntu's root partition's 1st block. This ain't working normally :-)
Try this out:
get to the GRUB's console

root (hd0
the type [tab] to see the patitions of the '1st' drive
then edit it to

root (hd1
and redo

All times are GMT -5. The time now is 08:10 PM.