-   Linux - Newbie (
-   -   GRUB Error 2 + a weirdly uncooperative BIOS = confusion (

nsreporter 01-18-2010 04:22 AM

GRUB Error 2 + a weirdly uncooperative BIOS = confusion
Hi, I'm brand new to Linux, and trying to get a system up and running. I had an old cd with Ubuntu 5.1 on it, and installed it on my computer (erasing the previous inoperable system); it seemed to work fine for a day or so, but I wasn't finding support online for any of the programs, so I wanted to upgrade. I'd heard KDE was good, so i downloaded Kubuntu 9.10 and made the disc.

The hash check worked fine, and the live disk option seemed to work perfectly, but when I tried to install the system (again over previous system) I get a Grub 1.5 loading -- error 2. And then everything stops.

I looked this up online, and most people who said they solved it did so by monkeying with the hard drive settings in their BIOS. But when I went into my BIOS setup, it was very strange: it's something called PhoenixBIOS and it gives me basically *no options at all* beyond changing the system time and the boot order ... it doesn't even appear to detect my hard drives! (Now, I haven't played with a BIOS setup since the mid-90s, so maybe I'm doing something really wrong... )

I looked for other solutions -- someone recommended a supergrub disk, but I can't find the file for this. I also tried re-installing Ubuntu 5.1, which worked, and then re-installing Kubuntu as a separate partition rather than an overwrite -- but Kubuntu just doesn't appear as an option in the boot menu.

I've seen a number of discussions of similar problems on forums but most are 1) totally beyond me, and 2) don't seem to have actually solved the problem. Does anyone have any idea how I can either fix the Grub issue or get my BIOS to behave?


yancek 01-18-2010 10:50 AM

How old is this computer?
Phoenix is one of the major BIOS chipset manufacturers, you should have more options than you describe?
Kubuntu 9.10 uses Grub2 which is still beta and your old Ubuntu uses the previous Grub legacy. If you use the Ubuntu Grub to boot, you will need to manually place an entry for it in the /boot/grub/menu.lst file. If you install Kubuntu version of Grub to the master boot record, it should detect the Ubuntu 5.1 and put an entry in its boot file.

Ubuntu 5.1 is pretty old and there is no support for it.

nsreporter 01-18-2010 02:03 PM

Thanks for the reply. It's a 2006 HP Pavilion, bought in the Middle East. I'm really surprised about the BIOS, too -- it looks as if they've factory locked it or something, but I'd never heard of that being possible.

So, I got the machine working about an hour ago -- surprisingly, by installing regular Ubuntu 9.10, which I would have expected to have the same GRUB error... and it's pretty convenient for a Windows refugee. Am I missing anything, aside from a funky blue color scheme, by not getting KDE to work?

I guess the urgency is passed, but I'd still like to know if anyone has a guess why my BIOS is so strange ...

jefro 01-18-2010 04:09 PM

Ultimate boot cd has a few tools to play with bios. All bio's seem to be lousy. No matter where you bought it HP has support for it. Might look for any bios updates that directly talk about this issue.

I suspect that you can get this working by using the live cd to determine your hardware and install and compare it to grub's config. Try also to boot to cd and then select boot from hard drive.

When you booted to live cd run the check disk is that what you did?

All times are GMT -5. The time now is 06:29 AM.