Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 01-22-2009, 07:50 PM   #16
LQ Addict
Registered: Oct 2003
Location: Australia
Distribution: MX 18/ TC64
Posts: 5,301

Rep: Reputation: Disabled


the bootloader is still the windows bootloader that is linked at mbr. I believe the original question is up to answer....but he may need to read how to use a rescue cd first...and howto fixmbr for windows in case he puts grub into mbr.


forgive me for any pressure you may feel but here are the 2 alternatives for you

bios jumps to mbr to find bootable partition ->
either windows or linux is linked to mbr but not both


install grub to mbr

boot live cd
root (hd0,1) 
setup (hd0)

you MUST see a end line that says succeeded...meaning mbr has a stage1 grub file that is linked to jump to balance of booting files at sda2....grub counts from zero

reboot computer

since I can not easily explain that non-visually let revisit your linux entry
title Ubuntu 8.10, kernel 2.6.27-7-generic
uuid 7ef466f2-9561-4b3f-9391-a2ed54e387de
kernel /vmlinuz-2.6.27-7-generic root=UUID=ba79e001-bf29-43d1-9a69-50aae1d475ed ro quiet splash
initrd /initrd.img-2.6.27-7-generic

The uuid entries must match the other entries you have posted for UUID

and your uuid entry shows

/dev/sda2: UUID="7ef466f2-9561-4b3f-9391-a2ed54e387de" SEC_TYPE="ext2" TYPE="ext3"

/dev/sda5: UUID="ba79e001-bf29-43d1-9a69-50aae1d475ed" SEC_TYPE="ext2" TYPE="ext3"

so the first mention of UUID takes grub to a partition called sda2 and that is correct

the second mention of UUID says root = (sda5) and that appears to be correct.

As you have a separate /boot partition to / partition.

Please report if you remember not doing this?

SO altho I do not like Ubuntu...etc...this entry may work as is.

b) but typical of ubuntu they have made the chainloader command section too messy

here it again.
# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Professional
root (hd0,0)
chainloader +1

# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda2
title Windows NT/2000/XP
root (hd0,1)
chainloader +1

Can I ask that when you reboot...boot into linux first then get root powers and delete those lines called

what savedefault does is ...treat you like an idiot....and so when you boot into makes that the new default for all new reboots...and we would like you to learn more about linux!!

SECOND whine is ubuntu has stuffed up and decided to create an sda2 entry for windows not realising its a linux delete that entry please


This option is if you decide not to put grub into mbr but chainload it from windows

1) redo grub for its root=boot partition

boot live cd
root (hd0,1) 
setup (hd0,1)
last line must say succeeded to hd0,1

2) then follow the steps in my signature to take a image of that new (almost mbr like part of /boot partition.....

reboot to windows and edit your bootloader to chainload it
Old 01-28-2009, 12:35 AM   #17
LQ Newbie
Registered: Jan 2009
Posts: 8

Original Poster
Rep: Reputation: 0
Ok, so I kind of got fed up with this and decided to just install grub to the mbr...I repartitioned my hard drive from what i had before and just used the default option to install grub in hd0, and magically everything seems to work. I spoke with some people who said that if I have the backup cd's I made from the service partition, then I really don't need it anymore anyway, so there's no need to go through all this hassle to try and make a separate /boot partition instead of overwriting the mbr (since the only reason I was doing this was to maintain access to the service partition). Anyway, after running through the install again and installing one or two recommended drivers (for the discrete graphics and trackpoint scrolling features) everything seems to be working fine. I just switched the order of my titles in the menu.lst file and so even configured the grub menu with the correct default OS (windows) and my preferred order in the menu. So I guess that's that.

Again, thanks to everyone who helped. It was a frustrating couple of days (more like a week I guess) but I learned a lot about what goes on when you boot a computer and what goes into installing Linux, so hopefully that will help me along the way. Take care.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 8.04 on dual boot Grub does not find Windows XP ronmettler Linux - Newbie 4 05-02-2008 08:38 AM
Ubuntu/Windows dual boot Grub problems ryanxav Linux - Newbie 14 10-21-2007 01:00 PM
grub dual boot ubuntu/windows dellcom1800 Linux - General 1 01-25-2007 06:02 AM
Grub will not load Windows XP with Ubuntu dual boot Alex4R Linux - Software 1 03-26-2005 11:29 AM
Dual boot GRUB - Won't recognize XP partition Travis S Linux - Newbie 3 01-31-2004 11:58 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:34 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration