LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-07-2006, 04:29 PM   #1
mohtasham1983
Member
 
Registered: Apr 2005
Location: San Jose
Distribution: Fedora 3,4- Ubuntu 6.06 to 8.10, Gentoo and Arch
Posts: 408

Rep: Reputation: 30
grub doesn't detect wireless keyboard


I have installed Fc4 recently on my machine and it is the default OS in grub.
I cannot switch to windows,because my wireless keyboard is not detected in grub and Fc4 autmatically starts.
Is there anything which I can change in /etc/gurub.conf?
 
Old 03-07-2006, 05:29 PM   #2
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
Chances are neither does your bios. Try entering the BIOS with your keyboard.

If that doesn't work, then connect a PS2 keyboard and see if there is a setting in the BIOS that will allow you to use USB keyboards.

If no setting exists, try a USB-->PS2 converter for your wireless keyboard.

If that doesn't work, you're SOL...
 
Old 03-08-2006, 11:40 AM   #3
mohtasham1983
Member
 
Registered: Apr 2005
Location: San Jose
Distribution: Fedora 3,4- Ubuntu 6.06 to 8.10, Gentoo and Arch
Posts: 408

Original Poster
Rep: Reputation: 30
Is there any way to disable gurub at boot and use windows boot menu instead? Because in windows boot menu keyboard can be detected.

Last edited by mohtasham1983; 03-08-2006 at 02:07 PM.
 
Old 03-08-2006, 03:07 PM   #4
pljvaldez
LQ Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Wheezy (x86)
Posts: 6,094

Rep: Reputation: 271Reputation: 271Reputation: 271
Yes but it's kind of involved. http://jaeger.morpheus.net/linux/ntldr.php

Basically, you have to:
1) reinstall grub to the root partition of your linux install, edit config files as required
2) restore the windows master boot record
3) Edit boot.ini to allow it to chainload grub from the other partition

Although you still might not have use of your keyboard if grub is actually the problem...
 
Old 03-09-2006, 01:57 AM   #5
arunvk
Member
 
Registered: Nov 2005
Location: India
Distribution: Fedora 11
Posts: 194

Rep: Reputation: 30
boot to windows and restore the mbr with 'fdisk \mbr'

but ofcourse i guess ur problem is not able to boot into windows.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless Keyboard not working to select boot options (Grub boot loader) psrini_vasan Fedora 7 12-16-2009 05:45 PM
knoppix 3.8 does not detect the keyboard, 3.4 does theory_prof Linux - Newbie 4 05-14-2005 07:42 PM
Need help to detect keyboard sugreer Linux - Hardware 1 07-11-2003 07:51 AM
I just downloaded Mandrake 9.0 and it won't detect the keyboard... HGeneAnthony Linux - Hardware 4 03-18-2003 05:51 AM
Slackware 8.0 doesn't detect keyboard mrned Linux - Software 2 10-26-2001 09:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration