LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   GRUB boots XP RECOVERY partition instead of XP. (https://www.linuxquestions.org/questions/linux-newbie-8/grub-boots-xp-recovery-partition-instead-of-xp-450023/)

Miah 05-30-2006 05:39 PM

GRUB boots XP RECOVERY partition instead of XP.
 
After installing Fedora Core-4 on a dual boot hd with XP professional, the default Fedora worked like a charm!(perfect). But when I tried to use windows I could only boot into the recovery partition (which erases everything and reinstalls windows XP ).

I tried hitting "e" for edit and bumping rootnoverify(hd0,0) up to rootnoverify(hd0,1) but it still booted into recovery. I think I tried rootnoverify(hd0,2) but around that point I accidentally entered recovery and wiped everything out.

I then tried deleting the recovery partition (after windows came back) and re-installing Fedora. This worked great and I could boot into either system.

However, I would like to make it work with the recovery partition if possible because it is very fast to recover compared to using DVD.

Does anyone know a (rather simple) workaround for this problem? I don't have a very good understanding of the boot process.

Thank you for any help anyone can give.

Miah in Maine

detpenguin 05-30-2006 09:08 PM

i multi-boot using grub on a system with xp, and the recovery partition...this is my grub entry for xp:

Quote:

# Other bootable partition config begins
title XP
rootnoverify (hd0,1)
makeactive
chainloader +1
# Other bootable partition config ends

whipermr5 05-30-2006 11:03 PM

Can you post the results of
Code:

fdisk -l
?

Miah 06-06-2006 12:00 PM

whipermr5: I did not use fdisc,I used QTparted.It showed the recovery partition as the first and XP as the second.

detpenguin: Your information inspired me to keep on with the (hd0,1) idea, even though it did not work when pressing "e" for edit during bootup.

I tried using a shell and vi to make a file that copied your grub entry.When I browsed to the file I was denied access because I was no longer root.You would laugh to see the trouble a newbie had trying to "enter as root".

NEWBIES READ THIS: To "enter as root" (the phrase I've always read) you more specifically (and so simply) type the word root at the prompt for user name--enter as "user name" root.

After becoming root I easily opened the installed grub file and changed the delay to 15 seconds,other to windows XP, and (hd0,0) to (hd0,1) and all worked perfectly. I then experimented until I proved that the critical entry was (hd0,1).Apparently grub did not respond to the temporary editing using "e" at boot time.

Thank you both for responding,it is very selfless for experienced people to take the time to help newbies, and it's nearly impossible to guess what sort of silly mistake an inexperienced person can be making.

Miah in Maine


All times are GMT -5. The time now is 12:45 PM.