-   Linux - Newbie (
-   -   groupadd: unable to lock group file?! (

macagent 08-05-2003 05:34 AM

groupadd: unable to lock group file?!
I am trying to get a 'fresh' install of RH9 running on my server. I installed everything, then ran up2date to get current.

After that, I was unable to groupadd or useradd.

Each time it gave me the unable to lock group (or passwd) file.

Yes, I am logged in as root (root is the only user on the machine thus far).

I Googled everywhere and cannot find an answer to this question. Maybe the replies to this question will help other noobs out there having the same problem.

P.S. I know my way around UNIX, but have never seen this problem before on my OSX Servers.

acid_kewpie 08-05-2003 05:53 AM

i *think* the lock file is /etc/ptmp or somethign very similar to it, what possi8bly happened was that a previous uise creashed without removing that lockfile.

macagent 08-05-2003 06:11 AM

I can't find a file by that name. Even if I did, what would I do to fix the problem?

acid_kewpie 08-05-2003 06:48 AM

delete it... try looking at the output of dmesg or the end of /var/log/messages to see if it's sayign somethign more indepth there

precore 09-11-2003 02:22 AM

Remove Lock file
I don't know if you ever got this fixed however I ran into the same problem and this fixed it.

needed to remove a lock file
remove hidden file .pwck.lock or .pwd.lock in /etc/

ksteward 10-08-2003 02:07 AM

i bumped into the same problem. Turned out that there were stale lock files in /etc: passwd.lock, gshadow.lock, shadow.lock, etc. Deleting these re-enabled the groupadd function.


Ordinary12 07-08-2007 05:31 PM

I'm using Ubuntu Feisty Fawn version and I need to know which files I should delete. I have two of each one. One has a red box in the top right corner while there other does not. Each file has one like this. Should I delete them both or just one of them?

All times are GMT -5. The time now is 10:49 AM.