LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-11-2020, 05:18 AM   #16
djoe_dev
LQ Newbie
 
Registered: Jul 2020
Posts: 18

Original Poster
Rep: Reputation: Disabled

sure thing, here it is

Code:
inxi -GSxxza
System:
  Kernel: 5.4.0-40-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  parameters: BOOT_IMAGE=/vmlinuz-5.4.0-40-generic 
  root=UUID=e219ad11-7ab4-49da-8d85-d5421478c70b ro quiet splash nomodeset 
  vt.handoff=7 
  Desktop: Gnome 3.36.3 wm: gnome-shell dm: GDM3 3.34.1 
  Distro: Ubuntu 20.04 LTS (Focal Fossa) 
Graphics:
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
  vendor: XFX Pine driver: N/A bus ID: 28:00.0 chip ID: 1002:731f 
  Display: x11 server: X.Org 1.20.8 driver: ati,fbdev 
  unloaded: modesetting,radeon,vesa compositor: gnome-shell 
  resolution: 3840x2160~88Hz 
  OpenGL: renderer: llvmpipe (LLVM 10.0.0 128 bits) v: 3.3 Mesa 20.0.8 
  compat-v: 3.1 direct render: Yes
 
Old 07-11-2020, 05:20 AM   #17
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 2,610
Blog Entries: 1

Rep: Reputation: 855Reputation: 855Reputation: 855Reputation: 855Reputation: 855Reputation: 855Reputation: 855
Quote:
Originally Posted by djoe_dev View Post
Code:
...
parameters: BOOT_IMAGE=/vmlinuz-5.4.0-40-generic 
  root=UUID=e219ad11-7ab4-49da-8d85-d5421478c70b ro quiet splash nomodeset
The amdgpu DDX cannot load until you boot without nomodeset.
 
1 members found this post helpful.
Old 07-11-2020, 05:22 AM   #18
djoe_dev
LQ Newbie
 
Registered: Jul 2020
Posts: 18

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by mrmazda View Post
The amdgpu DDX cannot load until you boot without nomodeset.
right and if trying to boot with nomodeset off, it freezes everytime. is there a way to open a terminal right before i enter my password so that i could possibly get some output that may indicate why it's freezing?
 
Old 07-11-2020, 05:29 AM   #19
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 2,610
Blog Entries: 1

Rep: Reputation: 855Reputation: 855Reputation: 855Reputation: 855Reputation: 855Reputation: 855Reputation: 855
When the GUI is frozen, does Ctrl-Alt-F3 reach a login prompt?
 
Old 07-11-2020, 05:32 AM   #20
djoe_dev
LQ Newbie
 
Registered: Jul 2020
Posts: 18

Original Poster
Rep: Reputation: Disabled
it did not but i can try again. i was also reading somewhere about this:


Quote:
Hey I got this to work just now by disabling IOMMU in the BIOS -- examining the logs from the failed boots showed that it got hung up during IOMMU allocation.
from this thread here: https://forum.manjaro.org/t/rx5700-n...x5700xt/145677

im gonna look into my bios and see if i can find a setting with IOMMU or possibly a linux setting here:

Quote:
The following are workarounds for this issue:

If a user requires IOMMU configurations, use the RAID700 (LSI 9260 RAID card) or RAID710 (LSI 9270 RAID card).
Disable IOMMU in system BIOS setup by setting “Intel VT-d” to Disabled. The typical menu entry for this option is:

Advanced -> Chipset Configuration -> Intel VT-d

Disable IOMMU in Linux by adding “intel_iommu=off” to the Linux kernel bootup parameter.
Install Linux without the “tboot” software package.
 
Old 07-11-2020, 05:42 AM   #21
mrmazda
Senior Member
 
Registered: Aug 2016
Location: USA
Distribution: openSUSE, Debian, Knoppix, Mageia, Fedora, others
Posts: 2,610
Blog Entries: 1

Rep: Reputation: 855Reputation: 855Reputation: 855Reputation: 855Reputation: 855Reputation: 855Reputation: 855
Quote:
Originally Posted by djoe_dev View Post
find a setting with IOMMU or possibly a linux setting here:
Maybe amd_iommu=off. kernel-parameters.txt has others to try.
 
Old 07-11-2020, 05:47 AM   #22
djoe_dev
LQ Newbie
 
Registered: Jul 2020
Posts: 18

Original Poster
Rep: Reputation: Disabled
i found the iommu setting in my bios, and disabled it was set to Auto. I was able to boot into linux without it freezing!

I went to terminal and retyped my command and got

Code:
$ inxi -GSxxza
System:
  Kernel: 5.4.0-40-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  parameters: BOOT_IMAGE=/vmlinuz-5.4.0-40-generic 
  root=UUID=e219ad11-7ab4-49da-8d85-d5421478c70b ro quiet splash nomodeset 
  vt.handoff=7 
  Desktop: Gnome 3.36.3 wm: gnome-shell dm: GDM3 3.34.1 
  Distro: Ubuntu 20.04 LTS (Focal Fossa) 
Graphics:
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
  vendor: XFX Pine driver: N/A bus ID: 28:00.0 chip ID: 1002:731f 
  Display: x11 server: X.Org 1.20.8 driver: ati,fbdev 
  unloaded: modesetting,radeon,vesa compositor: gnome-shell 
  resolution: 3840x2160~88Hz 
  OpenGL: renderer: llvmpipe (LLVM 10.0.0 128 bits) v: 3.3 Mesa 20.0.8 
  compat-v: 3.1 direct render: Yes
 
Old 07-11-2020, 06:01 AM   #23
djoe_dev
LQ Newbie
 
Registered: Jul 2020
Posts: 18

Original Poster
Rep: Reputation: Disabled
actually, my bad. still in the same boat after iommu change. i thought i had disabled nomodeset, but made a mistake and did not reset grub afterwards, in which case i had booted into linux thinking the iommu setting changed something this time but upon checking i saw nomodeset was still enabled.

upon disabling it properly, i got hung up at boot. also if i hit ctrl alt f3 at enter password screen, it freezes upon trying to open the terminal.

so something really finicky going on unless i disable nomodeset.
 
Old 07-11-2020, 07:58 AM   #24
djoe_dev
LQ Newbie
 
Registered: Jul 2020
Posts: 18

Original Poster
Rep: Reputation: Disabled
Hooray, fixed it!

disabling iommu in my bios and setting

Code:
sudo nano /etc/default/grub

change line :
GRUB_CMDLINE_LINUX=""

to:
GRUB_CMDLINE_LINUX="amd_iommu=on iommu=pt"
and make sure to...

Code:
sudo update-grub && sudo reboot
believe me i know how confusing this sounds because bios has iommu off and amd has it on and idk what iommu=pt even means but when i had these settings the way they are listed above, i was able to boot into ubuntu with no freezing, i was able to confirm my driver is now amdgpu and i was able to finally set fractional scaling - it fixed all of my graphic issues.

upon fixing the issues, i went back into the grub file and changed it back to

Code:
GRUB_CMD_LINUX=""
and updated grub and restarted and it did still boot fine and everything still works fine.

so although i don't fully understand what i did, ill just leave this info here hoping it helps someone else who may come across this issue in the future. thanks for helping me guys, definitely gave me motivation to find a solution!
 
Old 07-11-2020, 04:52 PM   #25
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 4,703

Rep: Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872
Well done, and thanks for sharing your findings. iommupt=pt (means allow passthrough). Usually used in thecontext of virtual machines to allow guests to have exclusive access to PCI devices eg video cards. Perhaps in this context it allows the AMD IOMMU driver to have this required direct memory access.

I don't see 'on' as an option in the kernel parameter list...
Quote:
amd_iommu= [HW,X86-64]
Pass parameters to the AMD IOMMU driver in the system.
Possible values are:
fullflush - enable flushing of IO/TLB entries when
they are unmapped. Otherwise they are
flushed before they will be reused, which
is a lot of faster
off - do not initialize any AMD IOMMU found in
the system
force_isolation - Force device isolation for all
devices. The IOMMU driver is not
allowed anymore to lift isolation
requirements as needed. This option
does not override iommu=pt
but like the tutorial you found it is mentioned as being required in conjunction with 'iommu=pt' to be effective. For example, this reddit thread.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I have installed Bhodi Linux but the graphics interface is not seen correctly SaloCB Bodhi 1 07-29-2018 04:03 PM
"the system is running in low-graphics mode" ==> your screen,graphics card and input device setting could not be detected correctly.you will sachinmm Linux - Software 8 01-04-2016 12:28 AM
Graphics driver and wireless LAN driver are not working on dell N5010 for RHEL 5.7 TnG Linux - Laptop and Netbook 2 05-24-2012 04:09 PM
[SOLVED] Wicd won't install correctly/run correctly (64-bit Slackware 13) bgraybr Slackware 3 04-01-2010 06:57 PM
Sound and Graphics not working in Intel D101GGC with ATI graphics and Realtek audio sanu1 Linux - Hardware 2 12-28-2008 07:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration