LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-12-2005, 05:32 AM   #1
Xyem
Member
 
Registered: Apr 2005
Distribution: Fedora Core 4
Posts: 100

Rep: Reputation: 15
Graphical Greeter Resolution


I am using FC4 now and I have successfully installed my nVidia drivers and now I get use my usual resolution (1152x864) but I have one small problem.

I have to set the refresh rate at 70hz otherwise my screen shrinks in width and I get like a brown gradient (going from the sides) either side of the actual desktop (the only bit that should be visible). While I am logged in this is fine and easy to change to 70hz (the refresh rate I usually use), but by default Fedora is using the highest refresh available (85hz) which causes that problem. This means my login screen (the graphical greeter I'm presuming) is not using the "correct" refresh rate.

(Just to clarify, the problem isn't the refresh rate causing visual problems it's the fact the greeter is using the wrong one.)

I have looked in /etc/X11/xorg.conf, /etc/X11/gdm/gdm.conf, the pre session, post session, init and post login default (all in the /etc/X11/gdm/ directory) but have not seen anything to do with resolution, let alone the greeter resolution.

Am I on the right track and if not, where should I be looking to change the refresh rate to 70hz for the greeter (or even better... to default).
 
Old 07-12-2005, 10:21 AM   #2
Dudydoo
Member
 
Registered: Sep 2003
Location: UK
Distribution: I use 'em all ;-)
Posts: 275

Rep: Reputation: 38
I've never had to look for it before, but have you tried the Gnome graphical utility that alters the GDM settings?
 
Old 07-12-2005, 10:44 AM   #3
Xyem
Member
 
Registered: Apr 2005
Distribution: Fedora Core 4
Posts: 100

Original Poster
Rep: Reputation: 15
If your referring to the configuration thing that allows me to select the theme etc. for the greeters there is nothing about resolution in there.
 
Old 07-13-2005, 02:07 AM   #4
v00d00101
Member
 
Registered: Jun 2003
Location: UK
Distribution: Fedora 8, Centos 5.1
Posts: 480

Rep: Reputation: 30
You will likely have to set the resolution by hand in the /etc/X11/xorg.conf file.

For instructions, try google, or man xorg.conf from console.
 
Old 07-13-2005, 06:59 AM   #5
justin_p
Member
 
Registered: Jan 2004
Location: Virginia, USA
Distribution: slack 13; I've used it all :)
Posts: 433

Rep: Reputation: 30
as root root type:
gedit /etc/X11/xorg.conf

scroll through and read the comments regarding all the sections. Closer to the bottom you will find the section to edit your resolution. There is also a section to change the default screen size. Alternately, if you are compfortable with the your knowledge of your hardware, you can run as root:
xorgconf
in a cosnle. This will run the CLI tool for setting up your xorgconf. You will be able to enter in the V and H sync as well as the default color depth and resolution. If you elect this option you will have to set up your scroll wheel and DPMS by hand.
 
Old 07-13-2005, 08:17 AM   #6
Xyem
Member
 
Registered: Apr 2005
Distribution: Fedora Core 4
Posts: 100

Original Poster
Rep: Reputation: 15
There is no such section for changing resolution and 'xorgconf' command doesn't exist.

I have included my xorg.conf.

EDIT: Unless I have to include something like 'DefaultRes' or 'DefaultResolution'? I mean put it in manually...

Code:
# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
#	Load  "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#	Option	"Xleds"		"1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
#	Option	"XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#	Option	"XkbModel"	"pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#	Option	"XkbModel"	"microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#	Option	"XkbLayout"	"de"
# or:
#	Option	"XkbLayout"	"de"
#	Option	"XkbVariant"	"nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
#	Option	"XkbOptions"	"ctrl:swapcaps"
# Or if you just want both to be control, use:
#	Option	"XkbOptions"	"ctrl:nocaps"
#
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "gb"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Unisys EVG3100-P"
	DisplaySize  310	230
	HorizSync    30.0 - 95.0
	VertRefresh  50.0 - 160.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
	VendorName  "Videocard vendor"
	BoardName   "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     16
		Modes    "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Viewport   0 0
		Depth     24
		Modes    "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "DRI"
	Group        0
	Mode         0666
EndSection

Last edited by Xyem; 07-13-2005 at 08:18 AM.
 
Old 07-13-2005, 11:31 AM   #7
justin_p
Member
 
Registered: Jan 2004
Location: Virginia, USA
Distribution: slack 13; I've used it all :)
Posts: 433

Rep: Reputation: 30
Here you can change your vertical and Horizontal sync:

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Unisys EVG3100-P"
DisplaySize 310 230
HorizSync 30.0 - 95.0
VertRefresh 50.0 - 160.0
Option "dpms"
EndSection


And here you can adjust your color depth and resolution:

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection


The one farthest to the left is the default. I know the command xorgconf works but sometimes you have to input the entire string for the command. But the graphical tool is usually pretty good in FC. Slackware is where I have set up X with xorgconf. Change those things and restart the X server.
 
Old 07-13-2005, 11:35 AM   #8
Xyem
Member
 
Registered: Apr 2005
Distribution: Fedora Core 4
Posts: 100

Original Poster
Rep: Reputation: 15
Heh I believe somewhere the problem has been lost.

I need to change the default refresh rate. I can't see what to change. I know it's defaulting to 85hz and I want it to be 70hz. Or at least make the greeter use 70hz...

Anyway, I'm not all that knowledge about HSync & VSync and things :P

Last edited by Xyem; 07-13-2005 at 11:36 AM.
 
Old 07-13-2005, 11:38 AM   #9
justin_p
Member
 
Registered: Jan 2004
Location: Virginia, USA
Distribution: slack 13; I've used it all :)
Posts: 433

Rep: Reputation: 30
it should change if you change the V and H sync to the appropriate level for your monitor. Once this is done, restart the X server. If it is still not to your liking go to the Pereferences and to Screen resolution. It should work itself out.
 
Old 07-13-2005, 11:40 AM   #10
Xyem
Member
 
Registered: Apr 2005
Distribution: Fedora Core 4
Posts: 100

Original Poster
Rep: Reputation: 15
Ok I'll try messing with the H & V Sync and try to restrict it. If I blow my monitor up, I'm blaming you... :P

AMENDMENT: Ok I changed my 'HorizSync 30.0 - 95.0' to 'HorizSync 30.0 - 70.0'. This seems to MOSTLY work, the screen isn't going strange but now it's slightly off center, there is a gap of about, half an inch on the left side of the screen. Going to continue fiddling with it maybe get it working 100%

2nd AMENDMENT: I've fixed it, now have another problem. 'HorizSync 30.0 - 60.0' makes the Greeter fit the screen perfectly, but I'm now forced into using 60Hz on everything. Which isn't good because I know this refresh rate gives me headaches & eye problems. I've only been in it for 5 minutes and my eyes are hurting... So I think I need an alternate method of running the greeter in 70hz than forcing Linux to thinking 60hz is the only frequency. Strange thing is, 'HorizSync 30.0 - 70.0' makes it off-center...

Last edited by Xyem; 07-13-2005 at 11:57 AM.
 
Old 07-13-2005, 11:57 AM   #11
justin_p
Member
 
Registered: Jan 2004
Location: Virginia, USA
Distribution: slack 13; I've used it all :)
Posts: 433

Rep: Reputation: 30
The nVidia drivers do that. Adjust make the adjustments with the monitor. Make sure that you know what the V and H sync is for your montior so you don't blow it up. Google for your monitor.
 
Old 07-13-2005, 11:58 AM   #12
Xyem
Member
 
Registered: Apr 2005
Distribution: Fedora Core 4
Posts: 100

Original Poster
Rep: Reputation: 15
I made a second amendment to my previous post.

EDIT: Problem Solved. The greeter uses the highest refresh rate it can. I noticed that even though my upper limit was 70hz according to xorg.conf, I was able to choose, and use, 75hz. It seems to give a leeway of 5hz. So I changed the upper limit to 65hz in xorg.conf and lo and behold, the greeter is using the right one. I could tell this because my screen didn't flicker between that and logging in

Thanks for all your help!

Last edited by Xyem; 07-13-2005 at 06:30 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Creating Graphical Greeter Login Screen BlandoCal Fedora 4 11-03-2006 12:31 AM
graphical greeter crash jlawren7 Fedora 3 01-08-2005 12:33 PM
problems with graphical greeter screen resolution gway600 Linux - Software 3 05-29-2004 02:41 PM
greeter program plerner Linux - Software 5 04-03-2004 11:23 AM
GDMsetup - graphical greeter help tradnbillies Linux - Newbie 0 02-27-2004 02:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration