LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Graphical glitches on boot with PowerMac G5 (https://www.linuxquestions.org/questions/linux-newbie-8/graphical-glitches-on-boot-with-powermac-g5-4175597218/)

UltrasonicMadness 01-11-2017 08:35 AM

Graphical glitches on boot with PowerMac G5
 
I am trying to install an operating system on an old Power Mac G5 (I have tried many other operating systems as well, none of which have worked). Whenever I try to install Ubuntu or Debian on it, the installation will be successful but on attempting to boot the installed system, the screen will graphically glitch out. Yaboot can now boot an installed GNU/Linux system since I moved the Mac's hard drive from slot B to slot A: the startup logs show on the monitor just like on an x86_64 machine, then every alternate frame will be a glitched mess and finally, the screen blanks out. I have tried this with multiple monitors, one of them shows an Out of Range message. This happens whether I install Debian with or without a desktop environment.

I have also tried installing a (burned) Mac OS X 10.5.6 disc from eBay which boots successfully into a graphical environment but does not install due to being unable to extract a file, reporting an error with the installation media. However, I was able to find that the graphics card is an Nvidia GeForce FX 5200 Ultra. I should also mention that I've been using the DVI port and a DVI-to-VGA adapter from Amazon to connect to the monitor.

Thank you for any help
UltrasonicMadness

wagscat123 01-19-2017 07:35 PM

I just saw your thread, and am not particularly keen on your issue, but some pointers I could give you would be to see if some (possibly archival) Nvidia drivers are available, or to see if any Nouveau drivers would work under PPC. You also might want to see https://www.x.org/wiki/ConfigurationHelp/, and maybe mess with your xorg.conf file (maybe post it here)

Also note the flavors of Ubuntu that support 32-bit PPC and Debian 8 will be dropping support for 32-bit PPC in early 2018 and early 2021, respectively.

ondoho 01-21-2017 05:40 AM

fwiw;...
many linux forums have dedicated threads or even whole subsections for apple macintosh hardware.
i suggest you search these (archives most likely judging from the age of your hardware).


All times are GMT -5. The time now is 07:32 AM.