-   Linux - Newbie (
-   -   GPT MBR Mismatch (

NickL 08-20-2011 06:31 AM

GPT MBR Mismatch
I did a very stupid thing and tried to do something myself without waiting for guidance. After adding 2 more HDDs to my RAID card I used the storage manager program to extend the array onto the drives. I then attempted to grow the partition to match but was stymied because after extending the array the backup GPT was in the wrong place. I tried to move it by using

sgdisk -e /dev/sdb1

which only too late I realized was stupid because I needed to run the command on /dev/sdb not sdb1. Anyway, sure enough the system will now no longer recognize the file system. When I run gdisk on the array I get:

GPT fdisk (gdisk) version 0.6.14

Partition table scan:
MBR: hybrid
BSD not present
APM: not present
GPT: present

Found valid GPT with hybrid MBR; using GPT.

Command (? for help): v

Warning! Mismatched GPT and MBR partition! MBR partition 1, of type 0x83,
has no corresponding GPT partition! You may continue, but this condition
might cause data loss in the future!

Identified 1 problems!

Granted, I have all my really important files backed up, but it would be a real pain to lose the non-essential stuff. Is there any way that what I did can be un-FUBAR'd? Any advice at all would be VERY appreciated.


Learning openSUSE

Server - openSUSE 11.4, Asus KGPE-D16 Motherboard, 12x 4GB RDIMM, 2x AMD Opteron 6128, OCZ 30GB SSD (OS), Adaptec Raid 5805Z running 6x Seagate 2TB Barracuda XT in RAID 5 (/srv)

All times are GMT -5. The time now is 02:01 PM.