LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Gnome login error message affecting network (https://www.linuxquestions.org/questions/linux-newbie-8/gnome-login-error-message-affecting-network-258162/)

applemaz 11-22-2004 10:38 PM

Gnome login error message affecting network
 
I have a dual boot (WINDOWS ME / Red Hat Enterprise Linux 3 (Tyroon)) machine where the windows 'Computer Name' is set to AMD850_WINME. When I have the machine connected via ethernet to another computer and then start up the Linux machine, choosing linux at the option screen, I come to the Red Hat login screen and it says: Welcome to AMD850_WINME then asks for username and password. I put in my username and password for one of my user accounts on the linux machine and I get the following message: "Could not look up internet address for AMD850_WINME. This will prevent GNOME from operating correctly. It may be possible to correct the problem by adding AMD850_WINME to the file /etc/hosts." Then I am given the option to try again or log in anyway. I just choose log in anyway.

The machine to which this Linux machine is connected has internet connection sharing enabled so I can surf the web using the Linux machine. However, SMB services seem to be screwed up so I cannot share files. When I try to use Nautilus to browse network services, it says it cannot connect to the SMB master browser. When I look under services, SMB is checked for startup and shows both smbd and nmbd are running.

In addition, when I do not have the linux machine connected to a second machine over ethernet, I don't get this GNOME error. What is going on here and how do I fix it? How does Red Hat Linux know the Windows Computer Name anyway?? That was set under windows and has nothing to do with Linux??

korozion 11-23-2004 04:17 AM

Seems that you just need to add AMD850_WINME to your /etc/hosts file
As in AMD850_WINME 192.168.0.1 or whatever address you have assigned to that system. Basically Gnome (and other programs) needs to know what ip address to call AMD850_WINME

Good luck

applemaz 11-23-2004 07:07 AM

But why do I need to give this in /etc/hosts ??? It makes no sense. This is my windows Me operating system on the other partition of the same hard drive that has my Red Hat Enterprise Linux 3. It cannot connect to it, since both cannot be running at the same time. I must choose one or the other at boot. That can't be the problem.


All times are GMT -5. The time now is 11:34 AM.