LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-17-2018, 01:43 AM   #16
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,616
Blog Entries: 9

Rep: Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094

i'm sure you can remove all but the currently working kernel.
 
Old 06-17-2018, 07:50 PM   #17
jakebob
LQ Newbie
 
Registered: Jun 2018
Location: USA
Distribution: Mint and Linux Lite
Posts: 9

Rep: Reputation: Disabled
After deleting the only other active kernel, shutdown worked perfect... no message about the gnome-keyring. Unfortunately, the message reappeared the next time I shut down the laptop (sigh).
 
Old 06-19-2018, 06:28 AM   #18
gillsman
Member
 
Registered: Mar 2014
Location: UK
Distribution: Mint 18.3
Posts: 192

Original Poster
Rep: Reputation: 35
I always leave two active kernels, that would be the latest one & the previous one, any others can go, this way if your current kernel has issues you can revert to the previous one which presumably worked without issues.
Removing kernels is easiest in the update manager "View" "Linux Kernels" "Right click" "Remove"
 
Old 06-19-2018, 03:41 PM   #19
jakebob
LQ Newbie
 
Registered: Jun 2018
Location: USA
Distribution: Mint and Linux Lite
Posts: 9

Rep: Reputation: Disabled
Hoping this makes sense...

My active kernel is 4.13.0-45. In the update manager > view > kernels, the left column shows 4.4, 4.8, 4.10, 4.11, 4.13 and 4.15. Clicking on any one of those series of kernels then displays the individual kernels in the right column. None of the other kernels with any series is active except 4.13.0.45. I can't delete the others (even if I right-click), the only choice is to install them.

I'll need to read up on kernels because I'm not sure why the most recent kernel (4.15.0-13) isn't the active one (or the one I should be using).

Thanks for your guidance/patience with this "newbie!"
 
Old 06-20-2018, 12:44 AM   #20
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,616
Blog Entries: 9

Rep: Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094
post output of
Code:
uname -rv
please.
 
Old 06-21-2018, 02:11 PM   #21
jakebob
LQ Newbie
 
Registered: Jun 2018
Location: USA
Distribution: Mint and Linux Lite
Posts: 9

Rep: Reputation: Disabled
4.13.0-45-generic #50~16.04.1-Ubuntu SMP Wed May 30 11:18:27 UTC 2018
 
Old 06-21-2018, 07:09 PM   #22
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,616
Blog Entries: 9

Rep: Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094
do you want the newest kernel?
assuming yes:
have you installed it?
have you rebooted?

https://askubuntu.com/questions/2793...-the-boot-menu
 
Old 06-22-2018, 05:06 PM   #23
jakebob
LQ Newbie
 
Registered: Jun 2018
Location: USA
Distribution: Mint and Linux Lite
Posts: 9

Rep: Reputation: Disabled
Success! Thanks for all the help!
 
Old 06-23-2018, 04:49 PM   #24
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,616
Blog Entries: 9

Rep: Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094
Quote:
Originally Posted by jakebob View Post
Success! Thanks for all the help!
and now please give back to the community and tell us (or others who might stumble upon this thread in search of answers) how you did it.
thanks.
 
Old 06-23-2018, 06:02 PM   #25
jakebob
LQ Newbie
 
Registered: Jun 2018
Location: USA
Distribution: Mint and Linux Lite
Posts: 9

Rep: Reputation: Disabled
Turns out this was the second false fix. Originally, there were two kernels installed: 4.13.0-45 and an older one (can't remember which). First, I removed the older kernel and kept 4.13.0-45 active. Upon shutdown, I did not get a "gnome-keyring-daemon not responding" notification and thought the problem was solved. Next time I shut down the system, the notification returned.

On the next attempt to fix, I installed the most recent kernel, 4.15.0-13, and removed 4.13.0-45. When I rebooted, the "gnome-keyring-daemon not responding" notification did not appear. I was hopeful yet again, but the notification returned during the next shutdown.

This leaves me wondering if it is, in fact, a kernel issue.
 
Old 06-24-2018, 05:53 AM   #26
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,616
Blog Entries: 9

Rep: Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094
i suspected that the purging of old kernels is just some voodoo snake oil.

so, back to post #1.
here's a few search results, please tell us if you find something useful:
https://www.startpage.com/do/dsearch...nding+shutdown

also look at post #11:
do you really need gnome-keyring?
i don't use any such software and my system works just fine.

Last edited by ondoho; 06-24-2018 at 05:56 AM.
 
Old 06-24-2018, 08:36 AM   #27
jakebob
LQ Newbie
 
Registered: Jun 2018
Location: USA
Distribution: Mint and Linux Lite
Posts: 9

Rep: Reputation: Disabled
I reviewed some of trouble-shooting suggestions in other forums from the link provided by ondoho in post # 26; nothing I read provided a resolution.

For good measure, I tried the kernel approach one more time by downloading and installing the most recent kernel update (4.15.0-23). As anticipated, that did not correct the problem.

What I DID do is remove "gnome-keyring 3.18.3-Oubuntu2" from the Synaptic Package Manager. I'm not sure how this will affect other aspects of the system, but after a handful of shutdowns and restarts, the message has not returned.

If anyone else attempts this solution, please reply with results. Thanks!

Last edited by jakebob; 06-24-2018 at 08:48 AM. Reason: type-o
 
Old 06-28-2018, 12:27 PM   #28
TappiKid
LQ Newbie
 
Registered: Apr 2018
Posts: 5
Blog Entries: 1

Rep: Reputation: Disabled
This issue just came up for me. I'm new to linux. Dabbled with it till took the plunge and wiped all my hard drive and went to linux Mint Cinnamon 18.3 All was going well with no flags till I installed and set up the Timeshift backup as the final step now all is set up as I like it. Now I get the notice on shutdown (so I didn't shut it down as wanted to read results). I consider myself to know enough computer stuff to do damage (learned much by trial and error) so try to proceed with clear steps. Could it be with the backup set up that is keeping the keyring open? I have all login stuff turned off except for where I make changes in my hard drive. I'm thankful ahead for any and all help!
 
Old 06-29-2018, 05:02 AM   #29
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 14,616
Blog Entries: 9

Rep: Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094Reputation: 4094
welcome to LQ!

Quote:
Originally Posted by TappiKid View Post
Could it be with the backup set up that is keeping the keyring open? I have all login stuff turned off except for where I make changes in my hard drive. I'm thankful ahead for any and all help!
it could be all sorts of things, but switching OFF autologin might help.
apart from that, did you read this complete thread in all its gory glory?
if that doesn't help you, you might want to start a new, dedicated thread with a valid problem description.
 
Old 07-02-2018, 05:53 PM   #30
TappiKid
LQ Newbie
 
Registered: Apr 2018
Posts: 5
Blog Entries: 1

Rep: Reputation: Disabled
Thank you! Yes, I did read the whole thread. The removing kernels seemed like something I'd really mess up but I did go and see how to do it. I don't have a list of old ones sitting there since I've just put all on here. My autologin was already switched off so I switched it back on then restarted (took two restarts before I did not see the open keyring - had read someone else got that too). Then went back and switched it off again and all is going great. I'm very appreciative for all the helps!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
XRDP and gnome keyring constantm Linux - Software 1 04-19-2018 11:20 AM
How to disable gnome-keyring? fannymites Linux - Software 20 09-30-2016 07:09 PM
[SOLVED] Openbox - Autostart gnome-keyring-daemon message. l0p3n Linux - Desktop 1 07-06-2015 11:00 AM
gnome-keyring-daemon couldn't allocate secure memory jrdioko Linux - Software 0 09-10-2011 12:49 PM
Gnome keyring from nowhere fridgitator Linux - Newbie 2 02-19-2008 11:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration