LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Gnome do I need to reinstall? Gentoo (https://www.linuxquestions.org/questions/linux-newbie-8/gnome-do-i-need-to-reinstall-gentoo-403509/)

Tbagz 01-15-2006 01:23 AM

Gnome do I need to reinstall? Gentoo
 
Ofter messing with the frame buffer in the grub.conf I have made gnome not owrk...lol fatal error. Even after taking out the edit or returning it to the original set up I still get the fatal error.

Do I need to "unemerge" and "ermerge gnome" again? or just "emerge gnome" to start over? I am using Gentoo.

Thanks in advance.

acid_kewpie 01-15-2006 02:03 AM

we won't have a clue if you don't even tell us what the fatal error is... we're not psychic!

Tbagz 01-15-2006 11:39 PM

sorry, it is hard to read all the text do to left and right sides of the screen are distorted. the text gets kinda squeezed on the right and cut off on the left.

But I can see... cant run in framebuffer mode. please specify busIDs for all framebuffer devices.

fatal IO error 104 (connection reset by peer) on X server ":0.0"

can that help you all help me?

ylts 01-16-2006 01:50 AM

I had same thing, it means that nvidia driver conflicts with nvidia framebuffer.
Use menuconfig and gompile your kernel without nvidia framebuffer support.
it should be in: device drivers -->> graphics.

Tbagz 01-16-2006 02:52 AM

thanks, I'll try this.

Tbagz 01-16-2006 01:48 PM

ok im in menuconfig but i donot have any of the nvidia drivers selected....

I do have
<*>Support for fram buffer devices[*]Enable video mode handling helpers
<*>Vesa VGA graphics support----->vesafb
[*]support for the framebuffer splash.

Im using an old radeon card like 5700 or something....

Im going to keep it here and wait if someone can rply quick.

but on a side note I think I used genkernal this last time.... I have tried this install 4 times. the problems did not start till I messed with the framebuffer in grub.conf

Tbagz 01-16-2006 08:20 PM

ok I may be getting way off track or getting closer I have no Idea... But I just tried
X -config /root/xorg.config.new

and got back:
Fatal: Module radeon not found
[drm] failed to load kernel module "radeon"
(EE) Radeon(0):[DRI] DRI screen Init failed. Disabling DRI
(EE) xF860 OpenSerial: Cannot open device /dev/mouse
no such file or directory.
(EE) Mouse 0:cannot open input device
(EE)PreInit failed for imput device "mouse0"
no core pointer


fatal Server Error
failed to initialize core devices


So maybe I dont have radeon drivers compiled in genkernel????

can I make menuconfig and take out framebuffer and add radeon??

and how can I see /var/lo/Xorg.0.log ???

I'm sorry I am asking so many questions.... I just need my window manager to work and I would be on my way...lol.

ylts 01-17-2006 05:43 AM

Radeon needs drm in and probably does not conflict with framebuffer:
Device drivers --> Character devices --> direct Rendering manager
If you have it try to modprobe drm before starting X.
for mouse if it is not working have look at my mouse section of xorg.conf
Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Tbagz 01-18-2006 10:42 AM

Quote:

Originally Posted by ylts
Radeon needs drm in and probably does not conflict with framebuffer:
Device drivers --> Character devices --> direct Rendering manager
If you have it try to modprobe drm before starting X.




Well I went to make menuconfig and found what you said above. I added the modules and make && make modules_install so we'll see.:Pengy:

now is there something else I need to do like update commmand or something to that effect?

ylts 01-19-2006 03:49 AM

http://odin.prohosting.com/wedge01/g...adeon-faq.html
Found this gentoo ati faq read it if problems.

Tbagz 01-22-2006 07:51 PM

it's frustrating that knoppix will work fine but I can't get a windows mgr in gentoo.....

ylts 01-23-2006 12:25 AM

post your /var/log/Xorg.0.log lines starting with (WW) or (EE) or with error mentioned and i can probably tell what the problem is.

Tbagz 02-20-2006 01:25 PM

Quote:

Originally Posted by ylts
post your /var/log/Xorg.0.log lines starting with (WW) or (EE) or with error mentioned and i can probably tell what the problem is.


WW open APM failed no such ile or dir

EE VGA(0) driver cant support depth 24

EE screens found but nine have a usable config

thats the only ones with WW or EE at the front.

I am using a ATI radeon 64 MB DDR p/n 1027070300

ylts 02-22-2006 07:43 AM

EE VGA(0) driver cant support depth 24

means you are trying to use vga driver and 24 bit colors and vga driver is not supporting it. If using Radeon 8500 or above install ati drivers and as root run fglrx-config. ati also has instuctions on:
https://support.ati.com/ics/support/...ge&folderID=27

With older open your /etc/X11/xorg.conf and change
[code]Section "Device"
Identifier "My Video Card"
Driver "ati"
EndSection[code]

so you can use opensource ati drivers instead of vga.

EE screens found but nine have a usable config

under Section "Screen" you can set screen resolution and colordepths. Myne is:

Section "Screen"
Identifier "Screen 1"
Device "My Video Card"
Monitor "My Monitor"
DefaultDepth 24
Option "UseEdidDpi" "FALSE"
Option "DPI" "96 x 96"
# Insert Clocks lines here if appropriate
SubSection "Display"
Viewport 0 0
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Defaulting to 1024x768 with 24 bit

you can also copy your xorg.conf from knoppix, it should work(probaly no 3d acceleration tough)

Tbagz 02-23-2006 04:16 AM

Thanks ylts, I am still hacking away at this. I know most of this is USERerror. It is getting so late here I must sleep soon. I will try it and let you know what happened.


All times are GMT -5. The time now is 11:44 AM.