LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-06-2006, 08:29 AM   #1
sarbajitde
LQ Newbie
 
Registered: Sep 2006
Posts: 2

Rep: Reputation: 0
GNOME desktop not loading after trying to log in with root user in RHEL4


Hi there, Well I am quite a newbie to Linux and am running RHEL4 on a system powered by Athlon XP 1800+, ASUS NVIDIA Nforce MB, 640 MBs of RAM and Linux installed on a separate hdd. I installed RHEL4 and had it running successfully for almost a week now. I have set up two more user accounts apart from the root. Now when i am booting up and try to log into the GNOME as root is doesnt work. I am able to log into the same using the other user running and am also able to boot into the KDE using the root login but it dosent seem to be happening with GNOME. After entering the root username and the password I get the blue screen with no splash screen where it should show the components which are being loaded and so finally am not able to get to the GNOME desktop. Would really appreciate any help regarding this issue.

*** I am running the 2.6.9-5.EL Kernel of RHEL4. ***

Last edited by sarbajitde; 09-06-2006 at 09:04 AM.
 
Old 09-08-2006, 01:11 AM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,284

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Perhaps root's Gnome setting are screwed up. There should be a bunch of directories beginning with .gnome in /root that would hold the root user's settings. Try moving them to a backup location and restarting Gnome (forcing it to recreate a profile). This might fix your problem.

FWIW, it's usually not a good idea to run a full fledged X environment as root.
 
Old 09-11-2006, 01:49 AM   #3
sarbajitde
LQ Newbie
 
Registered: Sep 2006
Posts: 2

Original Poster
Rep: Reputation: 0
Hi there,
thanks for the reply. I had booted into KDE and then copied the .gnome directories from /root and into another backup location. Then deleted those directories. Then tried to relogin into GNOME as root but same thing. from the login screen it would go to the screen with Blue background then sometimes the RedHat Enterprise Linux spalsh screen would appear but after that nothing. I am still able to boot into GNOME using other non root user accounts and also as root into KDE. Please HELP !!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome: root desktop applied to user desktop nick1 Linux - Newbie 1 02-24-2006 02:36 PM
cant log into gnome with normal user (only root) nenyo Linux - Software 4 07-22-2005 01:44 AM
loading linux from [root@user root] zagreb Linux - Newbie 1 03-03-2003 06:07 AM
loading mozilla from gnome desktop acid_kewpie Linux - General 2 10-14-2001 09:28 PM
Why does kppp.desktop require root userid for non-root user? rdaves@earthlink.net Linux - Networking 4 08-27-2001 10:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration