Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 09-12-2003, 04:40 PM   #1
LQ Newbie
Registered: Sep 2003
Posts: 2

Rep: Reputation: 0
Question Gnome Desktop Manager logon problem

I have just installed Debian Woody and can not log into XWindow.
Booting up the computer the GNOME Desktop Manager asks for the Username and the Password. When I supply the correct information instead of running the desktop, the same GNOME Desktop Manager window appears again asking for the logon information.
Old 09-12-2003, 05:22 PM   #2
Registered: Nov 2002
Distribution: Slackware 9.0
Posts: 321

Rep: Reputation: 30
Use a bootdisk to boot up in single user mode.

Change the default runlevel in /etc/inittab to 3 (multiuser with command line login), and see if you login works that way.

If not, boot up to single user mode and make sure the drive is mounted rwx. Then just delete that part of /etc/shadow that has root's encrypted password. That way, you can login as root with no password. Set a new password for root immediately with the 'passwd' command.

Old 09-13-2003, 02:37 AM   #3
LQ Newbie
Registered: Sep 2003
Posts: 2

Original Poster
Rep: Reputation: 0
I do not have any problem logging on in text mode. Even the desktop manager can recognize the password, because if I enter a wrong password it warns me. With the right password I do not get any error messages, just the manager restarts.

The first time the Xwindow ran I had to cancel the setup process, because my mouse did not work. Maybe that is the problem.

How can I get a clean start of the xwindow, to run the initial configuration program again?

Old 11-25-2003, 04:26 PM   #4
LQ Newbie
Registered: Oct 2002
Location: UK
Distribution: Ubuntu
Posts: 8

Rep: Reputation: 0
cannot login to gnome

What you need to do is to make sure you have the gnome-session installed. I had the same problem. I first had to upgrade to a newer version of xfree86 then reconfigure X and then make sure gnome seeion is installed. Once I did that I could get to the desktop.

Good luck

"If you fail try something different or read more!"
Old 01-05-2004, 09:51 AM   #5
LQ Newbie
Registered: Jan 2004
Posts: 1

Rep: Reputation: 0
I have the same problem. Did you resolve it?? How??
Old 01-12-2004, 04:39 PM   #6
LQ Newbie
Registered: Oct 2002
Location: UK
Distribution: Ubuntu
Posts: 8

Rep: Reputation: 0
Cool Gnome session

Make sure you have Gnome session and gnome installed with all dependencies. Upgrade your xfree86 packages. You can download the packages from

Once installed reconfigure the xdm or gdm with dpkg-reconfigure command. This should provide you with the correct drivers to get the xserver configured.

I hope it helps, I have reverted to a mandrake installations as I couldnt get to the Debian packages because of the server hack.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
newbie: no shutdown or root login in gnome desktop manager mhelal Linux - Newbie 3 03-21-2005 08:29 AM
How do I exit Gnome desktop manager? BliZZrdLiZZrd Linux - Newbie 4 03-13-2004 08:30 AM
Graphical file manager for non KDE/Gnome desktop Hex29A Linux - Software 8 01-05-2004 11:28 AM
setting gnome as desktop manager dzt Slackware 2 10-28-2003 12:17 AM
I want KDE Logon Manager benjaminrtz Linux - Security 1 07-08-2002 09:56 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:02 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration