LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   glibc-2.2.4.i386.rpm (Red Hat 7.1) (https://www.linuxquestions.org/questions/linux-newbie-8/glibc-2-2-4-i386-rpm-red-hat-7-1-a-71329/)

genoa 07-09-2003 01:28 PM

glibc-2.2.4.i386.rpm (Red Hat 7.1)
 
I need to upgrade my glibc package to 2.2.4 for an installation of another package.

However, after downloading glibc, common and development I attempted to use rpm to install each one and each one gave me a dependency error.

Each one says it needs the others in version 2.2.4 or greater, however if I can't install any of them how am I supposed to provide that dependency?


# rpm -i glibc-2.2.4-19.i386.rpm
error: failed dependencies:
glibc-common = 2.2.4-19 is needed by glibc-2.2.4-19
glibc-devel < 2.2.3 conflicts with glibc-2.2.4-19
glibc > 2.2.2 conflicts with glibc-common-2.2.2-10
# rpm -i glibc-common-2.2.4-19.i386.rpm
error: failed dependencies:
glibc < 2.2.4 conflicts with glibc-common-2.2.4-19
# rpm -i glibc-devel-2.2.4-19.i386.rpm
error: failed dependencies:
glibc = 2.2.4 is needed by glibc-devel-2.2.4-19

Any suggestions?

genoa 07-09-2003 02:55 PM

BTW, --nodeps just spews out a bunch of lines containing files and install conflicts with 2.2.2.

genoa 07-09-2003 03:05 PM

Nevermind. I did a rpm -Uvh and all three package names on the same line and it worked.


All times are GMT -5. The time now is 09:35 PM.