Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 01-27-2005, 10:44 AM   #1
Registered: Oct 2004
Distribution: Red Hat 9-2.4.20-31.9
Posts: 40

Rep: Reputation: 15

i have a rh9 2.4.20-8 kept up-to-date by yum thru Fedora Legacy project., with only a few
non-standard add-ons (alsa sound, winmodem driver, java runtime, jinchess) recently
was trying to install a downloaded game (gnu backgammon) and got error msg:

checking for pkg-config... /usr/bin/pkg-config
checking for GTK+ version 2 or newer... no
checking for gtk-config... no
checking for GTK - version >= 1.2.0... no
*** The gtk-config script installed by GTK could not be found
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
fall back
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
checking for glib-config... no
checking for GLIB - version >= 1.2.0... no
*** The glib-config script installed by GLIB could not be found
*** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GLIB_CONFIG environment variable to the
*** full path to glib-config.
*** You must have installed Glib1 or Glib2 in order to
compile GNU Backgammon

using (rpm -qa |grep -i <...>) i found found packages gtk+-1.2.10-25, glib-1.2.10-10,

my question is: what are GTK+, GLIB, and Glib1 and Glib2 in relation to what i already
have and do i have to install them? thanks for input:
Old 01-27-2005, 11:43 AM   #2
LQ Guru
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 75
You probably need their development packages., which I think are glib2-devel and gtk-devel, in your case also, you need version 1.2x coz there is also gtk2 & glib2 which are incompatible with their 1.x versions.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freerock uninstall stole GTK looking for up-to-date pango, atk, gtk, glib and xft tgz Oholiab Slackware 8 09-18-2005 11:57 AM
glib and gtk + charnel Linux - Software 3 04-13-2005 10:46 AM
Glib/gtk what is it ? i really need him ? SlackwareMan Linux - Newbie 6 07-31-2004 05:56 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM
help with GLIB and GTK BajaNick Linux - Software 3 12-25-2003 05:42 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:35 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration