LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-23-2002, 03:35 PM   #1
MikeeX
Member
 
Registered: Mar 2002
Distribution: Ubuntu 6.10
Posts: 165

Rep: Reputation: 30
glib 2.0


i am trying to update my glib to 2.0 .. because a program im instaling needs it. I have install it the way the readme says, i have also installed gettext and libiconv because it states in the INSTALL that i might need them. So i did.

now after installing glib 2.0 i do

glib-config --version


says i have 1.2.10

what am i doing wrong??



im using slackware 8.0
 
Old 03-23-2002, 03:47 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
glib2 uses the new pkgconfig system, rather than the old gtk-config, glib-config etc... it's more standardised and stuff, one program for all. so glib-config will always base around glib1.

http://www.freedesktop.org/software/pkgconfig/
 
Old 03-23-2002, 03:50 PM   #3
MikeeX
Member
 
Registered: Mar 2002
Distribution: Ubuntu 6.10
Posts: 165

Original Poster
Rep: Reputation: 30
i have donwloaded and install pkgconfig .. now that install went great (sorry i didnt mention that above)

now do i use a pkgconfig command to install glib2.0? or do i do that basic

./configre
make
make install

i thougth that if pkgconfig was loaded it would take care of the rest.

thanks for your help!
 
Old 03-23-2002, 03:56 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976Reputation: 1976
no no, i've not actually used pkgconfig, you'd do *something* like:

pkg-config glib2 --version

instead of

glib-config --version

yeah? I think pkgconfig might need to be properly installed BEFORE installing glib2, and i presume it'll regsiter itself with pkg-config
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 03:35 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
[GLIB] Problems Installing GLIB ThA_eLMo_GoD Linux - Newbie 2 09-04-2004 06:27 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
Problems relating to glib 1.2.10 and glib 1.2.9 p3ngu!n Mandriva 10 05-23-2004 10:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration