LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Git on RHEL5.5 (https://www.linuxquestions.org/questions/linux-newbie-8/git-on-rhel5-5-a-4175412273/)

Latman 06-19-2012 09:07 AM

Git on RHEL5.5
 
Been asked to install Git (latest version) on to our RHEL 5.5 x64 version.
Been searching around to find this, but there seems to be so many versions around and on top of that, I do not know how to download and install it.

Can anyone please assist?

Kustom42 06-19-2012 02:11 PM

Code:

yum install git


---------- Post added 06-19-12 at 12:12 PM ----------

http://www.ralfebert.de/tutorials/git/

Info on git if you want to bookmark it..

knudfl 06-19-2012 04:39 PM

No git-1.7.11 in any repo ?

# yum install git : Version = git-1.7.10.4-1.el5.rf, "rpmforge repo"

http://wiki.centos.org/AdditionalRes...11404998926a1b
( http://ftp.is.co.za/mirror/ftp.rpmfo...6_64/dag/RPMS/ )

.

Kustom42 06-19-2012 06:53 PM

Takes time for recent releases to get added to repositories, could also be a dependency or compatibility issue with some linux distros.

knudfl 06-19-2012 11:43 PM

#4
Quote:

Takes time for recent releases to get added to repositories
It's about Redhat Enterprise Linux (EL 5) : Versions do not change !
( Except firefox and a couple of other packages.)

The most official git for EL5 is git-1.7.4.1-1.el5 from the EPEL.repo :
https://fedoraproject.org/wiki/EPEL

.

Latman 06-20-2012 02:50 AM

Quote:

Originally Posted by knudfl (Post 4707240)
No git-1.7.11 in any repo ?

# yum install git : Version = git-1.7.10.4-1.el5.rf, "rpmforge repo"

http://wiki.centos.org/AdditionalRes...11404998926a1b
( http://ftp.is.co.za/mirror/ftp.rpmfo...6_64/dag/RPMS/ )

.

This is what I get:

]# yum install git : Version = git-1.7.10.4-1.el5.rf, "rpmforge repo"
Loaded plugins: rhnplugin, security
Setting up Install Process
No package git available.
No package : available.
No package Version available.
No package = available.
No package git-1.7.10.4-1.el5.rf, available.
No package rpmforge repo available.
Nothing to do

knudfl 06-20-2012 01:59 PM

Please read how to add the rpmforge.repo ..
http://wiki.centos.org/AdditionalRes...11404998926a1b

The package install command is simply # yum install git
I.e. when the rpmforge.repo is enabled, you will get their version of git :
The package with the latest version number will always be preferred,
when more than one version is available.

.


All times are GMT -5. The time now is 06:32 PM.