LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-15-2003, 06:08 PM   #1
R3N3G4D3
LQ Newbie
 
Registered: Apr 2003
Distribution: Ubuntu 7.04, RedHat 4.4
Posts: 22

Rep: Reputation: 15
gimp+gmplayer started crashing


About a month ago I installed Mplayer on my computer and I've been using gmplayer command all the time and it worked fine. However many of my applications looked different than the rest in skin, after searching online I found out that those applications were using gtk, while the rest were using my kde theme. So I found a program to switch themes called gtk_theme_switch but the 1.0.1 version kept complaining about not being able to find libpixmap.so and then said "Segmentation Fault", so I did "locate libpixmap.so" and after I found the folder I added the url (/usr/lib/gtk-2.0/2.2.0/engines) for the folder to my ld.so.cache and then rebooted and it still gave me the same error. So I downloaded the gtk_theme_switch 2.0rc1 version from the website and it worked fine (except half the themes in the menu had no effect), but when I was finally able to find the theme I liked I applied it, and rebooted and now the applications that use gtk-2.0 work fine (X-chat, gaim) while the ones that use 1.2 version crash. Gimp boots up, but after I select a file to open and click the "Open" button, it crashes, it worked fine before. Gmplayer at first loaded fine too and when I tried to open a file it would crash giving 3 error messages:

message1: MPlayer interrupted by signal 11 in module: unknown
message2: - MPlayer crashed by bad usage of CPU/FPU/RAM.
Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
disassembly. For details, see DOCS/bugreports.html#crash.b.
message3: - MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc
version. If you think it's MPlayer's fault, please read DOCS/bugreports.html
and follow the instructions there. We can't and won't help unless you provide
this information when reporting a possible bug.

now (after a reboot) it jsut crashes as it starts:

me@myPC:~$ gmplayer
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/local/share/locale


MPlayer 0.90rc5-3.2.2 (C) 2000-2003 Arpad Gereoffy (see DOCS)

CPU: Intel (Family: 8, Stepping: 4)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or directory
Reading config file /home/renegade/.mplayer/config
[cfg] read config file: /home/renegade/.mplayer/gui.conf
Reading config file /home/renegade/.mplayer/gui.conf
vo: X11 running at 1280x1024 with depth 24 and 32 bpp (":0.0" => local display)
Reading /home/renegade/.mplayer/codecs.conf: can't open '/home/renegade/.mplayer/codecs.conf': No such file or directory
Reading /usr/local/etc/mplayer/codecs.conf: 50 audio & 136 video codecs
font: can't open file: /home/renegade/.mplayer/font/font.desc
Font /usr/local/share/mplayer/font/font.desc loaded successfully! (206 chars)
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
Using usleep() timing
Can't open input config file /home/renegade/.mplayer/input.conf : No such file or directory
Can't open input config file /usr/local/etc/mplayer/input.conf : No such file or directory
Falling back on default (hardcoded) input config
SKIN dir 1: '/home/renegade/.mplayer/Skin'
SKIN dir 2: '/usr/local/share/mplayer/Skin'


MPlayer interrupted by signal 11 in module: unknown
- MPlayer crashed by bad usage of CPU/FPU/RAM.
Recompile MPlayer with --enable-debug and make a 'gdb' backtrace and
disassembly. For details, see DOCS/bugreports.html#crash.b.
- MPlayer crashed. This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your gcc
version. If you think it's MPlayer's fault, please read DOCS/bugreports.html
and follow the instructions there. We can't and won't help unless you provide
this information when reporting a possible bug.

And when I try to open up a file (picture) in Gimp it sends this to konsole:

gimp: fatal error: Segmentation fault

It also did the same to my Opera browser, when I type "opera" in command line to open it up it says:

/usr/bin/opera: line 138: 4293 Segmentation fault "${BINARYDIR}/opera" "${@}"

I'm guessing that all these applications use gtk and not gtk-2.0 cuz gtk-2.0 ones work great, and the theming worked on them. Please tell me how I can fix this and preferrably skin them with something other than the ugly default skin. Thanks.
 
Old 05-16-2003, 01:05 AM   #2
R3N3G4D3
LQ Newbie
 
Registered: Apr 2003
Distribution: Ubuntu 7.04, RedHat 4.4
Posts: 22

Original Poster
Rep: Reputation: 15
Hmm, apparently a full system shutdown and start up afterwards got rid of all the segmentation faults. So now Gimp seems to work fine, and opera works great too, still have a problem with gmplayer, it's a new one though. I type gmplayer and it starts up fine, open file and the file opens up, but when it starts playing it freezes on 0:00 secs and jsut shows the starting frame. I tried switching video modes, doesn't help. It doesnt give any errors, and sends no errors to console either, but it just freezes, hitting play button several times doesnt do anything either. Could some one help me with this, and also tell me how to change themes for applications that use gtk and not gtk-2.0 because gnome2 control center (I don't think you can even call it a control center anymore) only modifies gtk-2.0 stuff.
 
Old 05-16-2003, 05:25 AM   #3
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
The simple way to get around this problem is to upgrade to apps that use GTK2. AFAIK virtually all GTK1 apps except XMMS are being ported or have been ported. You might need to upgrade to the very latest versions to get them though.
 
Old 05-16-2003, 11:39 AM   #4
R3N3G4D3
LQ Newbie
 
Registered: Apr 2003
Distribution: Ubuntu 7.04, RedHat 4.4
Posts: 22

Original Poster
Rep: Reputation: 15
the thing is neither gimp nor mplayer use gtk-2.0, I checked both sites, they both use the first gtk (even the most current versions of them, and I think I got the most current ones anyway). Also my mplayer started working fine again, weird.

Last edited by R3N3G4D3; 05-16-2003 at 11:41 AM.
 
Old 05-16-2003, 01:59 PM   #5
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 47
The next version of the GIMP uses GTK2, the 1.3.x series - not quite as stable as 1.2.x yet but still pretty good
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
printing on HP PhotoSmart from Gimp 2.2, gimp-print drivers needed? pearman Debian 2 08-05-2005 05:19 AM
gimp / gutenprint prob: gimp does not print bitpicker Linux - Software 0 04-08-2005 08:38 AM
gmplayer doralsoral Linux - Software 4 01-07-2004 11:36 AM
gimp (1.3.21) and gimp-perl - need help installing gimp-perl keex Slackware 0 10-22-2003 04:54 PM
Can I load GIMP in english ? (only gimp) Dark Carnival Linux - Software 4 09-17-2003 06:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration