-   Linux - Newbie (
-   -   Getting X to work (

easy 10-09-2003 12:19 PM

Getting X to work
I downloaded debian cd-1 and burned it, then I installed it on my old comp. The installation did well, until it came to the X-thing.
It said that I was supposed to switch cd, but I thought that everything were on the cd I used, so I continued with it.

A lot of errors occured, and when I'd finished the installation, and rebooted, X didnt work. It still doesn't, the message I get when it has failed is "X is not properly configurated" or something like that. It also says something about some configuring-files that are missing.

So, my question to you guys is if you know what may be the flaw here? I'm really greatful for any information, though I'd like if you are 99% sure of what you're talking about :) Dont take that last senctence as I'm against help from other "new" people, cause I'm not, but it'd save both you and me time if I get help from a person who knows what he/she's talking about.

Thanks in advance!


bigjohn 10-09-2003 12:42 PM

God, it sounds like quite a few people have had similar symptoms, to what happened to me about 3 weeks ago.

Anyway, I didn't download it, I bought a dvd. It installed OK, but when I booted it, it would get as far as started X etc and no further. It would drop me into a system command input.

In my case, an aquaintence (who also happens to be a deb developer), came round and configured it all for me.

He confirmed a few things.

I had got the woody dvd. OK

My graphics card is an nvidia geforce 4 m420 (not exactly cutting edge, but reasonably current). OK

It transpires that nvidia drivers do work, but woody only seemed to have stuff for cards upto and including geforce 2 - The nvidia site has got drivers that work, but they aren't "gpl'd" so not included with the debian disc. OK

It also transpires that the nvidia drivers aren't supported by the 2.2.xx default kernel that installed with the woody, but they work with 2.4.xx kernels (or so I understand).

I ended up having to work out how to use "Lynx", the text only browser (which was installed by default) then going to the nvidia site and getting the driver (though I didn't know what to do next). When Steve came round, he checked over what I had done, and the first thing he did was to do a dist upgrade with apt-get (to sarge, which installed a 2.4.xx kernel by default), then he unpacked the nvidia driver and installed that, then he did some configuration of X (xf86config I think, It was all getting rather over my head and I could only watch!:D).

This got it all up and running (basically), because it took me ages to work out how to get it to play audio disc's and get system sounds working. Which I did eventually manage.

While all this was going on, I decided to check out knoppix (another aquaintance from the LUG had given me a copy of 3.1). Knowing that knoppix is debian based, I ran it from the disc, and it recognised and configured all my hardware and gave me a few clues about the sound problem (i.e. that I needed the "ide-scsi" module to use the cdrw that I've got, and some other bits and bobs).

What it did do, was show me a better view graphically, than what I had managed to do myself, show me an installer that worked seemed a lot better than the manual stuff that I had managed to work out, and a mega easy way to getting my "network" configred, and the package selection with knoppix is better than what I knew about i.e. I was able to do nearly all the stuff that I can do with my mandrake install.

I persevered with normal debian for a while, then eventually I did a "hard disc install" of knoppix over the top of the normal debian sarge - which basically gives you a normal debian install with a few differences. I'm very pleased with it.

So I don't know if any of this will be of any help, but it may point you in the right direction (I know that my post may be a little too general for what you need to do!), but hopefully it helps



p.s. the only problem that I have actually had, is getting the knoppix/debian to boot from my hard drive, but that's because I "multi-boot" with XP and mandrake as well - and it's the mandrake install of lilo that I use.

easy 10-09-2003 12:53 PM

Thanks for your answer, John!

I read your post, and I found it interesting, but still not very helpful for me. I have no idea which videocard I got (anyone know how you get to know that?), and I'm a so total newbie at this, that I don't even know how to get out on the internet! This is why I really need X, as I understood it it's a little more like Windows in the way that it's graphical and more user-friendly than a clear command line.

So, anyone got helpful advice to give?

(thanks again for the answer, John!)

bigjohn 10-10-2003 03:29 AM

Ha, I see what you mean.

If you have access to the net somewhere, then maybe you could either download or buy a copy of mandrake from one of the cheap disc's sites.

This could help especially if this is your first "foray" into linux. Mandrake is definitely easier to start off with, then once comfortable with it, give the debian a try. Or, follow the knoppix route, that's only one disc, the mandrake route is 3 for the "whole kaboodle", and if it's debian you've set your sites on, then the knoppix route would be better, because if your machine can run it (you just put the disc in, boot the machine and off you go) then you just follow the instructions for the hard disc install.

What ever happens, getting net access is dependant on your modem/method of access. If you have dial up access, then you WILL need to check the modem too see if it's a winmodem - some work (well, you can get the drivers for them), but a lot of them won't. If it's some sort of dsl or cable, then you've got more chance in connecting, i.e. my setup is an external modem/router for adsl and I've installed a NIC ethernet card, so even when I tried the debian sarge, during install, it asks for network configuration details and it meant that I could get online without graphical access using lynx to get the nvidia driver I needed.



All times are GMT -5. The time now is 06:27 AM.