-   Linux - Newbie (
-   -   getting USB attached printer going (

servnov 07-13-2005 06:47 PM

getting USB attached printer going
I just got a new printer for another computer of mine. Its an HP and I found all the drivers included in CUPS when i did setup via localhost:631. I have setup printers before with CUPS but only parallel port ones. CUPS shows USB ports to select from, but the printer just sits there, although CUPS says 'idle, accepting jobs'.

How can I get it working, it seems I am so close, and I know CUPS has the driver for it, since I found it during setup?

I have also tried 'lpr fubar.txt' and couldnt find the job in the print queue with lpq nor did anyting print :(

OrganicOrange84 07-13-2005 08:19 PM

Hmmm.... not that I would know particulary, but might it just might be looking in the wrong place? I don't know, but you could try all the following ports, er device names.


I had the problem too, with the printer telling me it was idle and accepting jobs, yet it would just sit there. I played with all these names for the device and for me the /dev/usb/lp0 worked. I don't know but MAYBE it will work. I hope so. That's in my minimal experience anyway. :)

servnov 07-20-2005 04:31 PM

Thanks for the response. How did you get them to work? In CUPS i get something like this:

Parrallel port
Serial 0
Serial 1
Serial 2

I think for serial and USB it goes up to 15 and I also have ipp and a couple other options. If I choose anything except USB 0 (like USB 1, etc) it gives an error telling me no device there. And nothing gives errors or complains with USB 0, it just doesn't print just sitting there (begging me to give up and install it on win32 haha :-P)

I tried chmod 755 /dev/usb/lp0 but no difference. I figure if its showing up in CUPS permissions isn't the problem anyway.

All times are GMT -5. The time now is 01:59 PM.