LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-19-2003, 10:10 AM   #1
Bill Hicks
LQ Newbie
 
Registered: Sep 2003
Posts: 21

Rep: Reputation: 15
getting in to xf86config


I would like to know how to get in to the xf86config file to change my monitor settings. well the problem is that when i load linux (redhat 9), just when it gets to the login screen my monitor switches off.

so..

when do you (exactly) write in xf86config??
 
Old 09-19-2003, 10:14 AM   #2
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
better use the 'xf86config' utility to edit the X config file.
 
Old 09-19-2003, 10:15 AM   #3
Bill Hicks
LQ Newbie
 
Registered: Sep 2003
Posts: 21

Original Poster
Rep: Reputation: 15
how?
 
Old 09-19-2003, 10:24 AM   #4
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
I think my post in http://www.linuxquestions.org/questi...threadid=94121 explains it all.
 
Old 09-19-2003, 10:40 AM   #5
mikeb222
LQ Newbie
 
Registered: Sep 2003
Location: Woburn, MA
Distribution: Mandrake 9.1
Posts: 25

Rep: Reputation: 15
If you made a boot floppy during the install process-
boot from floppy, log in as root, then enter the xf86config

If you don't have a boot floppy you might be able to short-circuit the process by doing a CTRL+ALT+F1 before the XFREE86 server loads.

Last edited by mikeb222; 09-19-2003 at 10:42 AM.
 
Old 09-19-2003, 12:46 PM   #6
Bill Hicks
LQ Newbie
 
Registered: Sep 2003
Posts: 21

Original Poster
Rep: Reputation: 15
I can not login, my monitor goes off before the screen appears
 
Old 09-19-2003, 12:51 PM   #7
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
When you boot up,if you are using grub, edit your kernel parameters(by pressing 'e') by adding a '3'.if you are using lilo,try boot:linux 3.
http://www.redhat.com/docs/manuals/...ing-single.html explains how to enter single user mode.just replace single in this doc with 3 to enter multy user textmode.After entering it,just try a 'startx'.you may get some errors.then check out your /var/log/XFree.0.log forerrors(they start with ee).post them here.you can try reconguring X (the config file is /etc/X11/XF86Config or /etc/X11/XF86Config-4.the -4 will override the other one if both are there.you can see the name in your log file) using 'redhat-config-xfree86' or xf86config.
If you cant clear the problem post your /var/log/XFree.0.log and the X config file.(see the log file to see whether it uses -4 one or the other).some one may be able to help you out from this.
once again,
X config file is /etc/X11/XF86Config or /etc/X11/XF86Config-4.
X startup log file is /var/log/XFree.0.log.
use texteditors like 'pico' or 'vi' from textmode.
use utilities like
'redhat-config-xfree86' or 'xf86config' to reconfigure X.
ps:It will be better if you delete all your X log files,i.e,
'rm /var/log/XFree.*' before trying 'startx'.
 
Old 09-19-2003, 12:52 PM   #8
mikeb222
LQ Newbie
 
Registered: Sep 2003
Location: Woburn, MA
Distribution: Mandrake 9.1
Posts: 25

Rep: Reputation: 15
so you are not getting any of the boot up confirmations?
you see none of the detection process going on, none of the services being confirmed as good or bad?

or

does it go off at the graphical log-in
 
Old 09-20-2003, 06:31 AM   #9
Bill Hicks
LQ Newbie
 
Registered: Sep 2003
Posts: 21

Original Poster
Rep: Reputation: 15
It goes off in graphical mode.

arunshivanandan -

I got linux to run in runlevel 3, when i started startx my monitor goes off, i put it back on by using <ctrl> <alt> <f1>. it stated that it had made the file /var/log/xfree86.0.log.
but when i type this in it tells me that the directory is invalid for this and the config file.
 
Old 09-20-2003, 08:34 AM   #10
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
Quote:
but when i type this in it tells me that the directory is invalid for this and the config file.
what you mean by 'typing'.I assume you are saying abt simply typing this and pressing enter.use more or less or cat to viw the file-
like
more /var/log/XFree.0.log
also,you can use text editors like vi.(I have posted some common linux commands here in http://www.linuxquestions.org/questi...threadid=94488)
 
Old 09-20-2003, 08:42 AM   #11
Bill Hicks
LQ Newbie
 
Registered: Sep 2003
Posts: 21

Original Poster
Rep: Reputation: 15
sorry, i used vi on both at different times;

vi /var/log/xfree86.0.log
vi /var/log/xfree.0.log

the vi program shows nothing in them and placing [NEW FILE] after the directory at the bottom of the screen.
 
Old 09-20-2003, 09:14 AM   #12
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
make sure that the correct name is typed.(dont forget that ;inux is case sensitive).i.e-did you try xfree86.0.log in small letters??i guess it would be XFree.0.log or XFree86.0.log.also,try cd to that directory(cd /var/log) and type 'ls' to view all the files there.
 
Old 09-20-2003, 09:41 AM   #13
Bill Hicks
LQ Newbie
 
Registered: Sep 2003
Posts: 21

Original Poster
Rep: Reputation: 15
Ah, i did not know that it was case sensitive. i can not try it now, i will tomorrow. if i can get in to the file i will post the error up on here.
 
Old 09-21-2003, 09:50 AM   #14
Bill Hicks
LQ Newbie
 
Registered: Sep 2003
Posts: 21

Original Poster
Rep: Reputation: 15
I have no [EE] files in my log. So i tried the config file.

xf86cofig did not work, it said that the directory was invalid but the comand 'redhat-config-xfree86' worked.

When it started my mointor once again switched off. i used <ctrl> <alt> <f1> and it told me that it was getting bogus readings.

monitor: none
Hsync: none
Vsync: none

What should i do now??
 
Old 09-22-2003, 01:19 AM   #15
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
'xf86config' is the command and it should work.make sure that you entered the name correctly.
monitor,Hsync and Vsync values can be obtained from your monitor manual.if in doubt,choose a conservative setting.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
root@localhost:~# xf86config -bash: xf86config: command not found klemen Slackware 17 01-06-2005 03:56 AM
where is the XF86config-4 or XF86config file in the fedora? u2911 Fedora 4 07-24-2004 09:38 PM
where can I find the XF86Config and XF86Config-4 files? souaw Mandriva 4 04-21-2004 10:30 AM
XF86Config compared to XF86Config-4 rberry88 Linux - Newbie 2 09-21-2003 11:29 AM
Diff btw XF86Config-4 and XF86Config BorgKing Linux - Newbie 1 06-12-2002 02:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration