-   Linux - Newbie (
-   -   Getting F keys to work in terminal emulation (

wideyes 01-28-2010 02:28 AM

Getting F keys to work in terminal emulation
Hi guys. I'm running Debian (both Sarge and Lenny, on different systems) under Gnome and have a number of thin client workstations that connect to a software application on an AIX server. I'm using gnome-terminal to provide terminal emulation for this software. Unfortunately, the emulation leaves something to be desired, and doesn't catch all of the F keys properly. It seems F1-F4 act as some form of escape key, exiting out of the software back to the command line, when they should be performing different functions in the software. F5 and F6 work as they should in the emulation. Is there a setting I can apply to my gnome-terminal launcher that will make this behave like it I want? The terminal should ideally match the behavior of a Link MC5 terminal (we have some of these old beasts still around, still crunching away), but alas, I don't know how to implement this. Please advise me on any additional data I need to provide, and how to modify this behavior.

wideyes 01-28-2010 01:59 PM

So I've come to realize that what I'm looking for is VT100 emulation. I'm now trying to get gnome-terminal to run in vt100 mode. Anyone have any insights into this?

wideyes 02-01-2010 01:34 PM

Well fine. I thought this was a newbie forum (i.e. you don't get ignored for asking a simple question), but anyway, I discovered that I got the results I was after if I used xterm instead. I run xterm with the -e flag to execute the command 'export TERM='vt100'when the terminal first starts. xterm has millions of options - probably the longest manpage I've seen yet!

All times are GMT -5. The time now is 07:33 PM.