-   Linux - Newbie (
-   -   Getting Ethernet working... Slackware box, uber-newb. (

Diademed 07-24-2004 03:21 PM

Getting Ethernet working... Slackware box, uber-newb.
Well, in dmesg, it states


00:0a.0: 3Com PCI 3c905 Boomerange 100baseTx at 0xb800.  Vers LK1.1.18-ac 00:60:08:a1:39:61, IRQ 5
and then a paragraph of stats for it... but 2 lines down, it says

eth0: Dropping NETIF_F_SG since no checksum feature.
I also have another card in there at 0xb400, mostly the same card, same model number, at eth1, and it says the same no checksum...

I'm trying to set this up with DHCP comcast internet, and having no luck... can anyone help?

Tell me what you need, I'll slap it on.

osvaldomarques 07-24-2004 05:16 PM

Hi Diademed,
Are you using kernel 2.6. I did some google with your error message and is plenty of posts for 2.6 with this card. If you have 2.6, try boot with 2.4. Post us your results.

Have a funny week end!

Diademed 07-24-2004 05:43 PM

I imagine it is 2.6

It's the kernel off the Slack10 disk--, so I imagine it would be the latest...all right, I'll try, thanks

btmiller 07-24-2004 06:24 PM

Slackware 10 ships with both 2.4 and 2.6 kernels -- do "uname -r" at the command line and see what it says.

Diademed 07-25-2004 01:56 AM

Sorry, it's 6.4.26.

Diademed 07-25-2004 02:39 PM

EDIT: It stopped working. Disregard this post. /EDIT

I got it working!!!

For those of you in the same situation try this....

The first thing I'd want to do is get my network going (if it isn't already). The netconfig utility that ran during setup, could not probe for my network adapter. However, I know that it uses the sundance module. How did I know that? Well, when I first bought those NICs, I typed D-Link 530TXS Linux (the "S" is significant in the model number) into a search engine (Google) and found the tidbit I needed in mailing list archives and the like.

Now, during setup we configured our network with the exception of the driver module for the network adapter. That means, all we have to do is load the module, and start the network. Slackware's startup scripts look for a script file named rc.netdevice in the /etc/rc.d directory. This is where the system init scripts are located on Slackware system. (It uses the BSD style init script mechanism)

It is very easy to create this file from the command line. As root, type:

echo "/sbin/modprobe sundance" > /etc/rc.d/rc.netdevice

This will redirect the output of the echo command into the specified text file that will get created. The quotes are important, because there is a space in the string we are echoing. Use the correct module name for your network adapter, of course.

Now, set the file executable:

chmod 755 /etc/rc.d/rc.netdevice

That's it, on the next reboot your network should initialize.

Alternatively, to load a network adapter module, you could uncomment the appropriate module loading line (or add one) in the /etc/rc.d/rc.modules init script.

Now, I don't feel like rebooting at the moment, so I'm going to just type a few simple commands to start the network.

I'm loading the module, then using the ifconfig utility to specify the interface, IP address of the machine, and subnet mask, and then using the route command to specify my router as the gateway.

You probably will want to attempt to start the XFree86 GUI now. By default, Slackware is set up to use the VESA Framebuffer driver for your display hardware. The /etc/X11/XF86Config file is a copy of the file XF86Config-vesa in the same directory.

So if you type startx you may have a usable GUI if the settings are compatible with your display hardware. That will do in a pinch, but you will want to properly configure XFree86 and use the accelerated driver for your video card (which hopefully exists, otherwise you've got some generic options)

All I did was switch his Sundance module for the 3c59x module that is compatible with my card, rebooted, and ping'd, and now on tty1, the ping command is running... still... I can't figure out how to shut it off.....:scratch:


btmiller 07-25-2004 05:12 PM

Control+C sends SIGINT to the ping program, shutting it down (this works for most other programs). Good that you got it working :) .

Diademed 07-25-2004 11:09 PM

Thanks--I tried everything I could think of... Break, ctrl+alt+break, ctrl+break, esc, ctrl+esc... etc...

Nothing worked. Of course it would be something simple like that. Good to know!:rolleyes:

Diademed 07-27-2004 05:16 PM

I take everything back. It stopped working. Back to square one. Any thoughts on why it started, then stopped....?

btmiller 07-27-2004 05:49 PM

Did it stop working after a reboot? If so, your driver module probably wasn't initialized correctly on boot. Since the sundance module worked for you, what does "modprobe sundance" give you now? After you modprobe does ifconfig show eth0?

osvaldomarques 07-27-2004 10:57 PM

Hi Diademed,
All you need to load the proper driver for your ethernet is to enter

alias eth0 3c59x
in the file "/etc/modules.conf". After you do this, you have to enter

depmod -a
to activate this configuration change. Your network configurations on slackware must be in a file named "/etc/ rc.d/rc.inet1.conf", at least in slackware 9.1 which I have installed.
The rc.netdevice must be conceived for any special driver, may be wireless, as the normal ethernet cards are properly recognized by the kernel and may be treated at "/etc/modules.conf" or at /etc/rc.d/rc.modules.

Diademed 07-28-2004 12:55 PM

I use the 3c59x module, not the sundance module, but I sort of thought that the modprobe was a temporary fix.

Anyway, thanks, you guys, I hope this is a permanent fix! :cool:

One thing.... my modules.conf file said something to the effect of "GENERATED BY ALSACONF DON'T EDIT", But I ignored that and made my changes anyway. I do not expect any drastic consequences, but should I ?

Thanks again!

qwijibow 07-28-2004 01:07 PM

nope, modprobe is vital tool for loading drivers and modules.


Sorry, it's 6.4.26
kernel 6.4.26 wow...
was Doc right ? do time machines have flux capacitors and time circuits ?
i take it linux survived all this software patent crap. is windows still around ?
what are Nvidia GeForce12's like ?
does kernel 6.4.X support quantum CPU's ?

Diademed 09-16-2004 11:34 PM

:D I musn't say.... might cause a rift in the space-time continuum, you know...

Now be nice or I'll go back farther and marry your mother. :p

All times are GMT -5. The time now is 08:18 PM.